Warning: Your graphics device has encountered a problem

For those with this issue, did doing a DDU cleanup help at all?

same problem here with the last two revisions of the the driver and gpu temps never exceed 58c 4090

I didn’t have this bug for months…now is back again

Is it because the update has reinstalled the old nVidia .dll’s?

Ive just had a crash as well. I had forgotten to replace them with the newer more up to date versions after the update.

Can the mods not pass this on to the devs? The game should be shipping with the latest .dll’s by now. There’s really no excuse

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

Flight launches fine, and about two minutes into the flight I get the same error message and the game freezes. Drivers were updated to the latest version prior to installation of the update.

Are you using DX12?


Are you using DLSS?


If relevant, provide additional screenshots/video:

That is very interesting. Cause this bug seem very irregular. I want to ask you some questions:

  1. How often do you play?
  2. How often do you update your graphics drivers?
  3. When did it come back for you? The latest WU, or did you update to latest nvidia driver?

Does games even replace graphic drivers? Doesnt make sense at all?

I’m not talking about the drivers, I’m talking about the dlss .dll’s. MSFS ship with old ones and v1.0.1.0 (of the frame gen .dll) always causes this crash for me

This problem continue with Oceania Update.

  1. Quite often
  2. When available
  3. It happened soon after the Oceania update

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:


This has been happening for me for about 3-4 weeks. Never had this message before. Every flight I run it gives me the same message after about 2 hours of flight time. 2080 Super using Nvidia Experience optimised settings. If I roll back to two GeForce versions ago (forgot the version number) it works fine however.

It’s annoying having to roll back just for one game in my library. I hope it’s fixed soon.

All forums are flooded with this problem with the exit from the game due to overheating of the video card.
Do you really believe it’s not the game?
I rolled back the drivers to the previous version, and reduced the simulator settings to the minimum without addons.
I have Radeom RX590 graphic card - and maximum temperature for as 85 C.
Why game crased on 76 C?
Spontaneous crashes - developers, will you fix the simulator ???


Rolled back the drivers to version 531.29 (from official Nvidia cite). No more any CTD’s teel now. Check version of your’s drivers.


I have Radeom RX590 graphic card

the game determine a problem ( any kind of ) and stop the game before its crash :slight_smile:

Therefore checking the event log about existing error messages is important.

I switched back to DX11 after my first notice of this problem and have not had it since. That’s not a guarantee that DX12 was the cause, as I have been using DX12 without issue for a long time.

It’s nothing to do with overheating but everything to do with video memory clockspeed and data source synchonisation. Tolerances are limited so if you happen to overclock your gpu then you’d best be certain that the rest of your system can present multiple data streams in an uninterupted fashion.

I just got this error message.It might have to do with my GPU set to oc mode which I normally have disabled.

Thought I’d try 531.68 today. Not getting the crash and ‘graphics message’ but it’s quite stuttery, not as smooth as 528.49… so I’ve gone back to that one. DX12 seems to be better than DX11 for me. Great advice given to me was to clear the shader cache after changing a driver.
3080, Ryzen 9 5900X, 32 RAM. (Quest2).

I just rolled back to 531.68 and am still getting the graphics message. Only got it once or twice with the previous MSFS versions. Since sim updated yesterday MSFS is crashing 100% of the time. GPU memory usage is maxed or nearly max’ed out continuously since sim updated. It is now never lower than 10+GB, even at alt. Previously it would spike (10GB to 11GB) at high demand scenery but at alt would hum along around 7GB to 8GB.

I’m going to try going back to 528.49 as you have and see what I get. Aside from that, I see the notice that ‘This topic has been resolved’ as I’m typing. Could someone please tell or point me to the prescribed ‘resolution’?