Weird lag with tobii eye tracking - frame gen issue?

Hi All,

I think I’m starting to go down a rabbit hole here and need some help to try and get out of it.

The other day I felt that I was experiencing some odd lag when using the Tobii head tracking (I’ve disabled eye tracking) in the sim. The panning movement just felt “off” and I couldn’t understand why.

I switched on the debug console FPS tracker and noticed that my FPS are somehow being locked to 58FPS and I’m sure that never used to be the case. I’m using frame gen, and I’m aware that the in-sim FPS counter is not able to detect the extra generated frames, but I’m sure that I used to get a higher “native” FPS than that! For reference I’m parked at my local airfield in the C172 so the sim is not stressing my hardware.

My sim settings are:
Frame Gen On
TAA
Reflex On
VSync off
DX12 Beta

My Nvidia CP settings are:
Vsync On
Latency Reduction Ultra
Frame Limit 117FPS

My system is:
Core i9- 14900K
Gigabyte 4090
64 GB RAM
Tobii 5

My screen is an LG OLED C3 120Hz display.

Can anyone help me with this? Should I be seeing a higher FPS than what the in-sim FPS counter is showing? Am I going mad? I’ve started playing around with settings in the sim and Nvidia CP and I think that is just making things worse…

If I switch Vsync off in the Nvidia CP I get better native FPS but really bad tearing when I switch on Frame Gen and I really dislike tearing!

I hope someone can save my sanity :slight_smile:

Even though you have Vsync de-selected in the Simulator, by turning it on in NVIDIA Control Panel, this should lock your frame rate to maximum refresh rate of your monitor. So if the debug console is saying you are locked at 58FPS, that will be your true FPS in the sim, NOT factoring in the gains from Frame Generation. If you want to see your FPS with Frame Generation, you can use the NVIDIA Performance Overlay.

It could be that whilst doing aggressive head movements with the Tobii, the simulator wasn’t able to keep up with the fast motion and could have caused some stutters.

I’m currently using a Tobii Eye Tracker with a 4090, and have a 60Hz monitor, where it is pretty buttery smooth for me, but I do try to keep my head movements smooth too!

I hope this helps :slight_smile:

1 Like

Thanks for the reply. When I disable Vsync in the Nvidia CP I get 70-80 FPS in the same spot, so my system is definitely capable of more. My understanding is that because my screen is a Gsync screen, it should be able to run at that FPS with no tearing (thanks to GSync) then FG can take that value and run with it to wherever it can get to?

My confusion is why Vsync on my 120hz screen is locking to just under 60FPS. I have checked and windows and NVCP are both set to 120hz in the monitor settings.

Edit: I should also add that the frame rate graph in the in-sim FPS counter is green and completely smooth when Vsync is on - when I turn it off it’s more variable and sometimes goes red. This confirms to me tha the system has plenty of headroom still at 58FPS.

The GPU maybe, but the CPU is probably the bottleneck.

Perhaps. However, if the CPU was bottlenecked (and it’s running at 6.2GHz so I’d be suprised if it was bottlnecked at a rural airfield with no traffic) then how come I can achieve 70-80FPS with Vsync off?

On this issue – I’ve tried using the AMD version of frame generation with my TrackIR head tracker and found that there’s some input lag introduced by the necessary frame-by-frame calculations, which felt off to me. I imagine this would be similar when using the Tobii for head tracking, and perhaps worse with the eye tracker part.

This is an inherent issue with frame generation technologies, because they require two frames’ worth of data to create an interpolated frame.

Either you’ll get used to it, or it’ll keep bugging you. :slight_smile:

Appreciate the post! The odd thing is that I’ve been using the Tobii for a few months now and it’s only over the past few days that things have felt “off” - I wonder if it’s actually my brain that has changed! (that’s not a good thing! :stuck_out_tongue:

1 Like

Where are you looking at your FPS? If you are reading 58FPS in MSFS, with FG on, Vsync on, and you set your frame lock to 117FPS, this is why you are reading 58FPS in MSFS. It is working correctly with FG enabled and if you check your frame rate externally with XBOX Game Bar you will see you are running at 117 or so FPS (your locked frame limit, synced to your monitor refresh rate). MSFS cannot account for the generated frames as this is done within the GPU. Stop getting hung up on getting more frames in MSFS with Vsync off. It looks worse with Vsync off at 70 to 80 FPS in MSFS because with FG that puts your frames at 140 to 160 which your monitor cannot attain and your frames are no longer synced. The max it can attain is 120FPS.

You should be running with Vsync on in the NVCP with your above posted settings and turning off Gsync if you are maintaining 58FPS in MSFS. Gysnc is of no benefit to you in MSFS in this case and in fact can cause issues if your frames drop to low. It also causes flickering in certain situations.

It appears to me that you may not exactly understand how frame generation works within MSFS. Hope this explanation helps a you a bit to understand. If you are really maintaining that 58FPS in MSFS with FG enabled and Vsync on, you should have a buttery smooth experience with a once in awhile FG anomaly.

Thanks for the post! I was already aware that the internal FPS counter does not recognise the FG frames, but thanks to you the penny has finally dropped - Vsync IS capping to just less than my screen refresh rate but that INCLUDES the frame gen’ed frames! I had previously thought that the NVCP VSync was working on native frames (in the same way that MSFS does) but see now that it must be FG-aware. That makes total sense now.

I’m interested about your comment regarding GSync though. My understanding is that it prevents torn frames by syncing the refresh rate of the screen to that of the GPU. Let’s say that I’m getting 105FPS (including FG) at a busy airport in the PMGD 737 (the 58FPS lock is when I’m at a rural airfield in a C172), won’t I be getting torn frames without GSync? I’ve been PC gaming since the before the Voodoo 1 existed and had never even noticed that tearing was a thing until someone “kindly” pointed it out to me, and I’ve never been able to unsee it… They’re no longer on my Christmas card list :wink:

Just to reply to my own message, I switched Gsync off and yup, tearsville.

If it works for you use it. I run without it and have no tearing. My guess would be the difference between you and I is TrackIR at 120Hz vs Tobii Tracking at 33/133Hz. You have a mismatch to your monitor refresh rate.

If you experience brightness flickering…it is due to GSYNC.

That’s really interesting that you don’t have tearing! Can you let me know what your settings are? What’s your panel’s refresh rate?

I don’t have brightness flickering, which is good I guess!

My monitor refresh rate is 240Hz. What other settings do you want?