Weird Stutters when moving cameras

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.


Brief description of the issue:

From the 23th of July I have started noticed this weird stutters when I move my cameras, sometimes for a second the screen become black or sometimes seems that the game loads a previous frame,it happened on the Fenix A320, PMDG 737 and even in the default aircraft like the 747, I mean I used to have stutters and low frame rates, but I’ve never had my screen becoming black for a second even when I was using a GTX 1060

Provide Screenshot(s)/video(s) of the issue encountered:

Weird stutters - YouTube

Detailed steps to reproduce the issue encountered:

Spawn to custom sceneries with aicraft like Fenix A320, PMDG 737 or Asobo 747 and move the camera between overhead panel to Pedestal, but it can happens on short final too

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version (Learn how to find your current graphics card driver version):

Nvidia Driver 536.99 but I had the same problem on 536.40

PC specs and/or peripheral set up if relevant:

Ryzen 5 3600X RTX4070 16Gb of Ram Windows11

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

You can take a look at the recommendations. Any questions I will help you happy.

Hi thanks for your answer I tried everything you said, but I still have these weird stutters, I discovered that this issued is caused from the DX12, with DX11 I don’t have this kind of stutters the thing is in Brisbane with the Orbx scenery and with the Fenix I do 60 fps with DX12 beta and just 30fps with the DX11, but now is a while that I’m using the DX12 and I started having this problem at least a month later I switched from DX11 to DX12 when I bought an RTX 4070.

DX12 is in beta. I recommend DX11 until we have a final version of DX12 If everything works fine for you, I’m glad.

I would love to use DX11 but with DX11 I do 20fps with the PMDG 737 in Melbourne Orbx with an RTX 4070! 650 euros of GPU, when I had a GTX 1060 I used to have more fps, for me DX11 is simply unusable

After some test I found out that it’s the frame generation that cause me all of these stutters, but without frame generations I do the half of the fps that I do with Frame generation On, the thing is when I bought the GPU and I tried different configuration Frame generation ON or OFF I didn’t find all of these difference, I will try to reinstall the sim this night and pray God

Have you deleted the shaders? C:\Users\User\AppData\Local\NVIDIA
After every graphic card driver update or bigger Windows Update I delete the entries in DXCache and the complete GLCache folder.

1 Like

I’ll try thanks

I also recognize a strage behavior… my 5800X3D only runs with 3400mhz on all cores after joining the beta… other programs runs with 4400mhz+
so I also have more stutters because of the lower core speed

unplug all usb devices
start msfs
load aircraft
plug in your joystick throttle etc

resolved my stutters strangely

nothing chance.

after joining beta again, my 5800x3d only runs @ 3400mhz MAX. before beta it runs @ full speed.

any ideas???

Yes I did, I still have this problem I found out is a Frame Generation problem without frame generation I don’t get this weird stutters but without frame generation I literally can’t play