Weirdest CTDs: just a few default aircraft cause CTD at "Ready to Fly," but not addons or modded ones?

TL;DR / BLUF: Set controls back to default and then flight loaded fine. This is the first time I’ve had to do this, and I have a lot of different controls I fly with.

So I wanted to fly in the awful wind we’re having here at CYS in a -172 because I love simming for that. :smiley: However, I had a CTD when I clicked “Ready to Fly” with the -172 with steam gauges. Like any complex piece of hardware, I expect some CTDs here and there. It happens. Especially when it’s community modded out the wazoo. (And NO, I do NOT use the googly mod. Never have, never will. Just a lot of planes and airport sceneries.) Here’s what happened next in my investigation.

Setup during “test”:
Nvidia 512.15 drivers
Monster PC that I built which runs the sim in VR exceptionally well
Didn’t start in VR at all this time, and kept “baseline” same for each test.

  1. Restart in safe mode, picked same flight, (parking 117 at KCYS, steam 172)
  2. Click Ready to Fly. CTD
  3. Restart in safe mode, picked Baron
  4. Click Ready to Fly. Worked fine.
  5. Quit to menu, reloaded C-172.
  6. Click Ready to Fly. CTD
  7. Repeated over and over, including without safe mode, with safe mode, with removed Community folder, with added community folder with the following results:

CTD at fly now with:
C172 steam (safe and with mods–GNS 530 mod)
C172 glass (safe and with G1000 mod)
C208 (safe)
TBM (safe)
Porter (safe, one of the tire versions)
Icon (safe)
XCub (safe)

And now the crazy part. Absolutely no CTDs with these:
DA-62 (no mods)
KingAir (no mods)
787 (no mods, and moved to north parking at the ANG for room purposes. LOL)
VL3 (no mods)
F-51D (no mods)
F-18 (no mods)

Salty 747 (moved to north parking at the ANG for room purposes. LOL)
Longitude (WT mod)
CJ4 (WT)
787 (heavy mod)
Twin Otter
F4U (or whatever it is)

What do the CTD planes have in common? I dunno. My first solution attempt is to repair the .exe a la:

. . .and then delete and re-download those planes.

I’ll report back with any changes. If anyone else has seen this, let me know!

P.S. Anyone want to vote for a “check file integrity” option for a future build?

No Joy. Reinstalled offending planes from Content Manager after deleting them and restarting the sim, and still same crash at “Ready to Fly.” :frowning: :thinking: :thinking: :thinking:

The fault code is the usual “check engine” of fault codes:

Edit 2:
driver sweeper of the 512.15s and now reinstalling 511.79s.

Fingers crossed!
(Yes, I literally took a screen shot before clicking fly now. . .)

Doh. :sob:


I’ll just reply to myself. . .with the fix.
Found it here, and here .

Thanks to @jmiguez and @Eaglepilot6 and @Decimator33 !

1 Like

Thank you for this post. It baffles me why this is a problem, but it sure enough was what suddenly started causing me to CTD when clicking ready to fly. It was working fine, and then it wasn’t :neutral_face:. It was my Honeycomb Bravo to be specific. And it was one specific profile. I created an identical profile and deleted the old one… everything works fine again.

During the Dev Q&A, Seb has said on multiple occasions that nothing should cause the sim to CTD, and they don’t understand why it happens. The sim seams so incredibly fragile.

just started having this issue thank you Solved the issue for me !! ch eclipse yoke… i wonder what caused the bindings to CTD the sim randomly

I believe that our control settings are “saved in the cloud” and I wonder if they occasionally get corrupted, or something gets out of sync when a new sim update comes out.