When will MSFS 2020 really support VR with Oculus Quest2?

This post is not a request on how to tweak a few more FPS out of the game but is of more a desperate attempt to understand what could have been fundamentally broken in VR support recently. In my Quest2 MSFS consistently and permanently flips in-game to 2 to 5 FPS (literally) after running well at 30 or 40 FPS for a good portion of the flight.

Before I start my desperate plea (rant) I’ll list the important parts of my kit: RTX 3037; Ryzen 7, 32Gig DDR4 2300MHz memory; 2300 MB/s M2 SSD; Oculus Quest 2 with approved USB3 link cable.

How can an app running in VR mode flip from running at 30 or 40 FPS to running at 2 to 5 FPS (literally) mid-game, and will then not recover without MSFS application restart? MSFS 2020 support for VR leaves me without words (that I can put on a forum) and frustration to the point on giving up. Whilst I don’t have the ultimate gaming machine, I should have expectations of maintaining maybe 20FPS with reduced settings, but for the app to go from running on high/ultra at 30 to 40 FPS to suddenly flipping to 2 or 3 FPS mid-flight seems to be a fundamental issue with support for VR. What’s really odd is that once the frame rates have dropped, even dropping out of VR, Quest is unable to render the quest link home page menu bar etc at more than 1 or 2 FPS while flight sim is still running.

The same PC has worked fine with MSFS in VR for at least 2-3 years, initially with my Rift2 and for the last year or so with my Quest2, but over the last 2 months or so, it’s been pretty much un-usable despite no changes to the config, drivers or app.

There are quite a few similar discussions around absolutely shocking frame rates with VR mode which really point to significant failings to address what seems to be critical incompatibility issues that are just not seen with other applications. It’s true, that some people who have encountered this have managed to get acceptable frame rates and visual quality by putting in significant hours, not just tuning in-game settings but by taking low level control of resolution, focus, plugins, libraries etc. Given, however, the required precise layering of settings, apps and timing of these solutions which often includes statements such as “don’t even think about taking off your VR headset or you’ll need to start again from the beginning and maybe even reboot your PC”, this is indicative of the complete disaster that VR support is in this application.

Two things to note and accept are:

  1. MSFS 2020 is a fantastic application that provides an amazing flight-simming experience. It’s obviously expected therefore that some “tweaks” may be required to achieve optimum performance with any given set of components.
  2. Once you experience flight-simming on VR you can NEVER (never EVER) go back to flying in pancake mode.

Put these two statements together and we all have to accept that to get a truly great experience with MSFS 2020 in VR you need a decent bit of kit and you need to play around with settings and accept a few limitations such as lower frame rates, reduced quality grass and bushes, reductions in cloud and wave quality etc.

There are hundreds of posts both here and on youtube about tweaking the last few FPS without compromising visual quality, but only a few desperate and frustrated posts about complete and absolute failure to get more than single digit frame rates with the lowest of flight sim visual settings on what really is half decent kit.

It really is an obvious reaction that, after finally finding a workable solution that stops you from smashing your VR headset on the desk, to forget your frustrations and get on with flying in VR. So I guess the point of this post is a desperate plea to anybody that has experienced the same, to please share any intelligence around the solution to help not just me but others who have been thrown to the lions trying desperately to restore double-digit frame rates after previously experiencing the amazing world that MSFS 2020 can be in VR.



I feel your pain. MSFS for me was running pretty good with the original Quest via link cable. Then I went and got a used Quest 2 because I just wanted it to look just a little better, and maybe even go wireless, without making the rest of my system a bottleneck. Now with the cable, or with Virtual Desktop, the game feels broken. Unplayable if not totally unresponsive in VR. If I turn my head the framerate is what you describe, and there are large black areas where ever I move my head.

Hi Pete!

Sometimes I was experiencing this in the Quest2

I notice that if my quest was set for 72hz, or 80, 90 etc, sometimes it lost this sync with the headset for no reason. The remedy for me was to have the Sidequest installed and when the headset started to go nuts, I clicked in 60hz for 10 seconds and than return to the setting that I started flying, 72, 80 or 90 again.


Maybe you can try that.

Thanks @TadeuPrimo.
Headset losing sync does sound like a reasonable explanation to the shocking drop in frame rate. I wonder whether Microsoft have had an official bug reported about this as there are a few posts mentioning this significant drop. I guess these get a bit lost in the general disappointment and challenges in searching for a solution to generally poor VR performance. It’s a shame that it comes to using some third party app to fix what is clearly a game killing bug.
I’d given up and bought X-Plane 12 which works seamlessly with my Quest2 with decent frame rates and a much more immersive VR experience. The standard A330 has so many more working buttons which are easily used with the controller and ATC haven’t given me ridiculous climb requirements close to an airport or tried to vector me into a mountain in the dark.
I’ll definitely try your suggestion and give MSFS one last chance, but hoping that they take VR support more seriously soon and make the sim what it really needs to be as an immersive VR experience.
Cheers, Pete