Why is juddering still occuring when frame rate is half of screen refresh rate?

When I updgraed to a 60Hz 4k monitor I managed to get a smooth framerate by synching at 30FPS, but when you’re at low altitude and look to the foreground, particularly when looking straight down, the juddering is really distracting. I’ve tried adjusting frame rates, refresh rates, in game, windows and Nvidia’s control panel but nothing works.

If I switch to 1080p and 60FPS the juddering disappears.

Is this just unavoidable at lower frame rates?

Intel Core i7-9700k, 32GB 3200 RAM, GTX1080Ti

  • Microsoft Store
  • No Addins
  • Not using Developer Mode

Hello @gandreou ,

if your computer is unable to consistently produce more than 30FPS on 4k with your settings, I would say that smoothness although somewhat subjective, can not be achieved and is therefore not a bug.

So no uneven stutters going on but an even flickering so to say?

That’s probably normal 30fps, it’s just a bit too low for a stable image.
You can use the Nvidia control panel to limit the FPS at 35, 40, 45 or any other framerate.
For me it starts to look smooth from 40FPS.

This is a matter of taste, but to me 30 fps is certainly not fluid at low altitude, no matter how even the frametimes are.

OK, not saying it’s a bug, just thought I should be able to prevent it with one frame for every two refresh cycles. Maybe it’s not exactly 30FPS and it’s 29.5 FPS or something, which won’t go into 60.

@CptEvillian most of the time I get a smooth and stable 30FPS due to in game VSync.
Unfortunately with my hardware I can’t get much more at 4k. If I turn off VSynch it increases to around 40, but it fluctuates like crazy and although you get more frames it’s not smooth.

@Aeluwas that’s probably what it is. But strange that if I pan forward and look into the distance the juddering diappears.

Not too strange! There is less motion (fewer pixels/sec moving past) when looking straight ahead, so the required framerate for smoothness goes down.
There have been cases where I felt 24 fps was entirely smooth (looking ahead/mostly ahead at high altitude), and yet I think 50 fps is choppy when moving the camera around.


If you are limited by the GPU you can turn down the rendering scale to 80 without much visual degradation and get a 20% higher FPS. If you can get above 40fps this way you can limit the FPS to 40 and disable Vsync. Buttery smooth!


Probably a good clue here. Depending on your overall graphics settings, your graphics card isn’t capable of rendering the image fast enough at 4K resolution - so you get jittering images while it sorts itself out. Try turning the render resolution down to (say) 80 and see how that works for you.

1 Like

I agree with the other commenters. Your pc is probably not capable of constantly producing enough frames for a smooth experience, so turning down your settings would probably be the best option. Significantly more performance is required going from 1080p to 4k, since 4X more pixels need to be rendered, potentially giving you only 25% of your framerate compared to 1080p.

Just to clarify, enabling v-sync 30fps or limit your fps, does not guarantee that you get to see 30 fps.
Maybe this explains it a little better:

If you don’t want to lower graphic detail, render scaling or setting the game to 2k may be a compromise.
As there currently is no indication of this being a MSFS bug, your topic was moved into #self-service:pc-hardware

1 Like

@CptEvillian Thanks, I already have render scaled to 85%. I even set it 50% with 40FPS fixed in Nvidia Control Panel and it still judders, and looks bad.

In addition, I find that setting frame limits outside the game results in tearing so I prefer to set it in game. I’ve noticed that from the beginning.

Setting to Medium quality I can get 50FPS but it’s not stable and although the juddering disappears, I get screen wobbling when looking straight down! Kind of like tearing but with a wave passes down the screen.

The only way to resolve all these issues is to set to Low End to reach 60FPS.

It’s not worth playing this with low quality settings, it’s all subjective, but for me I’d rather settle for the juddering at ultra, with a stable 30FPS, given medium and high settings don’t resolve the issue. The best thing about MSFS is the visuals.

@ITDreamFly I’m going on the MSI Afterburner screen overlay for the FPS readings.

A lot of commentators have been saying that 30FPS is perfectly acceptable for a sim, though that’s not quite true.

1 Like