Windows 11 MSFS limited by main thread- Intel 12th Gen

Please tag your post with #pc and/or #xbox: PC.

Are you on Steam or Microsoft Store version? Steam

Are you using Developer Mode or made changes in it? Yes. only using the fps display feature.

`Brief description of the issue:

When loading into the game from the world map, I’m experiencing very low frame rates(<10 fps). This is happening just before loading is complete and in game. I highly doubt if my PC specs (given below) are the issue. As per the FPS window, i’m seeing “limited by main thread” d3d11 as the issue. I could see that only 2-3 cores were being fully utilized on the 12700k. The GTX 1080 was also being utilized to around 70%. I have updated to the latest Nvidia 511.23 drivers. Windows 11 pro is also up to date. Vsync is disabled in game as well. The FPS is capped to 50 fps in Nvidia control panel but this did not help. This low fps occurs with any aircraft/airport. The DDR5 RAM speeds, CPU clocks and GPU clocks are all fine.

In game i have disabled multiplayer. I’m only using medium settings at 1440p. Rolling cache is enabled. I have tried a clean install of MSFS 2020 with no improvements. I’m running the steam version of the sim. I’m not using any mods currently.

Basically, have anyone of you encountered this issue? If yes, could you kindly, let me know how this can be resolved? Kindly let me know if you have any suggestions.`

PC specs and/or peripheral set up of relevant: CPU: i7-12700k (hyperthreaded and Intel virtualization disabled) GPU: GTX 1080 RAM: Kingston DDR5 4800 MHz 32GB (16GB x 2) Windows 11 Pro (With latest windows updates) Nvidia Display driver: 511.23 No overclocking of the CPU, GPU or RAM were done.

Build Version # when you first started experiencing this issue:

PC Specs Summary:

DX12-Beta: Both CPU and GPU frame times are affected severely ‘towards the end of loading and in game as well’,

DX11- Mainly getting ‘Limited by main thread towards the end of loading and in game as well’

Here is a video of my in-game settings and the issue i have explained above,

I had the same issue with my Intel 9th Gen. Then I found this post and followed the tips. I stopped getting the limited by main thread issue afterwards. Maybe it’ll help your case too.

I suspect conflicting mods have led your cpu on an amazing journey and it can’t find it’s way home.
MSFS features are designed to be overwritten by mods but the mods themselves are not designed to be overwritten by other mods. This includes marketplace purchases.

1 Like

As mentioned in the post already, intel virtualisation is already disabled in the bios but this did not improve anything.

1 Like

Apart from the world updates from Microsoft themselves, I’m not using any third party mods.

Then all I can suggest is trying to get your gpu use up to near 100% even if that means close to 4k resolutions, you should certainly not cap fps while investigating.

And I am baffled by such a mismatch of cpu and card?

1 Like

thanks. i have tried it now without any fps cap but still get the same issue. Towards the end of loading the fps drops form nearly 90fps to 2fps and when i enter the game it stays at 2fps (says limited by main thread).

I can catagorically say something is not right there :thinking: a 12700k shouldn’t be maxed whatsoever with a relatively tiny 1080. I can only suggest you may have to switch to PCIe3 lane use or auto settings in your bios but it could equally be something different so consult your mainboard’s manual.

You definitely need to push your graphics to 99 or 100% usage so at least try ultra

I have tried ultra settings. What i meant was the CPU overall is only 35% uiilized. and only 1 or 2 cores are being maxed out when running MSFS. So, overall the CPU is being under-utilized. Also, i re-applied thermal paste for the GPU which is relatively older and the temps now when the frame rate goes to 2 fps is only around 60C in the loading screen and initially in game.

So the GPU as well is being cooled adequately. Also, the summary of my machine is attached with this post. Kindly, let me know if you think something is wrong here or if more information is needed.

may be you get a lot of hints in all of this exising topics:

tip from my side: lower the LOD setting … this HT stuff is a myth, in my oipinion :wink:

Upd: and I forgot to mentioned… the fps of a “loading screen” or while “game loading” is not relevant

Thanks actually once it loads in as well it stays at 2 fps (in game in all camera views). For my system what setting of LOD would you suggest? Also, i have added the frame times i’m getting in the original post.
In addition i have tried with Game Mode Off and Hardware accelerated GPU scheduling (HAGS) Off as well which gave no improvements.

try level of details to 200… or just for a test-case go to LOW setting too…

but, if you not stay at the biggest airport in the world in the biggest airplane you own, I would then not expect that you get 2fps with your system ( down-scaled from 4K to 1440p )… I own i7.8700k and assume your single-core perf is 30% better than my, so you should reach 20fps ( on other side I own a 2080TI ) … The question for me is not! that your cpu is not full utilized, this is well known, the question is why you get in-flight stable 2fps only.

Within another topic we spoke already about the manipulators… did you tried different airplanes and airports ? Be aware that “mods” are also the market-place add-ons and some of it can cause trouble too ( g1000, etc ). And did you tried the safe mode already ?

I tried lod set 200 and lower than 100. With the TBM aircraft i spawned into a remote airport. I have multiplayer disabled and have only Asobo’s world updates installed. No other mods are being used. With the TBM i could get upto 40 fps but strangely if i pan around in the flight deck the fps drops to <10 fps and in the external view, i get <10fps with texture and objects LOD set to 100. I think there is something with windows 11 drivers/settings. I do not understand how there are many youtubers with RTX 2070 and an older CPU getting good frame rates at 1440p- high settings and that too with salty 747 mod.

I have also tried to disable full screen optimization for the exe, windows Game Mode Off and Hardware accelerated GPU scheduling (HAGS) as off.

At the same time for intel 12th gen windows 11 is better. Is windows 10 currently better for msfs? Does anyone here have a 12th gen intel cpu and are running windows 11. Kindly, let me know your experience.

1 Like

related to issue with “pan around” are also topics, but thought it was fixed with the new “Pre-Load-Parameter” ( but please not use airports like EDDF as reference, these are realy demanding ).
But LOD lower than 100 sounds realy a bit strange… in forum there are some 12700 users, you can use search function. I not remember specific issues to these cpu… may be its realy the combination with the old 1080… and a note: most of these youtubers have native 1440p and not do some kind of re-scaling, who knows…

I still run win10 , but only because I not want let force me from these company to do anything at my system and I will not be a windows 11 beta tester. But this is a different story :slight_smile:
So I’am not sure about possible issue with win11… by the way, cpu wise I have HT and all these usefully features enabled.


Thanks a lot for your suggestions and time. I will try some other stuff. I heard that photogrammetry was broken with SU5. Is it still so with SU7? Or is there any other feature which should be disabled to get back the old performance?

“You heard”??

That’s mostly rubbish, PG is not broken if your PC and internet are running as they should be. SU6 (I think) degraded AI scenery a little by removing some detail and textures but I assume this is just temporary.

Well based on the forums i could see that but yeah what exactly should i be trying next? Do you have any suggestions? GPU and CPU temps after running the sim at low fps for 30mins is maxing out at 70C and the clock speeds are reaching the boost spec and holding there. So cooling is not the issue for sure here.

I think apart from upgrading your gpu … keep lifting graphics, renderscale and resolution is the only advice I can offer. If you can’t get to gpu limited in the dev counter then you are flogging a dead horse.

1 Like

Have you try to reset your bios settings.

Your mainthread latency is far too high for it to be a setting issue. I would say its something more deep rooted with your system, possibly a windows 11 issue. Has it ever ran OK?