Windows 11 Not Recognizing Logitech Joystick Extreme 3D Pro

The Logitech driver used for Windows 10 is not compatible with Windows 11. Hence, MSFS 2020 doesn’t recognize the Joystick. Is there a workaround?

According to Logitech, it is not compatible with Windows 11.
However, there are folks who have got it working in MSFS.

One thing I have seen is this site which has Windows 11 drivers for it.
How well they work, or if this is just spam I don’t know.

Thanks for the link. Not sure I want to download an .exe file from this site…

Might need to get a new Windows 11-compatible joystick…

1 Like

Mine is working fine with Windows 11 and I don’t recall downloading any form of driver for it. Windows just automatically recognises it.

3 Likes

Your joystick works in Win11. I have been using my old Logitech Joystick Extreme 3D Pro purchased in 2005 since the release of MSFS. Currently, I am running Win11 22H2.

I never manually installed any drivers for this joystick or the Logitech Flight Throttle Quadrant I got last year. Windows discovered these devices and shows their names in Settings - Bluetooth & devices - Devices and Settings - Bluetooth & devices - Devices - More devices and printer settings as “Logitech Extreme 3D” and “Flight Throttle Quadrant”.

In MSFS each has its own full set of bindings available in Controller options. I do not know why your Win11 is not working for these devices, but at least you have confirmation that they do work with the latest Win11.

4 Likes

I have the Extreme 3D pro on Windows 11. I tried and then uninstalled the Logitech drivers because they caused issues. But without them, Windows 11 detected it as the correct device, and let me do the calibration. MSFS works with it as well as it did when I had Windows 10.

2 Likes

Yep, you don’t need the Logi drivers. Windows will do just fine without them…at least that was my experience.

1 Like

Some driver versions get blocked by memory integrity security feature. Test turning it off and check device manager.

Thanks for the tips. How do I completely uninstall the Logitech drivers? I tried uninstalling through the usual Windows uninstall feature, but there still seems to be some stuff left, as I am still seeing “Logitech Virtual Bus Enumerator” under Hardware as ab error message.
When I plug in the Logitech joystick it shows two entries under Hardware properties: 1. Logitech Extreme 3D Pro (HID) - with an error message and 2. Logitech Extreme 3D Pro USB - with no error message.

Is there a way to delete the first entry?

Did you remove them from control panel via the Programs and Features app? If it’s showing under device manager as having an error, try right click on the entry with the error and chooses uninstall, see if that helps.

1 Like

Thanks, I’ll try it later.

Hi!
Like AviatorCSnet I too have had my Extreme 3D Pro since 2009, if I remember correctly. Yes, there have been issues through the different versions of Windows 11, but it has functioned and since the latest Windows 11 update and a little while earlier, the stick just works. My current Windows 11 version is:
Windows 11 Pro (Swedish) version 22H2, 22621.1555
Interface: Windows Feature Experience Pack 1000.22640.1000.0

I have used the Logitech Windows 10 lgs510_x64.exe driver before and that functioned as well, but for right now (April 2023), just let Windows 11 find and install it’s own drivers. When I look in the Device manager now there are two drivers installed, a HID and a USB Logitech Extreme 3D Pro.

If you need/want to calibrate the stick, just run joy.cpl and the “normal” Windows game controller device calibration app will start. If you don’t know how to run it, search for it and choose the control object. ( I have it in Swedish, so maybe my translation of it is not completely correct. )

I hope this helps anyone who still has ( I think ) one of the best and simplest all round joysticks ever made! It has enough buttons and controls to cover all the basic needs and more. I understand that Logitech need to sell newer models and therefore give answers like “It is not Windows 11 compatible”, but it obviously is!

Then again, the firmware/drivers might not be as secure as Windows 11 wishes it to be and therefore it cannot be classed as truely Windows 11 compatible, so Logitech may have a point. At the same time, the firmware and drivers could be adapted and updated, if Logitech wanted to…

“Just saying…”
:upside_down_face:
/MacD

2 Likes

Hello Gladiator, Hope this suggestion helps you. If you have found the files that Logitech has left behind try to delete those files completely and then restart your PC while the Etreme 3D Pro is disconnected. Then after reboot try to plug in the E3D Pro and then Follow the above suggestion by: AviatorC Snet on March 12. Providing you cleared the entire files left behind, should fix the problem. Keep in mind, Those files contained the settings for other use cases on other games/apps so you may have to setup the controller all together once again in those apps. Good Luck.

1 Like

Thanks for the replies, but I’ve moved to a Thrustmaster joystick which Windows 11 recognized without any issues.

Hopefully, the posts here will help someone out who is trying to get the Logitech joystick to work.

Just putting my experience with it out here to help others: I installed the old drivers and it didn’t work so I actually had to go into device manager and delete the device, uninstall the logitech program, search for “logitech” on my C drive and delete everything, then plugged the controller back in and windows 11 recognized it and it works now so lesson learned: Just plug it in and don’t install any drivers. If you do, you’ll have to delete the device and remove the drivers.

Hi,

Came across this post while trouble shooting my wingman 3d and I’ve found out how to load the drivers required to use both the joystick and the Logitech software.

But it means disabling a security option.

Uninstall program and drivers, and remove all files left over.
Unplug joystick

Go to the “Core isolation” in “Windows Security”
Start>Settings>Update&Security>Windows Security>Device Security> “Core isolation” toggle button.

Restart PC
Plug in Joystick
Then reinstall logitech software.

Done!!!

in my device manager i only see

logitech extreme 3d pro (HID)
and not logitech extreme 3d pro (USB)
and in bluetooth settings it says “driver error” but when i go to the logitech website and download their profile driver it tells me that it didnt find any devices

I deleted the logitech profiler disabled steam inputs and restarted my pc but when i connect the joystick to my laptop i dont see it show up in game

wow finally my joystick works now

what i did was go in device manager uninstall both logitect extreme pro drivers and check the little box that says “remove this driver from ur pc” and restarted and i see it in game now
what a headache

I have a problem with my Logitech joystick. It shows up in Settings, devices correctly but I cannot see it in Device Manager so cannot check what driver it is using. It works in MSFS but the roll axis just gives me full left or full right. I have played with the settings but no luck. It works perfectly in XPlane 12 so I know its not the joystick. I have deleted all Logitech programs as above and restarted but no joy.
Any ideas before I buy a newer model?
Thanks.

Did you try the drivers listed near the top of this thread?