Windshield texture missing (or corrupted)

edit:Ive redownloaded the entire game and now it works

Hello everyone,
I just bought fs on steam two days ago, I have a lot of missing textures that make fs unplayable, as shown in the picture below. I have never modded the game and I have never touched the developer mode.

On all planes the windshield is either totally black or colored, and there are a lot of other missing textures.
It is very likely that this problem comes from my hard drive, so I tried to redownload some aircraft (the DA40), and all of the following:


I don’t want to reinstall all the game because the launcher is very slow and laggy, but ill do it if nobody know where is the origin of the problem.
Thanks in advance and sorry for bad english

Hey all please have a look at this, I removed my graphics drivers, reinstalled etc. and it is on all the default planes, not any 3rd party, what the heck!

I know you said “not third party” does that mean you disabled all of your add-ons and try to reproduce?

Also, did you make any changes to dev mode?

Thanks for the input, no add-ons tested and all graphic settings rest as well as dev mode, I can also see the same issue with other planes in the airports that are default.

1 Like

This is generally caused by an addon conflict.
It requires removing all your addons from the community folder, and disabling all purchases from the marketplace.
If this solves the issue, add the addons back a few at a time until you determine which ones are causing the issue.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

Every default aircraft has glass that cannot be seen through at all and is replaced with some strange checkerboard of multiple colours.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

No idea, it appeared out of nowhere and only happens to default aircraft that use whatever texture set they do for the glass.

I have removed graphic drivers which still does not make sense as no addons aircraft have the provblem.

PC specs and/or peripheral set up if relevant:

3060TI, I7 6700, 20Gigs ram but like I say everything else works perfectly.

Build Version # when you first started experiencing this issue:

Over the last few weeks but no changes were made to the existing install.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: