Workaround for Premium Deluxe scenery EGLL when loading halfway only 1.18.15.0

Here is my personal workaround on how to depart from EGLL with the Premium Deluxe scenery airport.

What has been my problem? Since SU5 and the two hotfixes I was not able to start a regular flight from EGLL. Whenever I tried to load up the scenery the loading bar stopped halfway. The game could not be used and shut down manually.

Yesterday I found out that there must be a major problem with the marketplace delived update of Premium / Premium Deluxe after SU 5 and HF 1+2.

How to get the scenery working I did these steps:

  • De-installation of EGLL via content manager
  • Load up the now default EGLL scenery and the desired gate (looks really ugly :wink:
  • Re-installation of the EGLL Premium Deluxe version via content manager
  • Load up on EGLL Premium Deluxe …

and it works fine.

This problem remains:
You have to do the steps again and again when you decide to take off from Heathrow. Obviously the sim forgets all the work :frowning:

Zendesk has been informed via ticket.

I believe that this kind of work around may work on every single scenery that comes along via marketplace and out of Premium / Premium Deluxe.

For me it helped a lot.
Cheers!

I’ve experienced the same problem at KSEA, it only loading half way and then stops, I was forced to end the game through task manager, but it was working at my second attempt.

Is your community folder empty? I don’t experience this issue at all.

What i do experience is that i cannot delete waypoints (USR) from flightplans anymore, so landing on EGLL is with some strange turns at the end above London.

I have the same issue even with empty community folder. I have since discovered more premium airports with the same issue. I’ve submitted a ticket as long as a bug report where you vote : Premium / Delux airports loading issue

1 Like

Scenery from the marketplace doesn’t install into community it installs into official, i have a similar problem with the orbx london landmarks from the marketplace, pre hotfix it worked fine, post it doesn’t load

1 Like

Also with EGLL i am always send to a stand spot somewhere way off the grid between some sheds…instead of parking at a gate at a terminal

I think there is some sort of scenery issue around the London area. I have the “deluxe” version of the sim. Since SU5, I can’t spawn into EGLC…hang up, quit sim with task mgr. But, if I spawn at EGLL, I can fly into EGLC, touch and go, and fly back to EGLL with no problem. Go figure!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.