Workaround :: FPS drop on long haul

Hi all,

as I am able to reproduce this issue, I’d like to share my results with you.

I am currently on a long haul from EDDH (Hamburg) to EGYP (Mount Pleasant - Falkland Islands)
https://simair.io/logbook/kqfflo/flight/39130

I flew the first 2 hours then let my copilot take over the ATC while on AP.
10hrs later I was stuck at ~10 fps.

Solution:

  1. Go to settings → Data → Disable online functionality → APPLY
  2. Wait until applied
  3. Get back to the cockpit (still at 10 fps)
  4. Go to settings → Data → ENABLE online functionality → APPLY
  5. Wait until applied
  6. Get back to the cockpit → FPS back to normal

Let me know if this works for you as well :slight_smile:

5 Likes

Thanks!

The sim should be renamed. Microsoft Workaround Simulator.

7 Likes

At least I do not need to land the 747 at 5fps later today. Flight time approx. 15 hours so around 2 hrs left.

2 Likes

It is the real live traffic causing this FPS Drop problem. You do not have to disable the complete online functionalitiy but just disable the real live Traffic at the data menue , then go to the cockpit and then again in the menue and enable the real live traffic again. After that you also have to choose the real live traffic option unter “traffic” again, because it will be automatically disabled when you diable the real traffic at the data menue.

1 Like

Oh wow, so you did find a solution! Thanks will try that! It seems the sim is loading something (maybe the map?) but it cannot unload it, resetting the function resets the load and thus gives back the fps.

I tried with disabling real live traffic but it did not work for me. But sure it might be of help for others. Maybe 10 hrs of autopiloting needed more than only this one to be disabled and enabled again
:wink:

1 Like

WOW … this is not only for longhaul

Did EHAM-EPGD today. 1.5 hours …. Ended up with 20fps uppon landing. Did the magic like suggested and was back to 35 !!!

Must be a memory leak or something.

Any clue on what online option this is hapoening ?

1 Like

Thank you! My FPS comes back as soon as I disable online functionalities. Re-enabling keeps it.

1 Like

Couldn’t even make it 4 hours, and frames started dripping. Tried the disable/enable online functionality workaround which didn’t work for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.