Working Title G1000 NXi Discussion Thread

Yes that’s part of my confusion. But I understand it now, just a different way of working from the asobo version I had got used to.Do you know if the Nxi way is the way it works in real life?

1 Like

I’ve never used either in real life so I can’t answer that, sorry.

The live traffic issue is separate from the problem I demonstrated with AI offline traffic. AI offline generates random traffic in the sim that’s not based on live traffic. Both AI offline and live traffic will show up in LNM if they exist. And if it does show up in LNM, as AI offline traffic does, it should show up in the G1000.

1 Like

I have the same problem with traffic, it shows on LNM and i can hear it on ATC but is not showing on TAS. I dont know if is not a bug with the sim and not Nxi because I cant see the traffic when looking outside, maybe the sim doesnt draw the models?

I landed at KLAS earlier, and there was no live traffic whatsoever. I think there are separate issues here that just happen to be occurring at he same time.

According to the WT Discord server, only live traffic, or Vatsim/IVAO/PilotEdge traffic will be displayed on the TAS. Apparently Offline AI and MP traffic is injected differently and will not show.

Live traffic is broken [ See Here ] and has been for several days, so TAS can’t display what the game is NOT producing. At the moment I guess Vatsim / PilotEdge is the only way to see traffic on the TAS of the NXi.

1 Like

It worked fine with 0.6, and I only fly with live traffic, never AI offline traffic.

Since I never have and probably never will use MP, i have no personal observation. I can only tell you what they say on Discord. Maybe go there and see what you can find out.

Live traffic DID work in 0.7.0 until the live traffic disappeared in game. The lack of live traffic in TAS is not the fault of NXi.

I`m guessing thats the problem, I switched from live traffic to Offline AI because I couldnt see any traffic, so sim bug not NXi.

1 Like

Taking the GPS out of the equation, the worlds busiest airports should be swarming with live traffic. And I have seen none today, or yesterday.

A few questions, which may or may not be related to the NXi system.

I have just installed this add-on, so still new to it, using it in Cirrus SR22 so far.

  1. On the map, I see no other aircraft, despite having the traffic button on, could be bug Asobo’s side or perhaps Im not meant to see traffic on the map?

2.Is there a weather screen, I cant seem to find anything?

Thanks

NEXRAD on the MFD, but not actual weather radar. Not yet, at least.

I see that button, so what is that supposed to do?

Thanks

It will show you precipitation around your aircraft, but the data is collected elsewhere, and sent to your GPS.

The data doesn’t come from the plane, but from ground stations.

3 Likes

Ah I see, so it would show on the map screen, would I need to tune to these weather stations then, I didn’t notice anything on my map earlier when flying few some rain clouds.

Just press the button on the MFD.

The way we have it is per the real unit. Pressing the ALT autopilot button does not synchronize the altitude preselector. Additionally, pressing the ALT knob actually turns off the altitude alerter, it does not either synchronize the preselector to the current altitude.

The sim traffic API does not deliver AI Traffic or Multiplayer traffic. You will only see Live Traffic and traffic that is injected via SimConnect (so VATSIM/IVAO).

-Matt | Working Title

2 Likes

For the DA62, the engine load displayed in the right glass cockpit is incorrect. Using the chase camera, when the chase HUD displays 75% for all engines is when the interior view shows 100%. It then backs off to 99%, etc.

I am playing on the XBOX One.

This is especially noticeable if you take off in cockpit mode and hold “A” until the glass cockpit shows 100%. Since it is in reality only 75% across both engines the initial climb is extremely sluggish with gear out and flaps on T/O. I couldn’t figure out why the DA62 just wouldn’t climb at full throttle until I switch to chase mode and noticed the engines were only at 70-ish %.

Apologies if this is a duplicate issue report, but I did search on Google and in this topic and did not see it mentioned yet. Thanks for fixing this!

All versions of the G1000 mods have not worked properly for me. In particular VS mode and NAV mode will not activate with sim button click on screen OR hardware button click [Honeycomb Bravo Throttle Quadrant]. AP will activate and HDG and ALT work fine but I am unable to adjust VS or engage NAV mode. If I remove the mod and revert to the default FS2020 G1000 everything works fine. Any ideas on what I may be doing wrong?

I think the WT release notes state that the external HUD is not syncing up with the cockpit displays properly.