World Update 3 download issue ongoing

I am still unable to download World Update 3.
Removed addons from community folder and restarted.
Heck, I have done everything, I have even done a full reinstall of the sim recently.
Cheers and even submitted a ticket to Zendesk (no reply)
So, how in the name of Zeus do I download the update.
Buttons are greyed out in the Market Place.
Is there someone I need to yell at to get some action.
In the words of Karen: Get me the manager…lol
Seriously, any help would be appreciated.

Two days of living hell. I got to 6GBs, then it hung. I actually turned off the sim and restarted the computer and then restarted the sim. It picked up at 6 and loaded the last 3GBs.

The only way I could successfully update was to change my ethernet connection speed from 1 Gb/s to 100Mb/s. When running 1 Gb/s downloads would always fail and restart over and over. After changing to 100Mb/s each download completed successfully and finally finished the update.

This is the main issuer
Buttons are greyed out in the Market Place.

My system is stuck on checking for updates at start-up. I updated it to through the MS Store. All windows 10 updates installed. Do I have to delete a registry key or folder somewhere? Thanks

In the Sim Main Menu, log out of your XBox for Windows account.

Exit the sim.

Go to MS-Store, log out if you’re not already, log back in.

Launch the sim, log back into XBox for Windows.

Market Place grayed out means your XBox account lost connection even though it appears logged in.

Thanks for the suggestion but, didn’t work

New to forum, have been trying to load from first install of 10 DVD pack premium deluxe 7 days ago. Tried all suggestions contacted Microsoft support still not loading! I get splash screen of Canary Wharf - Checking for updates - World update UK and Ireland blue bar appears bottom of screen then CRASHES.