X52 Controller detection bug & FIX - Hardware IDs dont match

Hello there!

So I had the same issue as all of you with a standard old X52 (not pro).

So - I went through the same process as you all and messed about with drivers and several attempts at unplugging and replugging at different stages. Also steam controller settings.
Its funny that the latest version of the X52_HOTAS_x64_8_0_213_0.exe driver package only seems to contain the drivers rather than the drivers that the professional version driver package does.

That asside, I still manged to get it working eventully with some file tweaks.

It turns out that the MSFS2020 controller profiles for the X52 has a hardware GUID ID and product ID that does NOT match those of my X52 for keymapping detection.

I have the steam version but the same will apply for any version, just locatate the input directory in your MSFS2020 install directory.

For me this was the steam directory:


But your location upto the STEAM folder is likley to differ.

Then locate the Saitek_X52_Flight_Control_System.xml file and make a copy. Call it Saitek_X52_Flight_Control_System2.xml or something.

Then edit this file in a text editor of your choice (I used notepad++).

This line then needs to be modified to match your hardware ID:

Device DeviceName=“Saitek X52 Flight Control System” GUID=“9a117810-f09c-11e7-8002-444553540000” ProductID=“075C”

In my personal case, I had to modify it to:

Device DeviceName=“Saitek X52 Flight Control System” GUID=“745a17a0-74d3-11d0-b6fe-00a0c90f57da” ProductID=“0255”

In order to find your correct GUID and product ID open up windows device manager.

Find your X52 H.O.T.A.S. device (either USB or HID, the IDs are the same so it doesnt matter).

Open up properties and then click on the ‘Details’ tab.

Under the property pulldown, the GUID can be found under ‘Class GUID’ between the curly brackets.

And the product ID can be found under ‘Hardware IDs’ - The 4 digit product ID is the numbers after ‘PID_’ and before ‘&REV’ in the first string of the several listed.

(pics showing device manager)

I dont know why the ones in MSFS are incorrect. Perhaps some USB controllers change things (unlikley) or perhaps the X52 was sold with different IDs depending on age or geo location. Either way, this works.

When you plug in now, you should find MSFS2020 gives you a correct default profile for the device with a lot of mappings now in place. It did for me. Although there is still no device picture on the right like other supported devices. Perhaps other files have to me modified for that in order for it to match a picture.

(pic showing detection working)

I hope this helps you all!

PS. This will probs work for other ‘supported’ controllers with the same issues.

1 Like

Thanks for detail info , unfortunately i play with XBOX PASS - there is IMPOSSIBLE to edit/copy files

I’ve also been looking to make this change and have the store version. I believe its related to the older X52 devices, something about the Logitech update. I had to deal with the same issue in Elite. I can’t even find the config file :confused:

Hopefully there is a way to get a config into the AppAata location so it can be edited?

1 Like

I will try this maybe that is my problem because dispite everything being selected it says you are “tring” to assign to a device that is not selected when I try to assign a key. thus I cannot assign combo commands or use half of the secondary keys. I can’t seem to find whee that file is located I bought it from the MS store but I don’t see where thy put that file. well aparantly I did buy it thru xbox for the pc ■■■■…should have gotten it thu steam I hate not having control over the files if I have to use juast a stupid game controler I will be ■■■■■■…

If only there was a way of changing this stupid XML file my worries would be gone,

maybe there are some geniuses out here who might have an idea how to change the hardware id of the driver rather than the xml file?

Same for me, unfortunately I have the xbox store version and can’t get it to work. Microsoft anychance you can help us out here

They dont care, send tickets, emailed them, i have no idea what they are doing.

Hi all

Check this post out - there is another location for the controller profiles for people like me who have FS2020 from the Microsoft store/Game Pass. I found my half setup config in a folder and managed to get a ready setup one and pasted over it.

Hope this helps

1 Like

it is soo depressing that others can actually edit config files but i can’t. i got mine from the ms store. i can’t find the files i need to change.
besides we are supposed to be flying now and fixing things! i thought i have a PPL not an AP license! frustrating isn’t it?

Actually, you can find your config file here: C:\Users[user name]\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\SystemAppData\wgs(folider with a name of a huge long string of number). There will be several folders with a long strings of digits, each including a file with a long string of digits. :slight_smile: You need to edit them with notepad, one of those will be a .xml file with the joystick’s config.

J’ai eu beau faire les modifications que vous mentionnez mais rien n’y fait il ne reconnais rien du tout.

Exactly the same problem here. That´s ridiculous.

There´s absolutely no way to get the x52 to work with the PASS-Version of this ■■■■.

So I won’t pay any more money for GamePass until the problem is resolved.

i feel you man, this is absolute ■■■■■■■■, cant believe they dont even respond to any of these issues

Same here…bought from the Microsoft store and now cant edit two little strings in a .xml file to get the 52 to work.

This is just dumb.

The FS 2020 update yesterday seems to have fixed this issue. I could edit the bindings to the controls over the last week but could not get them to operate when I flew. Now they do work when flying.

It shows the Logitech driver fore the USB as Not sure if I should try and install the later ones.

Also the Throttle lCD doesnt light up using a 3.0 USB but that isnt a FS 2020 issue.

““The FS 2020 update yesterday seems to have fixed this issue. I could edit the bindings to the controls over the last week but could not get them to operate when I flew. Now they do work when flying.
It shows the Logitech driver fore the USB as Not sure if I should try and install the later ones.
Also the Throttle lCD doesnt light up using a 3.0 USB but that isnt a FS 2020 issue.””""

It does not seem to me that with the latest update they have solved the problem encountered with the Saitek X52 version IDs 0255 that many report and send support tickets. For now those who have the X52 ID 0255 are not automatically detected as well as the owners of the Saitek X52 version ID 075. This problem can be solved simply by unlocking the file concerning X52 so that the users themselves without any effort from the developers, or , if they don’t want to unlock the files, they create a compatible one so that they can also use version IDs 0255.
Your problem with LCD throttle reporting is certainly a problem with your X52. Probable a bad contact of the bridge cable between devices and nothing has to do with the difference of the USB 3.0 or 2.0 ports.
P.S. May I know what version your X52 has since the title under discussion speaks clearly of Hardware issues? Exactly GUID and Product ID.

Microsoft / Asobo Where did you get that Saitek X52 with IDs 075 when the Logitech official website clearly states this. Who is wrong? Certainly it is wrong who does nothing to remedy the problem. One thing is certain, you cannot update the firmware but the .xml file compatible with version 0255. It costs nothing, feasible, fast and monstrously simple.

1 Like

Same for me - at least it now “sees” the X52 controller even if it doesn’t have bindings - now I can create a profile. Tedious to have to do this when there’s a super simple fix on the development side with a mod to the XML to properly support the older hardware IDs…but I guess that’s the new world of Microsoft where they don’t have test teams to test their software properly anymore.

Still nothing for me too with MSFS on Xbox Store. The parameters are empty and it is impossible to edit the XML.

ditto still can’t assign key bindings by pushing the button I wan to assign as it states,thus no ability to us the 3 mode programing.

1 Like