X52 pro stop working mid flight

The game is recognizing my controller in-game and works fine but at a certain moment during the flight the controls stop working so I can’t control my airplane anymore. It still recognizes the inputs in the options menu but the plane wont respond to any inputs.

Only a full restart of my computer fixes the problem but then it happens again at some point.

Any one else having problems with the X52? Any know solutions for this?

1 Like

I have the X52 Pro and this happens often, but it’s the cable coming out of the joy stick. I find its works itself loose. Once I push it in, it works straight away.

Edit - forgot to say, check your mouse is over the main flight window, or the input from the input device might be ignored. I can neither CONFIRM or deny I have reported it during the Alpha, because of the NDA. Not sure why CONFIRM is in capitals. How odd.

You’re NOT ALONE in this issue. And it has been contained within the legacy FSX for years. I mainly see it when trying to land at NIGHT. I believe it to be some sort of memory issue. I used to be able to control the occurrences by minimizing some of the graphics levels. I thought SURELY they would have handled this in 2020, but no. Only thing I have found that works is to reboot EVERYTHING, or one other thing. You can freeze the sim with ESCAPE. Unplug your X52, and wait about 15 seconds. Plug it back in, wait a few seconds for the program to recognize the X52, and release the ESCAPE. You may then finish your flight. Unfortunately, most of the time this happens at touchdown, and kills my flight through a recognized CRASH. Do I sound frustrated? Oh I AM, REAALY UNHAPPY. GOOGLE X52 lockup in FSX, and you will see MANY other frustrated flyers. Fly for two hours and lose the mission to a stick FREEZE? And after paying a LOT for FS 2020! Now, I am afraid of how many other controllers have this issue. And just as an FYI, I fly FULL SCREEN, so the mouse must be on the active program window. I feel your PAIN, and I know you feel MINE too.

1 Like

For what it is worth, I have flown MSFS for 3 months with my X52 pro, never had an issue like this.
Not all X52’s act like this, but all pc’s are different.

I did a little homework, and read up on what people were saying about this issue. What they said, and what I am seeing is identical. The LEDs sometimes go out on the flight stick while the throttle stays solid. What others have said is that most likely it is a loss of power going to the stick (probably from usb power saving options). Everyone said to disable all the power saving on the usb port, and that perhaps the BEST solution, was to get a externally powered usb 2.0 hub. Many people have experienced problems using the usb 3.0 ports on the pc. This problem has been more prevalent with the original X52s. So I think I have the fix planned out. It would explain how the stick might “timeout” on long flights on autopilot. Time to go get a hub. On the bright side, I can charge other things with it as well.
I have now started using a externally powered USB 2.0 hub. The problems with FS2020 losing the stick are still present. I do have a caveat though. At the moment, I am plugging into a usb 3.0 port for my hub. I have one final thing to try, I am getting a header connection to actually connect to a usb 2.0 port on my motherboard. If this doesn’t fix it, I’m out of ideas. Its beyond frustrating, losing the right stick after an hour flight. Landings are outside possibility because of it. And it is not an intermittent thing. It is EASILY duplicated. The throttle side still works, but with loss of x/y control, you’re dead.

After the port change, and the addition of the hub, things worked better. But I still got a lockup flying at night on a large airport, even after the patch. I finally unloaded all of it from the device driver and loaded the OLD Saitek driver that came with my OLD, very OLD, X52. I had been trying to use the Logitech drivers that were much newer. After doing that, I flew a five hour flight from Chicago to Seattle with NO JOYSTICK CRASH. I may actually have a working setup now. I tried to see if I could find a Thrustmaster to replace the X52. They are nowhere to be had right now (unless the seller says “STICKEM UP”). At least today, things were good. And landing in Seattle today was a BUGGER! I use all realism on settings.

My issue with my X-52 Pro Hotas is that only for prop aircraft, less than 2 minutes of being in the air, the engine power reduces to 50%, even though I am at 100% throttle.

I swapped to external view to easier highlight the above issue-

I watched your video, in your settings, do you have automixture turned on? I dont think it is a throttle issue, as the indicator still says full. So I have to wonder about MIXTURE. It auto mixture is not on, you will need to map mixture to a slider on your X52. And the throttle is on the Throttle AXIS. The mixture is on the MIXTURE AXIS (-100 to 100%)

Click the reverse axis in the control settings for Throttle Axis. I believe that your throttle is reversed. Mine shows the Reverse axis checked, and the graph shows all the way to the right with the throttle DOWN. Push the throttle forward, and the graph disappears to the left.

Fyi I deleted the post because I realized that by me adding a bind for increase/decrease throttle, that was causing the weird needle jump in the aircraft I wasn’t having engine power with.

Once I moved it to default, that needle jump issue went away however the engine power problem was still there on other aircraft. I’ll take your recent advice and report back. Thx!

Are you on DISCORD? I could talk you through some of your issues.

1 Like

Yes I am on discord. I’m also from/in Texas so way to represent a helpful attitude fellow Texan :slight_smile: