Xbox app launch frequently leads to BSOD - Go with Steam version?

I have experienced repeated problems launching game under Xbox game pass through the Xbox store. A MS Defender window comes up about running “Microsoft Store Package Dependency” and then no matter whether I answer “Yes” or “No”, I get a BSOD.

The problem settled down for a while after following the instructions under the Support post “How to Troubleshoot Loading issues”, specifically the instructions related to the Xbox app. However, they’ve recently cropped up again - I think after a Windows update, but not sure. After a number of hours and reloading Xbox app, checking Xbox Services etc., and making a Defender exclusion for Xbox Live and MSFS, the app is up and running again.

Seems like it’s all related to Xbox/MS Store, not MSFS itself (once game successfully launches, it’s ok).

I used the Xbox game pass as a good way to trial the game, and do plan to now purchase it. Getting it with 20% discount under game pass is attractive, but I am worried that this problem is just going to keep cropping up, even after I purchase game outright (i.e. not using it under Xbox game pass).

So question is what are others experiencing and how do they resolve? Given there is a support article on it, I assume there must be many others experiencing problem. Does it go away once purchased through Xbox/MS Store (ie. not accessing it under Xbox game pass)? Or should I just buy it through Steam and get rid of Xbox app altogether? The 20% discount through Xbox/MS Store is not worth it if I have to go through this hassle with Xbox services over and over again.

Thanks for your time and input.

because of Xbox App ?.. I fear there is another reason for a BSOD…

Users run normaly into CTD. BSOD points normaly to hardware or driver issue.

But, who knows :slight_smile:

Hmm… I hope not. I’ve updated GPU drivers and run troubleshooters.

The fact that the “Microsoft Store Package Dependency app” message comes up immediately before, seemed to me to point to the MS Store as the source of problem.

But “who knows” as you say.

Just my recent decision here, other could have better experience (I hope), but here what I wrote recently:

1 Like

Hey thanks for this and for the link over to the discussion on your thread. Interesting!

The one thing I’d like to get confirmed is what one poster there claimed - if you buy from MS Store, you don’t need to run Xbox app to launch the Sim. I think the Xbox app is a big part of the problem.

You can use the shortcut (bugged as too small, unreadable, another problem I forgot to mention) created for each game to launch them, and the Xbox app don’t appear, but not sure it’s not launched in background anyway.

Hmmm… thought I saw a MS help page saying to always launch from Xbox app, so haven’t tried the shortcut. Perhaps I will.

Thanks

It should be an old help page (I hope) as the XBox GUI allow you to create directly a shortcut when right clicking on your game at the left (from memory). I didn’t have less or more problem using shortcut. Just their display size which was really tiny. I found several post giving solutions (change icon display size back and forth using right click in empty space in the folder where my shortcut was) but it never worked for me.
Oh man, now I’m out of this, pffiiuuuu happy I am :wink:

Successfully launched from shortcut!

I also noticed an “optional” driver update for Intel Services (or something like that). I installed that first so that may also have helped.

UPDATE: spoke too soon. After running Sim for an hour or so, thought okay let’s test this. Closed it. Went away for a few minutes. Came back, relaunched from shortcut… BSOD. :frowning_face:

1 Like

I still assume/fear the BSOD comes from your system. If so, you possible search the issue “at wrong place” :slight_smile:

The only idea about a software issue is the Defender… you realy checked that all MSFS folders ( installation and content ) are in exclusion list ?

Please add your system specs ( cpu,gpu,psu,drivers, ‘special devices’, somewhat wireless, … ). Possible check whether windows have logged somewhat into the windows event viewer log.

Then,. have you tried to check windows installtion with dsim and sfc ?

Yes perhaps I did post in wrong place. I don’t know enough about what Windows does I guess. I just know it crashes only when I’m trying to launch the Sim. If wrong place I’m sorry. But thanks for your help anyway.

Even if in wrong place, since I’ve started, here’s what happened next…

I’ve checked exlcusion list, but since MSFS app is buried so deep it’s hard to know if I included “all” folders. If you exclude the top, it should exclude all, no?

I updated mobo and gpu drivers and that led to Activation issues which took a while to resolve. Then I have run dsim and sfs and it did come back saying it found some file issues but fixed them. But still got BSOD after that. But after going and checking all Xbox services were “running” I have had some successful launches today. I have also looked at events but don’t know how to read that. Saw something about cloud services so ensured One Drive was closed before next launch, and also all USB peripherals were unplugged before launch. And had a successful launch. I guess I’m just going to have to get used to doing this careful set up before launching program. Annoying!

So in short, done a lot to system, had some successful launches and some crashes. Maybe just have to get used to it.
Thanks again for your time. No need to reply if this is the wrong place.

i5 9600kf @3.7, 16 Gb Ram, Radeon 570, Gigabyte Z390 mobo

I think what he meant is that you searched in the wrong area of the forum - I think!

But your topic is in the right place. :wink:

Okay. Thanks!

p.s. I have purchased the Sim from MS Store earlier today and have since deleted Xbox app. Not enough good experience yet to say it’s made a difference.

1 Like

sorry… I see again: I need a english training :grin:

I not meant your thread is wrong :slight_smile:

What I wanted to say is ( double checked with translator now ):
we search the possible issue with the precondition " it must be somewhat with the Xbox/App or Defender"… But possible it is a completly other reason… We should look in another direction to find the reason. So, possible “place” was the wrong word :slight_smile:

Now… I see that you own:

Have you increased the windows virtual memory ? ( 4gig min/20gig max or more ) ?
Normaly BSOD comes not because of these, but is worth to test.

You mentioned that you get windows event logs. Can you share one of it ? ( just latest ERROR related to FlightSim… ).

Also…
some users with an ATI card reported issues with specific driver versions. Possible re-check this to ( I own an NVIDIA ).

Thanks for your reply and no problem, your English is very good.

[quote=“MichaMMA, post:14, topic:361258”]
Have you increased the windows virtual memory ? ( 4gig min/20gig max or more ) ?
[/quote] I have increased VM yesterday to a max of 24,576 using a formula I saw under the CTD avoidance guide elsewhere on this site. I don’t know what I put for min - will check if it is 4gb.

Not sure how I would share it on here - and which logs? I did send them to a son-in-law who is a techie guy and his comment was it’s like searching for needle in a haystack. LOL

Good to know - I will search for more info on that.

Thanks!

p.s. regarding ability to get rid of Xbox app after purchase: no can do. Today (after I deleted app yesterday) the MS Store says Sim is not in my account despite my having a purchase receipt from them yesterday. I reinstalled Xbox app, signed in and … voila, “you own this” is the message. So I only own it if keep the Xbox app?? Now I’ll brace to see what happens when Xbox game pass expires in a few days. With the record so far I am not optimistic.

no private data are necessary ( and you should never post logs which looks ‘private’ ).

For us interessting would be a ERROR entry from event viewer:

Possible somewhat with Flightsimulator.exe… simple copy/paste the text.

lot of users mention a ‘formula’. But simple and easy : set what you need :slight_smile: A formula exist only for “system managed” settings. MSFS needs overall at least 32Gig memory. With 16Gig RAM you can set 4/20 or also, because you allways need more 8/30. Lots of users with 16gig RAM helped this setting.

Hey sorry for delay getting back to you. I’ve been away for a few days. If you are still interested, there were a number of errors in the events logs, but here is one that may be relevant for around the time of a crash:

Log Name: System
Source: Microsoft-Windows-WER-SystemErrorReporting
Date: 2/6/2021 4:27:50 PM
Event ID: 1001
Task Category: None
Level: Error

Description:
The computer has rebooted from a bugcheck. The bugcheck was: 0x0000012e (0xffff9c8ee3891010, 0xffff9c8ee1106010, 0xffffd6792c6c4a00, 0x00000000000aa000). A dump was saved in: C:\Windows\MEMORY.DMP.
Event Xml:

Another one was:

Log Name: Application
Source: .NET Runtime
Date: 2/6/2021 4:23:58 PM
Event ID: 1026
Task Category: None
Level: Error
Keywords: Classic

Description:
Application: etocfile.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
at etocfile.Program.Main(System.String[])

1026
<TimeCreated SystemTime="2021-02-06T21:23:58.1081004Z" />
<EventRecordID>8379</EventRecordID>
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Channel>Application</Channel>

<Security />
Application: etocfile.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.FileLoadException at etocfile.Program.Main(System.String[])

I have reset the VM but not sure I followed your guide as I am not sure what you mean by 4/20. Is that 4gb / 20 gb or 4X16gb / 20X16gb ?

Thanks

:roll_eyes: you have GigaByte EasyTune Overcloacking Tool running ?
For this is your error report :slight_smile:

sorry, I was possible not exact enought.

I mean Minimum and Maximum Setting of windows pagefile. Here is a Screenshot which Windows-Dialog I mean.

https://forums.flightsimulator.com/t/ctd-issue-persists-fix-it/313199/19?u=michamma

Where I set 1024: you set 4096 / and where I set 4096 you set then at least 20000 ( more more ).

Thanks for reply. Yes there is a gigabyte software running. Im not sure it does overclocking automatically does it? Just a management tool I thought. Can it be deleted without running into problems with mobo.

Thanks for other clarification.

not sure,… I own asus board… but at least, if these tool cause a crash… hmmm :wink:

I think you not need to “delete” it, just not let run it all the time. There are similar tools for asus boards, also with overclocking features etc,… but I use these only for monitoring and I start these tools only if necessary ( no autostart ).