Xbox compatibility with Honeycomb

A brief update to whet your appetite…

My XPC Alpha is running beautifully on the Series X. I have now configured the Bravo to my liking although I have yet to decide just what functions I want on some of the switches. The Bravo lights still do not work though. I am just waiting for the promised software update to see if that is fixed. Note, the update will have to come from Asobo I guess, because there are not a lot of options to add external (eg Honeycomb) software on the Xbox. I am on the SU10 Beta version but that is not currently helping, so … fingers crossed. The final SU10 must be very close?

But take it from me… it will be worth the wait!

That’s really great to hear, thank you. You mention a “promised” software update - who’s promising this?

I got that from Honeycomb after I asked for some help soon after receiving the gear. Here is part of their reply:

“Your shipment was despatched ahead of schedule, luckily for you.
However this has meant that they were available before the update to the Xbox software. Once the software is updated the issues you are having should be solved.”

Appreciate the appetite whetting! You’re definitely one of the few who have it.

As of this morning, FedEx is en route with my XPC finally! Gonna try and find a FedEx livery and ensure it gets here safe and is handled appropriately.

1 Like

Is there anyone in the UK got their xpc unit yet?

Hi I got mine today but I’m having a hell of time trying to get anything to work on the Bravo front - in all honesty I’m sure what I’m doing! But I know enough to realise there are issues. The Alpha works fine I just need to configure it - the bravo only one throtttle works nothing else on it does! Trying to configure it seems impossible as it won’t recognise any input when scanning so I’m at a loss to know how I can set up a profile - anyone that help I’d be most grateful!

1 Like

Ok it’s not easy but I’ve configured the bravo on XBox - it’s taken ages! If anyone is struggling I’m no expert but happy to help. As others have said on here no lights work but everything else seems ok

I have yet to get the xbox to recognize any inputs from the bravo. The XPC seems to function correctly but I haven’t went through all of its inputs due to the frustration with the bravo. I do not get any response while in the control options or even trying to move things around in the game. I keep reading that most people have theirs working minus the landing gear lights and I’m not sure what I’m doing wrong or what else there is I can do? Do I need to try and update software within the Bravo somehow? I just purchased the Bravo at the same time I preordered the XPC so it surely isn’t isn’t old stock needing updates

You didn’t mention the Hub, but are you aware the Bravo needs to be connected to the Xbox via the Honeycomb Hub which, in turn, is connected to the back of the XPC.

I have the XPC set to XBOX, plugged the Bravo into the hub, then the hub into the XPC, then the XPC into the xbox in that order, Then turned the xbox on

It took me hours to sort this - it will try your patience and you have my sympathy. The hub and Bravo do work but it’s not straightforward and it’s not intuitive at all.

Out of the box the bravo can appear not be connected at all. There are no lights and moving throttles doesn’t seem to work. I tried re connecting several times (I almost gave up thinking the hub was faulty) when I realised that one throttle lever was working. Also the Bravo doesn’t always connect - it can be fine then on next start up nothing - it’s very hit and miss. You just need to restart again and it will work eventually!

Once you know that it’s definitely connected as one lever works (there are no lights - these do not yet work on XBox as an update is needed first which is yet to happen) mapping can begin. Trying to work out the numbers for the various throttles and buttons is trial and error. At some point I may have a go at labelling them but on XBox I found that nothing matched any numbered diagram I could find for PC and most You Tube videos were for set up on a PC.

The good news is once connected I found the gear lever and most of the Autopilot buttons corresponded to the aircraft (a320 and Cirrus) I fly most often.

I’d recommend:

  1. Keep trying to get a connection till you find one of the throttle (mine was the left middle lever) on the default airbus. Go into a flight and move the throttle
  2. Once connected use trial and error to map the other throttle levers and flap controls - you can save this as a new profile don’t delete the original profile rename when prompted.

Don’t expect any lights on the Bravo to illuminate they may flash on and off briefly when connecting.

This isn’t what we expect from a plug and play device it’s frustrating and long winded but it does work (Mainly) - I don’t think you’ll find any support direct from Honeycomb there customer service is largely absent sadly. Hang in there!

Hi all, just wondering the Throttle Quadrant will work independently on XBox?

No, the hub goes into the XPC.

Cheers. Just wondered if it would work independently with the XPC adapter with the V1 yoke.

Just received my Alpha XPC seems to work ok with the hub and somewhat with the Bravo quadrant. It’s supposed to work with Logitech rudder pedals as well, but when you plug them into the hub, the Bravo quadrant disappears. Honeycomb told me they were supposed to work and to get help from Logitech. Anybody out there get the Logitech rudder pedals to work? I assume the Charlie pedals work so that’s an option once in stock again I guess. All in all, pretty buggy still. I have all the MSFS updates installed as of today - Xbox Series X.

My pedals just worked without issues. They are old ones with the Saitek brand name, but I understand they are the same as the Logitech brand pedals? At first the toe brakes were not working, despite my attempts at ensuring they were mapped correctly.

But one day, without me being aware of anything I did, they worked! (Yes I must have done something, but I don’t remember what!)

Of course the pedals must be connected to the Hub, along with the Bravo, but your post reads as if that is the case for you. So, I have nothing to offer, other than to confirm they DO work for me and they should work for you.

Maybe check the pedals are working OK on another (PC?) system just to be sure they are OK.

Good advice and thanks for responding. At least I know it works for somebody! If I get this working, I will post the trick (if there is one).

Working now. All I did was verify the pedals were working on a different system (they were), then plugged them into the hub, then powered up and waited for the green light to light up on the pedals before starting MSFS, then started MSFS and now everything works. Now for some flying!

Hmmmm, can’t really explain that, but who needs an explanation? They work and that’s all that matters.

Glad to hear it.