[XBox] CTD on Start Up after installation of the WU IX Italy

They are aware of it and working on it.

I’m starting to think number 9 is quite unlucky as also SU9 is probably the worst update ever


Topic Author @erasam was informed this is a duplicate report of a larger thread and also provided latest update on mitigation.

Maybe we should all be getting on Microsoft more, not Asobo. MS can give them more resources to get things working better. MS has plenty of CASH to help.

For those currently unable to launch on Xbox Series X|S due to World Update IX, we have just released a beta build to the Xbox Insider Hub. If you would like to help validate our fix, please join the build using the following steps:

1 Like

Actually, according to today’s Development Update, it looks like the crashes were caused by a mandatory update for the generic airport data folder on Xbox not by WU9 itself, which explains why some users who said they did not download WU9 also experienced the startup CTDs.


Currently the beta patch is working fine for me. So far, there are no additional bugs to the ones that are already there that I have noticed. I test further today

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

the software loads and I managed one flight. But on completion when I tried to load a second flight the game froze. I restarted my console XBox X but now when I try to load a flight it freezes on the loading splash screen.

If relevant, provide additional screenshots/video:

Hi, Installed the Beta update and great I can get passed the “NEW ACTIVITIES” screen, Able to take off and fly but CTD when landing.

1 Like

Just loads up to Italy splash screen update then quits to xbox home page for me.

Welcome to the xbox crash club. I can’t even load the game up after the Italy update. Crashes back to home screen. Getting exact same results as you guys. Its bricked.

You just looking for bias confirmation, or what?

As I suggested to you elsewhere:


Can you give us a bit of detail on what does this update update fix?

Read the start of the thread that linked post is from for more details.

WU9 introduced an issue that caused a number of Xbox users to experience a CTD (Crash to Desktop/Dashboard) during the startup of the sim.

The patch addressed that, and only that, issue.

However, for some, it didn’t work until they cleared their Reserved Space, hence my suggesting that course of action for you.

I think there’s a lot of scenery DLC that might be messed up with SU9. I know Global shipping is one for sure, how many others?



MSFS on cloud simply still doesn’t launch anymore since Update 9 came out.

1 Like

I have been on it every day this week and no problems.

1 Like

I have got the same issue it just keeps on crashing

The interesting bit about the WU9 update is this - almost simultaneous with the WU9 release a “mandatory update for the generic airport data folder on Xbox” was pushed out.
I didn’t download WU9 - but coincident with this pushed update, the flash screens changed, and I started to experience huge stutters and a CTD. The PG scenery at EGHI also went to pieces. All within minutes of this compulsory update (at the time I was puzzled as to why I suddenly experienced a batch of major issues)
So the questions I’ve got- to what extent did the pushed update cause problems? It definitely did to me - though not the CTD on start-up - or was it the combination of pushed update and WU9 that caused the CTD problems? And if it was the combination, was the order in which the two updates were applied critical?
Definitely highlights issues in configuration control at work, I’d say - and this IMO is one of the root causes of many problems, especially once third party add ons are included in the mix…

Particular Issue resolved with the latest patch.