Xbox WARNING License Authentication error on startup Xbox Series X

In the Evening Hours this issue about 6pm to 2am eastern US this issue crops Up on sign in I started a support ticket but the Issue remains they forward it up and the said post it here. So after 2am or from 2am till 6pm the sim runs fine I’m on the Original Deluxe Premium release and when the 40th Anniversary auto update xbox series X the above started Happening

TS_Steps: reinstalled Flight sim completed Issue remains

[ Issue resolved ]

When I logged on through Xbox today I got a message saying that my licence needed to be authenticated and services all show offline. Tried restarting, rebooting etc but no online services. Anyone else experiencing this? Have a fix? Thanks!!

I had this happen to me today, it had been fine this morning & and when I tried to log in this evening, the “can’t authenticate your message” kept popping up when starting the sim. I could click OK, and it would load into the game, but I had no Live Weather, no Multiplayer, no servers to choose from and it just said “Automatic” and the loading wheel beside it just kept spinning. I tried various things (signing out of MSFS, hard reboot of the Xbox, etc) but nothing changed.

I was in the Xbox Console Update Beta (not the Flight Sim beta) and just in case this was causing the issue, I left that beta. It said that if I left the beta, that I’d have to update the console & set it up again (like it was out of the box), but that none of my games would be affected. After leaving the beta, restarting the console & starting Flight Sim, it turned out that my Reserved Soace had been deleted (all 270Gb’s). The funny thing is, the game started perfectly, no “can’t authenticate your license “ message, Live Weather, Multiplayer & my my servers were back.
I’m guessing here, but I think it was my Profile Data that might have held my digital Cert (?), or just that the profile got corrupted, but as it’s only a few Mb’s, you should try deleting it & see if it fixes your issue?
If my profile wa corrupted, I’m guessing that this was the reason that my licence couldn’t be authenticated.

Try deleting your profile, it’s only about 15mb and it’ll download from the Cloud when you restart the sim.

At the Xbox Homepage, highlight the sim (with tge green box), on your controller press the button with tge 3 horizontal lines ~ select Manage Game & Add Ons ~ select Saved Data ~ highlight your profile- press the button on the controller with tge 3 horizontal lines and Delete Saved data.

It’s working perfectly for me now.

Edit: I’m recommending to delete your profile, because it’s only your profile & add ons that are stored in the Reserved Space (E.g. World Updates, Premium/Deluxe add ons, Bush Trips and anything downloaded from the Marketplace). I can’t see how DLC could affect the licence, but I can see how a corrupted profile could.