Yoke and rudder pedals not detected

My CH yoke and Logitech rudder pedals are not being detected by the game. They do not show up on the device listing in Options → Controls.

dxdiag shows both devices are present.
joy.cpl shows both devices are present, and they show axis movement and button presses

I was in the alpha and had no issue with this same hardware.

joy

+1 for me Ive got pedals and Saitek X55… nothing in options… nada.

Same for me as well.

Saitek Combat Rudder Pedals
CH FLIGHT SIM YOKE
TM Warthog HOTAS

Only difference from the Alpha/Beta builds is that I’m on Steam… in case that helps.

I am on Steam as well.

Things I have tried:

  • Running Steam as admin
  • Verify integrity of files
  • Uninstall/reinstall of the Steam app (used the same content directory)

Just change the filters on the left side from “ASSIGNED” to “ALL”.

If only it were that easy…

As you can see the devices in question do not even show up

Filter set to all doesn’t do anything for me either.

In the alpha the device would show in the bar, even if never used before. Something is causing it from detecting extra devices, just not sure what it could be. My dxdiag output lists multiple keyboard and mouse devices

-------------------

DirectInput Devices

  Device Name: Mouse
     Attached: 1
Controller ID: n/a

Vendor/Product ID: n/a
FF Driver: n/a

  Device Name: Keyboard
     Attached: 1
Controller ID: n/a

Vendor/Product ID: n/a
FF Driver: n/a

  Device Name: Gaming Mouse G502
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x046D, 0xC332
FF Driver: n/a

  Device Name: CH FLIGHT SIM YOKE USB 
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x068E, 0x00FF
FF Driver: n/a

  Device Name: Gaming Mouse G502
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x046D, 0xC332
FF Driver: n/a

  Device Name: Programmable Hotkeys
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x06A3, 0x5081
FF Driver: n/a

  Device Name: Flight Rudder Pedals
     Attached: 1
Controller ID: 0x1

Vendor/Product ID: 0x06A3, 0x0763
FF Driver: n/a

  Device Name: Natural® Ergonomic Keyboard 4000
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x045E, 0x00DB
FF Driver: n/a

  Device Name: Gaming Mouse G502
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x046D, 0xC332
FF Driver: n/a

  Device Name: Gaming Mouse G502
     Attached: 1
Controller ID: 0x0

Vendor/Product ID: 0x046D, 0xC332
FF Driver: n/a

Poll w/ Interrupt: No

I just realized I am on Windows 1903. I’m updating now to 2004.

Similar issue with x52. Device doesn’t show up in the options menu, only Keyboard and Mouse. Additionally, it reliably crashes whenever I try to plug it in with the game already running. Also on steam

Solved for me. In Steam, right click the game > properties. Set “Steam Input Per-Game Setting” to Forced Off.

2 Likes

Thank you @Nightman897 that resolved it!

1 Like

That did it! Appreciate it!

1 Like

Hi. I’m not sure what you mean but can you explain what to do. I have the same problem. My controllers are not working with fs 2020.

If you are on Steam, try this (in Steam):

  1. Right-click on “Microsoft Flight Simulator” in the Steam Library
  2. Click “Properties”
  3. Change the “Steam Input Per-Game Setting” to “Forced Off”

image

THANK YOU! It’s fixed. Appreciate you my man.

1 Like

I wished that this would solve my problem. Unfortunately, I don’t have the Steam version.

There’s no such setting when I look in the properties page. I think this was removed.