Yoke Axis Recognized in System but works as Buttons Only

Hello, first of all, I would like to apologize as this thread is kind of a repost of another thread in Self-Service. After being unable to find help there and realizing this is a bug I opened a ticket in zendesk and wanted to also post about it here. If moderators find it necessary, they can delete this thread.

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

No add-ons.

Are you using Developer Mode or made changes in it?

No, dev mode wasn’t activated

Brief description of the issue:

I recently bought a CH Products Flight Sim Yoke and I have been trying to configure it and have been trying to fiddle with controls for such a long while and axis controls aren’t recognized properly by MSFS2020 only.

The Axis’ -both ailerons (x) and elevator (y) axis and all three throttle axis’ (x,y,z) are recognized by my windows 10 system (checked on joystick configuration) and also by flight simulator 2020’s sensitivity configuration menu. But when I map the joystick axis’ to primary control surfaces they don’t move at all.

The “Joystick L-Axis X” type of controls don’t work at all, but “Joystick L-Axis X- and X+” are recognized as buttons.

When the axis control “Joystick L/R-Axis X/Y/Z” is selected the control stays stationary when I’m actually moving my yoke… The x/y/z- and x/y/z+ movements are recognized as if they are buttons, just not recognized in the whole axis while any other app or sensitivity tab recognizes the movement as if it
is an axis.

When I try to move the yoke for the game to automatically recognize the axis instead of manually mapping it, it doesn’t recognize the whole axis “Joystick L/R-Axis X/Y/Z” but instead, a button as “Joystick L/R-Axis X-,+/Y-,+/Z-,+” depending on which direction I rotate my yoke.

Detailed videos of this behavior are included in attachments.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

1-Map any axis control to an axis on your controller.

PC specs for those who want to assist (if not entered in your profile)

As per controllers, the following are connected:
CH Flight Sim Yoke (the one with the problem)
Saitek Pro Flight Rudder Pedals (axis’ on this controller work perfectly)
MM710 Gaming Mouse
Logitech G710 Keyboard

My PC Specs: AMD Ryzen 5 5600X 6-Core Processor. 16.0GB’s of ram, RTX 3070 GPU

Did you submit this to Zendesk? If so, what is your ticket #?

Yes, ticket number: #94843

Solution found:

You have to delete the input, then confirm (not try to reassign while it’s already assigned).

THEN pick the axis (e.g. throttle 1 axis) from the big list of unassigned input again and assign the axis using the lever. Now it magically works.


This is such a common issue, wonder why it has not been fixed yet. For example when they ‘reset’ the cockpit movement keys, and then later the SPACE binding for landing view. BUT SPACE was already bound. You actually had to unbind and rebind it again to start working.

1 Like

Does not work for me. NOT A SOLUTION

1 Like

I have the same issue i.e., I have CH Throttle quadrant and cant assign any axes to the throttles and if an axes is assign to throttle ,mixture or prop control the cockpit throttle act erratically.
This issue only started with the last MSFS update. It is only a problem with MSFS because the CH Throttle work fine with X-P***12. I will add that my Logitech Pro joystick throttle slider works fine.
I tried everything suggested on the forums but still not working.

Perhaps its better to contact CH Products?

Any assistance would be wonderful

Running MSFS 2020 on PC.


It is a bug that occurs specifically between several Joystick interface cards and MSFS. If you switch to any other Simulator, you will notice that the problem does not occur.
In some more advanced simulators, I was only able to resolve this by switching to SPAD.next and letting it take control.