"Your Game Needs an Update" screen stuck

MSFS 2020 Store version for PC
I am getting a message since this morning “Your Game Needs an Update” but the Downloading progress is not moving from 0.0 B of 0.0 B | 0.0 MB/S
It has been like that since this morning. I have rebooted the computer and logged out and back in of the MS Store.
What else should I try?

1 Like

I had exactly the same, stuck at 4kb/0% of download. I closed the sim down, went to MS Store library, clicked on Open at the sim library entry, that took me to the XBox app and I downloaded from there no problem.


Working now.

1 Like

Not working for me. Exhausted all possibilities. Totally lost as of today 23 June 2023

It just sits here doing nothing. Tried launching though xbox ,ms store, signed out then in, updated drivers, reset gaming svces, rebooted, … when trying to update through store it calculates duwnload size. Then starts download but stops and I get “something went wrong this end”. When trying to update through xbox, I get some error code that I can’t recall right now.
Checked ms store servers and they report all good. Why is this happening all of a sudden??
Was working fine yesterday. Before this started, the gaming services were updated today.

Store version premium deluxe.

I had the same, but I remembered that I had blocked windows updates temporarily. I enabled again, than I opened the Xbox app to updated and after when I opened the MSFS it download the updated successfully.

I don’t remember blocking windows updates but I do have Windows driver updates blocked. Maybe that has something to do with it? Will check that tomorrow…

What I did do that was successful is that I swithched to a VPN and it updated immediately. Go figure! Only problem, it uninstalled RJAA by Drseweiki (excuse the spelling) and LimeSim BER that I bought through ORBX. Weird! Had to reinstall them through ORBX Central.
Switched back to non VPN and the sim starts fine. Very strange but it worked.

1 Like

What country did you use

  • List item

I have no idea. I enabled my Kaspersky + VPN module then turned it on. It doesn’t give a country option, though I just read how it works here but I can’t seem to find a setting to select a country

Ooops… yes there is a setting within the VPN module that allows one to choose a country. I didn’t even do that! Maybe it picked one randomly?

Next time I will choose. I did notice that when going to Netflix while on VPN I could not sign in using known credentials. I have no idea why.

Just looked at settings and the place to choose country is checked as automatic. I can change that, then make my own choice.

So I guess I was lucky.

One more thing happened that might have cuased this entire problem. When trying to sign in here, I wasn’t able because Microsoft said that I enabled 2 step sign in which I never recall doing!! Because I didn’t have their “authentication” app, I couldn’t insert a code to sign in.
Got the app on my phone, then finally was able to sign in! Perhaps that’s the most logical explanation for this whole debacle and the VPN thing was just a coincidence?