Zlin Ultra Shock (MSFS Premium Delux aircraft), wrong speed bug, crash during flight

Afetr one year it isnt solved. I opened a ticked at Zendesk, they marked as solved but I tested it in SU6 and no ANY CHANGES. So its not solved.

From Zendesk:
This is second part about this model so its continuation of bug Request #112632 (pls check it alos).
Model has wrong all range of speed, its a bug probably not understanding that is has speed gauge in kilometers per hours, not miles or knots.
Real data you have below.
Example 1:

  • model : full throttle (forward), fixed, horizontal flight - about 100-105 km/h (with max power!), when in real life it should be about 160 km/h (near green and yellow arc on speed gauge).
    Example 2:
  • real life, cruise Shock Ultra with this engine at 75% Power — 87 mph / 76 knots means 140 km/h (on gauge in model), but the model flies with 70-80 km/h … so worse than old Piper Cub from 1941.

In horizontal flight, even with full throttle (on about 2000 ft) its impossible to reach green arc on speed gauge even, with which there shouldn’t be a problem at all.

All this causes the model of engine to be there underpowered. Pls fix it, thank you.

Maximum Cruise Speed — 112 mph / 97 knots (180 Km/h)
Cruise at 75% Power — 87 mph / 76 knots
Range — 323 nautical miles
Maximum Climb Rate — 1,000 fpm (2 meters/second)
Minimum Flight Speed — 21 mph / 18 knots

Hi, this is my favorite default plane - Zlin Shock Ultra, however from the beginning (so August 2020) it has crash problem during descent. The model HAS WRONG SPEED for overstressed, something about 110 km/h. Please notice its still GREEN line on speed gauge (see screenshot). For this plane IN REAL LIFE MAX SPEED S.L. is 180 km/h (112 mph), no 110 Km/h (!). Please fix it finally, Thank You!

Performances: AeroSavage.pl - Savage Shock Cub - Samoloty Savage

Did you submit this to Zendesk? If so, what is your ticket #?

Request #113079 Zlin Ultra Shock model - wrong speed performance

Request #112632 Bug with structural crash of the plane - wrong max speed

Request #123231 Re: Bug with structural crash of the plane - wrong max speed

I’ve reported this in the past also. Nothing ever changes. The dial on the gauge is showing the plane’s actual speed in knots even though the dial units are supposed to be km/h. They broke it way back in SU2 or SU3 and have never bothered to fix it.


Yeah, it is broken. The Mars Climate Orbiter crashed for the same reason, mixed-up measurement units, more than 20 years ago. And still, the same root cause in large engineering projects… :confused:

I hope the issue will be fixed soon, the Shock Ultra would be a great plane for bush trips. The XCub is also great, but for real bush experience I would rather fly a plane without glass cockpit.

They still didn’t bother to fix it in SU6 even though they specifically worked on the Zlin Shock Ultra. :man_facepalming:


I am sure it will be fixed. They had to prioritize the critical bugs, and to be honest this is not a burning issue. Very annoying issue indeed, but there are alternatives, the Savage Cub seems to work fine, the XCub as well, especially with the Bush League Legends mods.

Let’s see if it is included in the next update.

(Personally, I still believe than it would have been better to include fewer planes in MSFS from the start, and make those in better quality. We got 3 different Cub variants, but why? None of them are fully modeled. Anyway, I go back, flying my usual 152/XCub and wait for the next update. )

That is what I thought when I saw it.

Still the same :frowning:

Hi, in SU7 finally its solved from now, thank you for the support here.

1 Like

Ok, but the new bug in SU7:

1 Like

I haven’t tested it yet, the air speed indicator bug is finally solved (again)?

Yes its solved what is great news for me.

1 Like

I heard that in the other variants itsn’t solved :sweat_smile: :confused:

EDIT: I mean the floats and the skis ones.

Yes? :frowning: I tested only wheel version, will try.

1 Like

Confirmed by myself, the wheel version is fixed, but the floats and the skis not. The airspeed indicated in the cockpit is in knots instead of km/h, wich is it’s scale.
Another partial fix.

Pic with the floats version

EDIT: Please, notice that the speed indicated in the HUD is in knots, that’s why I showed up the HUD in the cockpit in this screenshot

1 Like

i have trouble taking off with the zlin shock ultra. As I increase throttle, the engine revs up for an instant and then starts to die. I had no problems with other single engine aircraft such as the cessna 152 of the zlin savage cub. Do I need to do anything different with this plane? Like let the engine warm up etc?

They’ve fixed the airspeed issue now, it’s working in km.

A little disappointing they didn’t program all the switches for such a simple plane, didn’t expect to see so many “inop” in this one.