Zoom Custom View issues

Hi,

There is a problem with the cockpit view :

When i save a view and reload it, the zoom of the view is not saved.
For all the views that I save, when I reload them, the zoom is at the minimum.
I’m now forced to zoom in on all the views that I load with my mouse.

Nobody has this problem ?

Thanks

Did you assign a custom view and also setup custom views on your keyboard? I use RightCTRL 0 as an example. here’s a great tutorial on custom view setups.

https://www.youtube.com/watch?v=qMlwAmTYHwA&ab_channel=XP72

Are you on about the zoom setting on the camera drop down menu when in flight?
If you are and want to save the zoom you set there you have to go into the pause menu, go into camera and adjust the zoom level there, then click apply/save and it will keep the setting.

Yes I can define views with the shortcuts but the zoom that I configure for each view is not saved: when I reload the view with my shortcut I’m too far away!
I found a solution: I define my view by zooming in more than necessary so when I reload my view I have the right zoom.

This drove me crazy as well!

The cause was that before setting up custom camera views I had used the default cockpit camera settings to adjust. Resetting the height, position and zoom sliders back to default 50 on those and then setting up custom camera views solved it.

@FlySKy7777 it might be worth editing the topic title for better clarity, as it only affects custom cameras - this may make it easier for others to find and help with voting.

I also found that EVERY custom view did not appear to save correctly - when returning to the view I’d just saved, the camera would be too ‘close’ to the instrument panel.

The workaround was to move the camera further away than I wanted before saving the view, but it was a lot of guesswork.

I can confirm that a ‘fix’ is to set the default cockpit camera zoom to ‘50’ in the menu (it’s original value). This is found under General Options > Camera > Zoom.

When set to ‘50’, everything works and the sim even saves the zoom level with each custom camera. If you don’t use 50, then this happens:

  • Using default zoom > 50 results in the saved custom camera being closer than you wanted it
  • Using default zoom < 50 results in the saved custom camera being further than you wanted it

It’s very frustrating, as I don’t like the default zoom of 50. I feel it’s a bit too wide angle for my tastes and I normally use 60.

I logged it via Zendesk, issue number 130303.

A related side issue I also discovered:

What’s more, there’s a bug that effects the min/max zoom level when saving custom views. If you have a default zoom < 50 and save a view, your new view will be too far back / too wide-angle. If you then resave that view again, switch to another view and back, it gets wider still. It does have a limit (0 zoom), BUT if you drag the zoom slider in the pop-up camera window, the angle gets more and more wide after each new save of the camera.

The result can be an ultra-wide fisheye view or an ultra-zoomed telephoto view. Far exceeding the normal limits imposed by the sim.

Example of zoom ‘0’ after first saving a custom camera (note zoom = 0 in the camera panel):

Example of zoom ‘0’ after saving the camera, switching back to ‘Pilot’ and back to my custom view, resaving. Repeat this 3-4 times, then the camera zoom slider gives you a wider and wider view (in this case, only when the default zoom in the menu is < 50):

You can’t normally get this kind of angle with zoom = 0.

It’s not a problem as such, but may help to understand what’s going wrong with how the sim saves the camera.

In summary, no matter what zoom level is saved with the custom camera, the in-game zoom slider will always be set to your default zoom when you first switch to your custom camera. So you can then zoom in/out even further, beyond any normal limits.

1 Like

It would be nice if Asobo does something to correct this…