1.37.11.0 After two to three normal starts, MSFS gets stuck checking for updates

After two or three starts, during which there are no problems, MSFS gets stuck checking for updates. Then two or three starts go fine again. After this, the simulator again gets stuck checking for updates. And this happens all the time.

I’ve had it happen once so far today as well.

I had this happen on first launch this morning.

I just quit the sim while it was stuck checking for updates and relaunched it and it was fine – Not that I’m advocating that this is okay…

Happened first load after latest build. After a restart was able to get one flight in before I started encountering the flight loading bar getting stuck at 3/4. Tried wiping community folder(well Xbox equivalent), leaving the beta, dancing on one foot whilst making a cake…. Said screw it and doing a fresh install.

To be honest, when I scanned this thread, I figured it’s just people with network problems. There’s always a few, right?

Then, the installation manager seemed to get stuck on my system, too.

I waited it out, it took a couple of minutes, then the loading process resumed as usual.

edit: It seems to happen “occasionally” for me. Maybe 20% of the time.

edit2: In the past days, since the last edit, I’ve seen the issue only once. Startup was smooth in the past three days. It feels like a network issue that has been resolved (at least for me) or is happening very rarely.

edit3: Nah, I was wrong. Still happening occasionally.

Have exactly the same porblem on .11

I am not on the beta but also had this problem earlier. Ended up killing MSFS using task manager, was ok after I restarted the sim.

Same here. Need to kill the process and start again

I had the same problem, associated with an endless download.

I’ve not had the problem since, though.

it may well be a network issue… I fixed it 100% repeatably by using a VPN… thread about it here - my post at the very top explains a very similar issue…

Should this be marked as a regression? This problem keeps coming back. My load time has been over an hour now. (30 mins on Check for Updates)

See this topic that was marked resolved previously:

Yes. can confirm this. It also happened to me a few times when starting MSFS and stuck at “check for update” display.

If you check the network activity in the taskbar, you’ll also see very high bandwidth is in use during this update checking, which is weird…

Happening to me right now, circle has been spinning for like 5 minutes whereas it’s usually instantaneous (or at least since a few sim updates ago).

It happened to me last night. I had to quiet and restart it. I’m on Xbox Series X

Had this happen again on my PC (rarely but occasionally strikes) running current beta, had no troubles yesterday. Rebooting didn’t affect anything, and an Xfinity speed test run showed me getting expected wifi-limited download speeds. Letting the screen run for 7 and a half minutes got it to move on to the next stage (dune pictures :wink: and after a few more minutes it completed loading and showed me menu.

I don’t have a VPN setup at the moment to test with, but I’ve had this kind of thing miraculously disappear with minor network changes before, implying routing or DNS may be at issue (eg, it’s sending something to a wildly oversaturated server or over an oversaturated route and there’s lots of slow round-trips in this checking screen).