~ 100% GPU load in the main menu

I’m a bit confused. I’m getting nearly 100% GPU load and a bunch of lags and freezes while just browsing through the main menus or while looking at the world map. My fans are going crazy, although I am doing nothing than just having the game open (not even flying or so!).

I have no complaints while playing. The game uses significantly less GPU / CPU load while I’m actually flying around. Somehow just the main menu is taking more ressources than flying around New York City.

i5 9600K + RTX 2060

Is this only for me?


Me too, although I have a GTX1060. I am thinking that it is because I am trying to render to a high res monitor. I plan to try changing the render scale to 50% to see if that helps.

Me too.

What displays do you use ?

BenQ PD2500Q. 2560 x 1440. 60Hz.

Another thread also suggested that limiting the frame rate in the Nvidia control panel to 30 fps helps. I haven’t tried it though.

1 Like

I’m running a Ryzen 3700x + RTX 2070 Super @ 1080p and seeing 100% GPU load in the menus.
Drops to about 70% once I’m loaded in with my current settings.

Surely this is some sorta bug? I’ve submitted a bug report.


Yes I get this. I don’t think it help that there a hangar animation going on in the background which would be nice if we could disable it.

1 Like

well of course you’re lagging while browsing the main menu mate…

assobo decided that rendering full blown scenery and airplanes in the background while you’re on the main menu was a good idea.

this is not a bug what so ever lol, just terrible developer design


Good. I was beginning to worry they were mining bitcoin while we change options.


I am really confused now. Once I minimize the window, my GPU and CPU blows up 100% load and it stays on 100% while the game is running in background… when I maximize window again, its just 30-40% load. I expected it do be vice versa.


That could be a bug. Some people reported the behavior becomes consistent with the windows in focus/out of focus if you set the CPU scheduling to prioritize background processes, from here:

Then it doesn’t matter if you minimize it or not, you’ll always get 100% CPU and 100% GPU usage in the menu :slight_smile: But as a bonus you might get better performance when you fly.

Of course, that 100% usage in the menus is usually not what you want, in which case setting a FPS limit from the GPU driver could help. The in game frame limiter seems to apply only while flying. But unfortunately the driver limiter could affect performance while flying as well, if you set that limit too low, so not sure if it’s a good solution.

One thing is for sure, that hangar rendering in the background in the menus was a really bad idea. It might have made sense to do that in the graphic settings window, so that you can preview some of the impact on performance, but not everywhere.


found in nvinspector “fps limiter v3” option and set half or 3/4 of your monitor resolution, in nv control panel it will “max frame rate” if you do not use any limitation like v-sync or fps locker, your gpu will rendering max fps as usual if game don’t have lock fps itself

I have the same issue: MAXING at 100% through the whole process.
The LAG I experience is sporadic at best. I can fly for 15-20 minutes with no issues at all and all of a sudden: WHAM! Catastrophic lag.
Hopefully this gets corrected.,

If you have airliner in the hangar as “main airplane” just change it to something smaller. xD

i mean…you wont be staying in the main menu for a long period of time?! but i agree it needs fixing

Same issue.

100% (98%-100%) in main menu. Sitting there I see spikes in the fps ranging from 48fps when just below 100% and then out of nowhere, it will jump to 100% and the fps drops to 12fps.

It is the same in flight. Flying along all fine at 48fps, then wallop 100% GPU and fps drop…leave it for a bit and either it stablises again going back to 48fps, or I get a crash to desktop (I assume it is toys out of the cot time).

My CPU are ar at 12% utlisation in the main menu, and roughly 40%-60% in flight.

Dell G7 7700 (i9 10th Gen - RTX 2070 Max Q - 32GB Ram).

Weird. I hope this is a “bug”, and the system seems more than fine to run this simulator and should be delivering…but the drops in fps is harsh and the 100% GPU…


only fix is to cap framerates :frowning:

This is crazy. I like MSFS20, but let’s be clear that for them to know this is happening and do nothing about it is unacceptable from a customer service perspective. I have an i9-10980HK with 32 Gb RAM and n RTX 2080 Super Max Q. Just sitting in the menu home page, my 2080 is between 97% and 99%.

This is shoddy programming and ■■■■-poor quality control. No way a reputable software company doesn’t know this is happening. And even worse, no hotfix for it. That 99% load is driving my laptop temp to over 90 deg. C steady, with no let up.

I can’t leave the sim too long on the menu or my laptop actually overheats. In game, the load actually drops to between 40 and 50%, even on ultra. I have never seen anything like this. Again, I love the sensation of flying, but I don’t trust anything these guys do or say from here on out. Also nice that there is no mention of it in the proposed patch. People not being able to install might be the lucky ones here.

btw, capping framerate in control panel doesn’t help. I have capped at 60.


I just submitted a ticket for this. The main menu gpu usage is disgusting and nuts. I loaded up DCS just to double-check, and my cpu is 39C at 2% usage, gpu 43C at 5% usage (fluctuating +/- a few %). But in MSFS2020 my main menu load is 60% cpu and 96% gpu, temps 50 and 80 respectively. I have an i5-9600K overclocked to 4.8ghz, and an RTX 2080. The menu doesn’t lag, but it shouldn’t be trying to melt my GPU. Is Asobo using my system to mine for bit coins or some ■■■■?

It’s driving me nuts.


same story, 100% GPU load on a GTX 1080 - just by browsing the menues, it’s going down to 65% while flying - clearly a bug!


me too 100%

RTX 2080 Super