1st hour relase load bug

Pre ordered the game, it doesnt even start… for me or my firends who also pre ordered it

sits on main splash screen with loading bar down the bottom.

very disapointed… how long till this is fixed?

Restart the sim and it should work!

your not telling me to turn it off and back on again are you? think i not tried that?

same with my friend we have tried running it a few times. bar always stops at the same point

Press Alt+F4 to shut it down, then restart.

Same Prob, restart Pc , Reinstall and now it works

is currently download the Content :slight_smile:

we have both rebooted

It worked for me and many others. Also, you’re the one asking for help. Don’t be mad at the people giving you support!


Another workaround is to restart and run as admin, that seems to kickstart it most the time as well.


I did have the same problem and went to bed. 6 hours later I loaded it up and it took me to the installation path screen and then proceeded to download.

You do have to just try and reload if you get to a screen where there is a partial blue bar in the bottom left hand corner. That isn’t the download screen but a pre-cursor to setting the installation directory.

1 Like

offer support not just turn it off and back on again… that is not support.

I don’t know what you mean but @Jummivana even offered the same solution. I’m sorry if it doesn’t work for you. Good luck fixing it! :smiley:

Turn off your firewall.

1 Like

I would offer support if I knew more, but I’ve literally just installed the game myself.

Good luck with it.

I had the same problem. It sat on the splash screen for 15 minutes with 1/4th of the bar filled in. I ended up closing the game and relaunching via the store and it seems to have worked. On download screen now about 90% done.


looks like they just ■■■■■■ up what they put it out…

I uninstalled it form steam, then re installed it.

when i installed it origionally steam said i needed 500MB free, now its asking for 1,000 MB and is doing updates

1 Like

91GB to be installed into the users profile account WTF?

Yes. Roughly 91GB. That is the installation size of the standard version.

yeah but it throws it into you user profile app data which is stupid…

if you have another drive for games it then only puts 1% of it on the right disk and fills your C up

Did you miss the step in the installation process where you can tell the installer where to put these 91GB of files?