40th Anniversary Edition Missions

Known Issues: https://flightsimulator.zendesk.com/hc/en-us/articles/360016027399-KNOWN-ISSUES-Last-update-November-17th-2022-

Please use this thread to post your impressions and feedback about the Missions available in the 40th Anniversary Edition.

If you have any bugs related to these missions to report, please create a new thread in the Bugs & Issues section of the forum.

1 Like

The missions are very poorly implemented, imo. They seem to all just use text to speech and the objectives are very basic, just fly to these points on the map while a robot talks to you and then you’re done.

13 Likes

Sill having connection issues, but these appear to be nothing more than a collection of landing challenges, discovery flights and short bush trips. The text to speech intros are embarrassingly poor.

It’s hard to appreciate ‘free’ content when it’s as worthless as this. Giving it publicity beforehand shows an awful lack of self-awareness.

2 Likes

Could this be because the servers are a mess and the Azure engine is down? Or is it like this even with servers?

1 Like

I tried the land at princess Juliana one and it wouldn’t let me move the throttles off 100%.

1 Like

I never experienced any of the originals, but the Sitka one appears to use recorded dialog from FSX. That’s not a complaint, it’s better than text to speech.

I had a look on youtube and the original has a lot more going on such as the traffic ahead which is absent in the reproduction…

Also, when lining up on approach there’s a completely nonsensical message saying something like “Sitka’s behind us now, turn around and head for the airport”.

5 Likes

The Kittyhawk Wright Flyer one doesn’t work in VR for me. It just renders as a 2D image projected on a flat screen in the headset.

The challenge to “see how long you can fly for” just has you crashing into trees. Brilliant.

3 Likes

Why do none of these count toward the Decathlon Achievement??? We haven’t gotten a working challenge in a freaking YEAR on Xbox. Is Asobo trolling us?

Agree with all the other criticisms. It’s a loose, sloppy collection of random, short items nowhere near the quality of missions that previous FS titles launched with. This isn’t at all what was advertised. Shame.

5 Likes

Huge FSX fan, daily MSFS player - but what we have is a string of thematic landing challenges, aimless “discovery” flights and bush trips with no events or signs of life.

Adventure is in the journey, not the destination. FSX took me places i’d have never gone to on my own, because it gave me a reason to make the journey.

JustFlight, Aerosoft - where are your amazing story-driven, interactive missions? Asobo needs you!

4 Likes
  • I’m not getting these to complete. I flew the San Juan Island Run, got all the way to the end, dropped the passenger off at the docks, and it still shows my progress at 0%.

  • Flew the first leg of the Alaskan Floatplane Pilot mission, landed the plane and shut it off, and it acts as though I’ve not started the mission. Still shows 0% and won’t “complete” the first leg.

  • Please remove or allow us to remove the HUD in 3rd-person view. You’ve created the incredible scenic missions for us to participate in them and we can’t take a proper screenshot.

2 Likes

You can already do this. Not in front of the options menu right now but maybe someone can give you the exact options path. If not I’ll find it and send it later.

You can also use the showcase camera which removes HUD.

I appreciate these for what they are in the legacy of MSFS. I appreciate the work that went into them and I’ll probably try to do em all. But I don’t think they should have really been called “missions”. Thank you for the free content :slight_smile:

3 Likes

I was under the impression it was in the Assistance menu, which is greyed out for all Missions, and therefore not accessible for these. On my current settings, they ONLY show up during Missions.

I tried the Changi 747 mission. Really liked it at first. Immersion is cool and the audio from ATC and copilot. But i didnt get the ILS to work… MCDU was off so i could not see if RAD-NAV page got the right frequency.

6 Likes

I have same issue, The plane cannot intercept both localiser and glide slope, the MCDU is off, so l cannot put ILS frequency into it. The approach mode cannot be achieved.

2 Likes

Like others, I’m baffled. I expected to see some implementation of the systems we had in FSX, and was in fact hoping this might be the return of proper a la FSX missions, but instead we’ve got a very clunky set of disguised landing challenges and bush trips…

6 Likes

In the Official Folder find the mission you want to get rid of the annoying HUD.
Then find the *.flt file in the underfolders.
e.g. microsoft-bushtrip-akfloat\Missions\Microsoft\BushTrips\akfloat\13_akfloat.flt

Open the 'flt file with a text editor of your choice.
Then do a search (CTRL+F) for

[Assistance]
Preset=ASSISTANCE_PRESET_BUSH_TRIP

and replace this with

[Assistance]

(Simply delete the line Preset=ASSISTANCE_PRESET_BUSH_TRIP)

Save the file.

Then you can have fun and enjoy the mission as it should be.

1 Like

With the still broken NavLog window!

I can’t believe they made it past testing, they’re almost all completely unusable why would you release them in this state.

In the flight over the channel mission the copilot tells you to ask tower for clearance but being a bush trip you can’t interact with ATC at all, it just makes no sense.

6 Likes

They aren’t really missions. A very long way off from FSX & what people were expecting. These are just landing challenges & bush trips disguised as ‘missions’. So much wasted potential.

9 Likes