A320 Autopilot doesn't work after SU6

The A320 Autopilot stopped working after SU6. I don’t have any problem with altitude, just with the horizontal navigation. It doesn’t recognize my route, the nav points.

Same for me but also problems with hight descent throttle

same for me.

HDG and ALT are Ok.

The same for 747. I really don’t understand. It supposed to be a Sim Update which would fix a lot of bugs. It just gave me a pretty worst bug.


I have tried and experienced the same issue. I have not yet much practises with ILS approach, so I thought I was doing something wrong, flying into Copenhagen (EKCH).
Now I think I will wait and see if a fix or a workaround is going to be available.
In the meantime I will try to see if I can manage to do an ILS approach using a smaller aircraft.

Thank you for sharing your frustration.

Are you inputting the route into the MCDU manually? I am using FS world map to create flight plan and can navigate fine on AP on default A320. (XBox series X)

I have the same problem with the A320, the planned route is sometimes completely undecided, especially when the approach phase starts, the plane starts to turn out of nowhere or lost HDG. For me the game is practically unplayable now. :frowning: ILS at many airports navigates to the runway completely off the runway, for example Milan airport LIMC, but also many others.

I noticed that autopilot only works on HDG and GPS mode’s. ILS/VOR/DME etc. not working on the following GA planes: TBM930, C172, DA62. I set for example NAV1 to VOR/DME and AP is just taking the plane around 360. When I bring manually the plane to ILS glidescope, set APR - nothing happens.

1 Like

Today, everthink works fine (3 flights!)…

really strange :wink:

Hi there,
Found a you tube channel where he explained that it might be caused by discontinuities in the flight plan.
Check out on your MCP any waypoint called usr… that’s a discontinuity…
Remove them and check. If it works.

Could be related to the issue reported here.

G3000 Nav is broken after SU6 - Bugs & Issues / Aircraft Systems - Microsoft Flight Simulator Forums

I have noticed the same thing. I used the A320 to fly from KLAX to KLAS and came across the same issue. When I activated autopilot on the climb out, it turned away from the route and just flew its own path in the opposite direction.

When I tried to direct to a waypoint, the plane turned but at an impossibility steep angle - almost 90 on its side and started to stall.

Very very weird.

This is on Xbox.

Yes, man. It’s very bad. Check if there’s no update to be installed and restart your device. I did this and worked for me.

1 Like

I am seeing the same things in both the A320 and 747. I don’t really fly those much but wanted to give them a shot and they both behave erratically after turning on AP. I put in the flight plan in world map and I am on an Xbox X. They fly in lots of 360 degree circles, great fun for the passengers…

Interesting. I’ve seen the autopilot disconnect on the 747 randomly while in flight with the update.

I’m struggling to play anymore. It seems like every time there’s an update it makes it worse.
I thought I’d try yesterday to do EGKK - EDHH on the A320 and the AP worked fine until descent. It stopped following the way points and in turn didn’t follow the ILS approach, went completely off track.

I checked, there was no updates or anything available.

I tried another flight from EGLL to EGCC and the autopilot worked fine. No idea why it’s got a mind of its own.

1 Like

I have a bravo throttle, previously when I pressed the ‘VS’ button it would engage and I would either go up or down in altitude. After latest release 7.1 A32nx, this doesnt work and I have to use the mouse and click. Has anyone else noticed this and do you have a fix?

Just had a small flight and A32nx stopped following flight paths at landing.
More bugs with every update