A320 Neo Autopilot Navigation

The default A320 autopilot will not follow any lateral navigation - it doesn’t follow flight plans and it won’t even hold heading. It just starts banking left or right until it spirals out of control. Had this issue before and after the recent update. Everything else works fine - speed and altitude work - just not navigation. It randomly worked 1 time after I rapidly clicked the heading hold button a thousand times out of frustration but since then have not been able to recreate such luck.

Plane is not usable… Help…

More detail needed. How are you creating the flight plan? How do you begin lateral navigation?

Tried creating flight plans using the world map, also tried creating manually in the fmc. All the waypoints show up fine. After takeoff I engage the A/P, either push or pull the heading knob and the green NAV or HDG will show up in the PFD as if it’s tracking, along with SPD and ALT. Except that it behaves as if it completely ignores any kind of navigation input. Just rolls left or right. The Flight Director moves according to where the flightpath is, but no reaction from the airplane.

1 Like

Usually this is an issue with your flight controls dead zone. Check your Controls setting under Sensitivity. What is your Dead Zone set to?

0% on both joystick and rudder pedals

Yeah, you need at least 10% for roll and pitch

Strange… looks like my joystick would get “stuck” while in the neutral position. Wiggling it just a little bit seems to unlock it and the plane flies fine, even at 0% deadzone.

Thanks for the help!

That’s what deadzone is suppose to do. At 0% deadzone, even a feather touch pressure being applied to the joystick will override the autopilot control (even if it’s still active). That’s why by adding at least 10%. You’re telling the sim to ignore the micro-phantom inputs coming from your joystick, and will only react when you deliberately moving the joystick up to a certain threshold.

At 0% deadzone, even “neutral” it’s really neutral. There’s always microscopic deviation from the true neutral which the sim inputs as a valid position.

1 Like

My issue with the autopilot is similar to Reni’s, but with a hitch. Before the last patch everything was fine with the bus for me. After it, it doesn’t want to follow the nav line, follow the heading input or keep the speed with auto throttle. I turn it on and the only thing that works is the altitude hold and V/S. If I let go of the stick, it’ll slowly bank left or right unless I ease it back level while still on. Once level I’ll let go then about twenty or so seconds later there’s a violent left or right bank. If I fly with autopilot off, it fly’s fine, little bumps here and there but no violent rolls.

Here’s where the hitch comes in, it’s only like that when real weather loads when starting a new flight. I loaded in a flight once and the real weather bugged and didn’t load. I said the heck with it because I didn’t want to restart the sim and re-plan everything. Low and behold everything with the autopilot worked as indented. So I tested it out six times, three with real weather, three without. Every real weather flight was a problem, every flight without real weather was fine.


1 Like

And yet I have not had a problem with the autopilot and I always fly with real weather. Obviously something else is going on.

I have the same problem, I insert all destinations manually, never plan ahead through the world globe. Once the coordinates is set, I fly up above 8.000 feet and switches on autopilot, but the plane starts to bank right, and it does a 180 and flies in the other direction.

How and why, is two big questions for this topic, the real question is, how do I fix this?
Who can I contact with this issue?

1 Like

I am having huge challenges with the A320 autopilot. (see video below). The flight plans I am using are taken from the world map. Take off normal with no incidents and after about 1000ft set the autopilot. Everything seems fine and then the aircraft starts banking at an incredible angle which ultimately ends in the “screen of death” with the aircraft been overstressed. Even when I disconnect the autopilot, fly back to the track and the re-engage it the same thing then happens. I have flown the A320 regularly since the sim came out and it is only recently that I have been experiencing these issues. Its the same on every flight, making this aircraft unflyable.

Attached is an exmaple video i have just created to show the problem.

Does anyone have any ideas or advice?

Looks like joystick interference to me. Starting at 3:30 it’s already obvious that the AP is not able to follow the FD commands.

At 5:30 the A320 continues to turn at the maximum possible bank angle (67°) which can only be achieved with a manual roll input.

1 Like

@PZL104 Thanks for spotting that. Any advice on how to fix it? I have been using a Yoke for sometime and haven’t experienced this on any of the other aircraft, if the yoke/joystick is interferring would this not show up on other aircraft? Any tips greatlt appreciated.

Just for testing suggest to increase the deadzone to 50% and recheck.

If the problem disappeared try reducing the deadzone.

If the problem is still there, I don’t know what else could be the problem.
In this case I’d try with the joystick unplugged to rule out any hardware malfunction.

This problem might be unique to the A320 due to the simulated FBW system.

Sounds ridiculous but try just wiggling the joystick a little in the neutral position – it appeared to “reset” whatever false input it was stuck at. Works for me every time, autopilot re-engages the fplan.

With a deadzone of 0% this doesn’t sound ridiculous at all, since wiggling the joystick apparently resets to joystick to the required perfect centered position.

I’m using a 2% deadzone which is tiny, but prevents such problems.

Before the big update the A320 was fine in A/P operation. But now the A/P Heading Mode is not working anymore. HDG is diplayed in PFD but the the A/P does not follow the heading indicated in NAV Display.
ILS APPR- Mode is working OK.

Have just used the AP on the A320 Neo & found that although setting it per the dial to top out at 12,000’, it would only show a climb to 5,000’ & that is where it levelled off.
Any way to fix this?

Are you in managed mode? Is there a constraint at 5000?