A320 package pointlessly required to play CJ4 based landing challenge

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes - also a fresh install (and a few things uninstalled - see below)

Brief description of the issue:

I couldn’t start the C74 based ‘Sestri/LIMJ’ landing challenge - the game referred me to the Content Manager to install an A320Neo.
Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

I removed the A320 from installed content - it failed to launch the landing challenge - I installed it, and it worked fine. However there appears to be no need for the A320 as there are no planes about.

PC specs and/or peripheral set up if relevant:


Build Version # when you first started experiencing this issue:

Over a year ago (Dec '22) but it’s still there in

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

See my previous post: A320 package required to play CJ4 based landing challenge

If relevant, provide additional screenshots/video:

Maybe some files from the A320 package are really required, in that case it should not be considered as a bug.

Why would they be required? There’s no sign of an A320 anywhere, yet the .jon file says this:
FS2020\Official\Steam\microsoft-landingchallenge-limj-sestri\manifest.json states:
“dependencies”: [
“name”: “fs-base-propdefs”,
“package_version”: “0.1.0”
“name”: “asobo-aircraft-a320-neo”,
“package_version”: “0.1.0”
“name”: “microsoft-italy-point-of-interest”,
“package_version”: “0.1.0”
“content_type”: “MISSION”,
“title”: “Landing Challenge - Epic - LIMJ Genoa”,
“manufacturer”: “”,
“creator”: “Microsoft”,
“package_version”: “1.0.4”,
“minimum_game_version”: “1.26.3”,
“release_notes”: {
“neutral”: {
“LastUpdate”: “”,
“OlderHistory”: “”
“total_package_size”: “00000000000002963211”

I reckon it’s been left in accidentally. Have a read of my post I put up over a year ago for a bit more background.

Well, the Maverick challenges are required to make generic ship wakes work properly, so yes, there could be some seemingly unrelated content in that package that is referenced by the CJ4 landing challenge.

As mentioned by @BigCow74, sometime modules that do not seem to be connected indeed are for specific purposes. Even if in the code you are showing you don’t see any link, since the A320 warning message pops up, it should be coded somewhere else. If by following the requirement of having the A320 installed you can run the challenge without any issue, I don’t see where is the bug.

Moved to User Support Hub User Interface & Activities

1 Like

A little update:
I installed the A320:

Then I ‘methodically’ went through the files in the ‘:\MSFS2020\Official\Steam\asobo-aircraft-a320-neo’ and deleted bunches of them in a kind of logical a manner, restarting the sim at each go, until I was left with this:

a bit more detail (ignore the 388 files - that was the total count before I started deleting):

but even after all of this, I was still able to complete the challenge (forgive the poor result!):

Finally, I deleted the manifest.json and tried again. The lack of this file brought back the warning that I needed to install the A320, so to finish my investigation, I restored the manifest.json file and deleted everything else in the folder - no joy, it still didn’t allow me to fly it. Adding the layout.json file back in showed that the existence of those two files alone allows me to play the challenge.

I would conclude that, from this evidence, it is clear that the A320 is pointlessly referenced in the config for this landing challenge.