A320NX FBW Experimental Latest (09/19/2021 - 7de8f12) - Not allowing changing sim rate?

Hi there. I post this here as I am not in discord and FBW experimental has no release notes (I think).
I updated today to the the last experimental version (7d38f12) (I have been using Experimental since weeks ago) and on my first flight I see that I cannot increase simulation rate. As I press the hotkeys for that, simulation is increased to 2x but after one second it goes back to 1x.
I know some purists may hate me, but I do not have enough Flight SImming available time for long flights, so I always run at 2x time speed while on cruise (sometimes 4x if flight is long and if weather is calm).
Can somebody tell me if this sim rate increase has been blocked with the latest experimental?
And if yes, is there some workaround to re-enable it?
Otherwise I will have to roll back to Development version, but I do love the new custom flight planner :frowning:

I haven’t observed the sim rate issue but will test it later today.

You shouldn’t have to justify the way you use the sim. Who cares what others think, quite frankly. I sometimes use the sim rate accelerator myself when I can’t be bothered to wait for descent in the Airbus - and would definitely miss it if it were not there.

Addons like PACX keep time even if you ‘fast forward’ so it’s all good.

1 Like

We’re working on a few changes to the core systems to get better performance when sim-rating. One of those changes introduced this bug where the rate gets reset to minimum. We’ll be working on a fix soon as this is a known issue.


You can also share your PC config, average FPS, and the rate of simulation that you generally use, as this will help with investigating the issue quickly.

We currently support a stable simrate at a maximum of 4x.

  1. Thanks for the explanation, I will probably revert to the Dev version for a few days until the bug is fixed.
  2. PC config: i711700F, 32 Gb Ram, 3060Ti GPU. Running on 4K, render scale 100, capped to 30 fps, settings between HIGH (most) and ULTRA (some). Terrain LOD to 4.0 in config file. With the FBW experimental I get the 30 fps mid flight and in some airports, in custom crafted ones the rate seems to suffer and drops to the 20’s with some minor stutters.
    About sim rate, with the earlier version, performance was fine at 2X. At 4X the AP usually gets in a roller-coaster mode, unless the weather is very calm. FPS drop by higher rates was either not to big or not very relevant for me.
    Hope this helps

Thanks for your opinion :slight_smile:
I am certainly not ashamed of using my flight simming time slots for the juicier parts of the flight. Even when flyting over beautiful areas (such as the Alps), the scenery at 2X looks gorgeous from 38,000 ft.
And I am sure I am not the only one, as flight rate increase has been around for more than 20 years in MSFS…

1 Like

Actually a slight off topic question, while I do use sim rate increase personally, sometimes the stuttering makes my count on the correct 1X sim rate difficult… may I ask how to observe what is the current sim rate being used?

If you have the PACX addon, you can see more clearly because the time advances in seconds on a discrete toolbar at the bottom of your screen. Otherwise I watch the clock seconds on the Airbus.

I believe there is now an addon you can use which displays sim rate also, but I don’t use it personally and am not sure what it is called…

With the AmbitiousPilots shiftZ toolbar you can see, among other things, sim rate. You can download it at flightsim.to

1 Like

Ooops, I see same bug also in the Dev version :frowning:

1 Like

At least with the FBW team working on it we can be confident that it will be fixed ASAP.

Yeah, once confirmed they are aware that ths is a bug, I trust they should fix it quickly…
I do love this aircraft!

I personally built this feature - it’s definitively not a bug.

The reason is simple. People are complaining about osciallations and that the autopilot or fly-by-wire is not working properly when using time compression. I’m honestly tired arguing and asking question about those bugs to finally find out that either the performance was bad and/or sim rate was very high.

The principle is as follows: when you want to increase sim rate you need to be above 14 fps for the AP/FBW part. Calculation is simple: 30 fps with sim rate 2x = 15 fps. Means with that framerate you will not be able to get 4x.

There is an additional mechanism that reduces sim rate when stutters or reduces frame rates occur. In that case it reduces the sim rate until it’s fine again.

This mechanism is right now quite agressive and I’m willing to work on it, so it’s more convenient to use but also ensures that no issues appear (as good as possible).


@AGuther your idea is brilliant, but as it is now, I am limited to sim rate 1x, despite being at 30 fps most of the time. Please refine it to allow at least 2x during cruise flight :slight_smile:
Thanks for your great work, but please enable running your wonderful aircraft at 2X if frame rate allows it.

From AGuther explanation above, you should be able to use 2x time compression if your FPS is more than 28.

Are you sure you got 30FPS? Try to use the Dev mode and turn on the internal MSFS FPS counter

I bet it’s the once a while drop below that frame rate causing the problem.

But one more question is that is the FBW now simulates the fuel consumption at the higher sim rates? Coz previously when I play at 2x it will make the plane uses half the fuel

This should be a toggleable EFB setting, not hard coded.


Yes, I am sure I can get more than 28, during the cruise phase. The protection as applied now is too too aggressive, hope they can make it more tolerant…

Yes, agree with that, good idea, please make this option selectable in the “options” page of the EFB :slight_smile:

Yes, strongly agree. Maybe two settings for “Sim rate limit”: unlimited and “highest stable” or something along those lines.
There are plenty of times where I want to use 16x+ for a short time and where the stability isn’t much of an issue.