Adding custom object to existing project

I must be doing something wring, but tried everything to solve it myself and searched the forum here.
Now I’m stuck and hope you can help me.

I have a finished project with more than 80 custom objects and polygons for my city.
It took a lot of time but fianlly the package is built and scenery works just fine.

Now i wanted to add more objects.
I used Blender export just like before and added models and textures to the modelLib just like more than 80 times before.
But when in DevMode opening the project and loading into the Scenery Editor, the newly added objects do not show up.

Clearing and re-building Package did not help either. Only the objects and Polygons that were in the folders on first loading of Project show up, anything new cannot be added.

I helped myself by vreating a second scenery that I run parallel to the first one, but this will soon pollute my community folder.
I even managed to merge the 2 finished sceneries to one, but then of course the merger does not show up un Scenery Editor.

So is there a simple way to add further objects to an existing project?
Or is there a way to merge 2 or more projects into 1? (managed this by rewriting the .xml files but couldnt work out the polygons)

Every hint would be highly appriciated.

And as you are already here: is there any site where custom models can be downloaded for use in MSFS? I’m looking for a red obstacle light to be added on towers and high buildings as for some weird reason Asobo did not include this in the SDK…

I have similar problem… Can not add extra objects no matter what I try. During the building process the load corectly and everything.
I am hoping their is a salution, otherwise I will end up havong to redo the entire airport, each time I want to ad a object.

Yeah, sounds very much like the same problem and i cant believe there is no solution.

Did you try to make a new package with a few (2-5) objects, build the project and add to the new project later? Just to be sure you can add objects after building > editing.

You could also try to run Process Monitor from Sysinternals to see what files are loaded and from where.

It’s definitely possible to add new custom models to an existing project in groups of several or one by one. I have done so multiple times throughout my own airport project without problem. I never saw anything about a limt for the number of custom objects in a project either.

It’s always difficult to diagnose such issues from afar unfortunately. Are you sure you’re using the correct process to get the new models into the library?
No duplicate file names, no duplicate GUIDs, no missing model-info XMLs?
No faulty or missing model files (one gltf AND one bin per model)?
Error messages in the console when (re-) building the package?
What do you do to replace your old package files with the newly built ones? Just overwriting them while FS is running can lead to problems for example.

you are right and i am very well aware that it is most likely me who is doing something wrong.
Thats why I was asking for some help here to understand how it should be done correctly.

So what am I doing?

  1. I setup a Project Folder according to the sample scenery from SDK
  2. I change the Names of Folders and references in the xml files according to my project
  3. I export the Model from blender to the modelLib folder and have the textures going to the corresponding texture folders
  4. I start the sim, turn on Developer Mode, load the project, create package, load the it to Scenery editor
  5. I place polygons for exclusions and position the objects. Add some light to have them illuminated nicley at night and then save the scenery before creating package again.
  6. I then copy the package to my community folder load the sim again and am a bit proud of myself as everything works out fine and more than 80 objects show up as intended.

Then I want to add more objects:

  1. export from blender to same project folders, just like before, check if files and textures are in the right folders
  2. in sim opening the project again, building package again, loading to scenery editor.

Now all my previos objects and polygons are there. But in the objects library the newly added model does not show up.
I clear the package, rebuild it, same result.

So somewhere here i must make a stupid mistake and i cant find it.

The object itself is fine, because if i copy the very same files to a new project that was never before initialised to the sim, they show up nicely.
So my workaround was, to build a second packagage, ending up with two packaged in my community folder. Does the trick but is no long term solution.

Id highly appreciate i brief step by step guide how to add a new model to an existing and already started project so they show up in the objects library.

You can’t add new objects when your package is loaded into the community folder. Close the sim, delete your package from the community folder and try again. It will work

2 Likes

oh.
A very simple, yet confusing solution.
I didnt think the community folder has anything to do with it, as i load the project from a total different source.

will give it a try and let you know if this was it.

thank you very much!

deleting the package from comunity folder, clearing package and rebuilding it in editor did it!

1 Like

And I thought he deleted it when mentioning “cleared package”… :roll_eyes:

Haha.
Well, no.
Just hit the “clear package” in dev mode, so only effecting the package of the project folder, but not the community folder…
But now I know

1 Like

Glad it works now though. :smiley:

I am having this issue but the fix didnt work for me.
I have built a basic scenery with no imported objects.
I then built another project and imported a blender model. That workd fine.
I then opened my original basic scenery, after copying my blender modelLib and textures to the correct modelLib folders of the orig scenery.
I cleared the packges, rebuilt packages, re-opened project and the model isnt there.
Any help greatly appreciated.
The console windows doesnt show anything being compiled from the other models. *.bin *.gltf .xml

did you also delete the package from your community folder?

After you open your project up in the project editor, you will see your project and then under that will be some child nodes. Do you see a .BGL and a .ArtProj node or just a .BGL node?

@Wined2310 YEs I deleted it.
@ab353 No, I only see a .bgl… but the original scene doesnt have any art project in it so I figured I shouldnt see any.


Here is a video of what I do. My mouse highlights names etc as I go.
I HAVE removed the orig scene from Community.
I have already ‘cleaned project’ but did it to show.
Thanks.

So the only way that I have been able to successfully create a project is if it has both the .bgl and artproj. If it doesn’t have the artproj I am not able to place any custom objects or even see them in the editor. You said your original project had 80 custom objects but no artproj. When you say custom you mean that you created them from scratch right? Follow this tutorial and create a new project and make sure it has both child nodes under the project. See if that helps.

https://www.youtube.com/watch?v=3K0XhAf0WYw

Hi.
I had exactly the same problem and have been trying for weeks to figure out what was going on.
Fortunately i have found this thread and that has solved all my problems.
Delete my project from the community folder and delete _PackageInt and Packages Folders from the project.
Click clean project and rebuild. Close the project but not the sim. We open the project and there is my new model.

Note to the developers. We should not need to mess around like this.
And i still feel that there are issues with the Steam version of MSFS and the SDK.

Thank you guys for the help in this thread.

1 Like

That is strange because I never do this. I always add new objects and never touch the built package in the community folder unless I overwrite it with a newer package that I just built.