AFC_Bridge showing in Content Manager to install but download not possible

i have the microsoft store version, zendesk ticket number 127919

I have a honeycomb throttle quadrant since a couple of days. Downloaded the driver version v2100 and installed it as administrator. On my d drive in the community folder is a subfolder afc_bridge with a bin folder in it. In the bin folder is the exe file and a configuration file with the extension .json.

Starting up msfs 2020 with a new flight afc bridge is not running, only after starting it manually it is visuable in taskmanager. Lights are then working but if I go to content manager it shows that afc Bridge is not installed, how do I get it installed. See printscreen.

Anybody know a solution?

Hello @Dutchy9999 ,

it is correct that AFC_Bridge is showing in-game as not installed. The AFC_Bridge should work regardlessly, so just ignore the entry. The program is only required for lights so usage of your throttle should also be uneffected.

If AFC_Bridge does not start automatically, you may want to reinstall it and make sure that in your MicrosoftFlightSimulator_xxxx/LocalCache/exe.xml file, the AFCBridge is listed and the path points to your AFC_Bridge.exe .

As this is not a core sim issue your topic was moved into #self-service:peripherals.

1 Like

Thank you for your reply, I had to change the path in my exe.xml file that was not correct, after changing it afc_bridge starts during the start of msfs2020.

Thanks

1 Like

Hi,
I noticed that the “AFC_Bridge” is still not installed in the community folder while it’s already installed few days ago and it’s exciting in the community folder as well.

I tried to select it in the “Content Manager” to install but it feels like a DIMM and is not getting to install.

The AFC_Bridge is an API that allows the Honeycomb Bravo to interact with the sim for the purpose of lighting up your annunciator panel. So long as the lights are working as expected when in flight, it is installed :slight_smile:

There is a bug present in 19.X.X of the simulator where third-party addons, may show up as “NOT INSTALLED”, even though they are.

1 Like

AFC_Bridge is not an aircraft or scenery. Add-on aircraft or scenery subdirectories contain files that identify the add-on to the Content Manager. AFC_Bridge shows as uninstalled in Content Manager because its files are different than aircraft or scenery add-ons.

For the addons in the Community directory Content Manager is only an inventory list. It doesn’t and cannot “manage” anything in Community.

As long as AFC_Bridge is in your Community directory it is installed. In other words, don’t pay attention to what Content Manager says.

I know this is strange and not documented at all but this is how Asobo has been delivering many undocumented features.

Thank you.

I’m annoyed by MSFS2020, it’s disappointed me, I downloaded it from the store two weeks ago and still, I was unable to do one IFR flight just trying to assign the Bravo autopilot keys into the default 787 autopilot panel.

I saw a lot of YouTube videos as well as in this forum but still useless.

I was wrong when moved from X Plane 11.

Did you download AFC_Bridg expecting it to configure the Bravo autopilot keybindings? If so, I can understand why you are disappointed.

AFC_Bridge Is only to enable the lights on the Bravo. That is all. It doesn’t do any configuration or keybindings.

You don’t mention any specific YouTube videos. I don’t want to recommend any that you have viewed and discarded.

The Bravo is a sophisticated peripheral and MSFS keybindings are difficult to understand. Adding the Bravo to MSFS takes some time and patience. It took me about a day to configure my five Bravo profiles for all the different aircraft I fly mostly due to the MSFS arcane keybindings process.

It took me about an hour, I can link you the videos I used in the morning if it might help

One day for five aircraft, does 787 one of them to bind its autopilot keys? I didn’t try any other airplane yet.

Share the link videos, please while I’m pretty sure all are the same as what did follow on Youtube.

This post (and thread) may help, and this has rmag’s videos linked which may well be the ones others are referring to:

You can ignore the bit on here about the 10x bug as that’s been fixed now

1 Like

Thank you for sharing, I saw all of them many times but did not help in my case in 787 Dreamliner.

@gordongreig’s link has the videos I used. What specific issues are you having @ThePilot8452? I can try and repo the issue later today.

Five aircraft categories:

  1. Small Aircraft (single engine, fixed pitch propeller),
  2. Complex Small (single engine including turboprop, variable pitch propeller),
  3. Complex Twin (all two engine aircraft),
  4. Complex 2 Jet (all two engine jet aircraft and airliners including the 787),
  5. Complex 4 Engine (747 and DC-6)

Of course if you only fly one aircraft, only one profile is needed saving a lot of time. I fly aircraft in all of these profiles. Keybindings were assigned to all buttons, switches, knobs, and levers (including the autopilot) except for the different number of throttle, propeller, and mixture controls.

The time I spent configuring the Bravo included Windows calibration, watching various YouTube videos, downloading and installing AFC_bridge, verifying that everything was working correctly, and documenting all the profiles for backup and restore purposes. Once the configurations were finished, these profiles worked very well.The only problem I have is human error. I usually forget to change the configuration when using a different aircraft type. When SU5 scrambled the profiles, my documentation had the info to fix the profiles in about 15 minutes.

1 Like

Can you share the 787 autopilot binding configurations with Bravo Autopilot panel?

I do appreciate your help.

The issues is assignning the Bravo autopilot keys to 787 autopilot panel.

I did the same using FSUIPC 7. Now, I don’t have the remember to switch profiles when switching planes. It is automatic. It took a while too but it was worth it.

These settings work for my stock 787. Hope this helps you.


Hello, @ITDreamFly . I am having some trouble with some of the lights in the Auto Pilot row at the top of my Honeycomb Bravo. I’m trying to verify whether AFCBridge is causing the AP to have issues. The main (red) lights on the Bravo are working mostly (Anti-Ice always seems to be on) but after SU6 the AP lights and functionality are not working as they used to on my system before SU6.

I have reinstalled the Honeycomb driver and see the AFCBridge files in what I think are the correct locations. I see no improvement in the AP lights or AP function. I checked the exe.xml file you mentioned and it seems to list correctly the path to the AFCBridge.exe file.

I do see AFCBridge listed in Task Manager when MSFS is running. (And, of course it is listed in the sim as being not installed, as has been mentioned.)