After playing a few hours, FPS drops from 40 to 5FPS

dosnt help i found this 2 weeks ago

2 Likes

Hello,

I had the same main thread problem. In the meantime I have been able to fix it. The culprit was the FSUIPC7. This was detected as a virus by Microsoft Defender. Also the Xbox toolbar played a role. My steps were:

  1. I deactivated the xbox toolbar in the Windows settings.

  2. I removed the FSUIPC7.exe from the virus scan, as well as the FSUIPC7.bat file. since then the MSFS2020 runs as usual without performance drops over time.

  3. I deactivated photogrammetry

The next test will be with photogrammetry on.

Maybe it helps you further.

Just to confirm you are referring to this option here?
image

i dont have fsuipc installed i test now with the game bar deactivatet

That is Confirmed

Roger. I have tried another fix I saw regarding an NDU thing, link here:

And see if the performance changes at all. Also, I am running FSUIPC, added to the AV exceptions. Gonna be back with the results!

I hope it works. I tested it on several flights with more than 3 hours. On my pc the degradation startet between 1.5 and 2 hours airtime.

Here’s my checklist:

  • Removed add-ons that I wasn’t using (an airbus chopper and YourControls)
  • Added FSUIPC.exe MSFS.bat and the entire FSUIPC folder on WindowsAntiVirus exceptions
  • Turned off X-BOX Game Bar

I will now be running the FlyByWire A320 Experimental versioning attached (FYI, never had issues prior to 3 days ago, was on FBW dev which didn’t have any updates at the time and have issues with vanilla aircraft too)
image

I already see a improvement if you can call that even, the FPS counter is now green, not red. image

I will start my typical flight. LGAV → EGLL

KOR1F KOR UL53 GARTA UV60 YNN UL611 TUMBO DCT OVVER DCT RODON DCT NERRA DCT VEKEN/N0453F360 DCT ERKIR/N0447F300 DCT BABEG DCT LIRSU DCT DENUT L608 LOGAN LOGA2H

Usually, I go Low-Frames-To-Death around 1.5-2 hours in the air. Going to report my findings then.

YourControls and ToolbarPushback are known to have “possible” memory leak which causes FPS degradation over time.

Noted. So far performance is fine, as before.

Kinda bummed out I can not use the Xbox bar as now I can not take high-quality screenshots. Currently in the sky, if nothing has changed after disabling things, I should start seeing performance drops in the next hour.

as i am happen to have a fast degredation i can tell disabling game bar dosnt have much effect in cockpit view but the degradation stops in outside view but returns when switching back to cockpit view

but the degredation returns when going back to inside view

Have enabled the wasm in the developermode? I have both on. Its Important for glass Cockpits like fbw

no i dosnt have developper mode on

After you have ticked on the wasm you can close it.

never used developper mode before i will have a look

When you activated it you can find it ( wasm) in the options

you mean fast WASN?

Both the Fast one and the other one

so both are checked but 16 FPS over the sea is not hat i had before

Setup : i9-9900K
64GB Ram
RTX2080
MSFS ans WIN10 Installed at SSD