After playing a few hours, FPS drops from 40 to 5FPS

Exactly the same for me, after playing a few hours, FPS drops from 40 to 5FPS or even lower.

Playing on high.

Ryzen 7 3800x
32GB RAM
RTX 2080 Super 8GB VRAM
1 TB Nvme gen 3
600 Mbs wired ethernet connection

No AI aircrafts, just opened a ticket to Microsoft

Hi @JUAS33!
Welcome to the forums!

I’m going to move your post as a new topic into Bugs & Issues.

3 Likes

I had the same problem 45FPS, after 2 hours 10FPS and even lower.

i9 9900k
32 GB RAM
RTX 2080 8GB
1TB Nvme
500Mbit wired ethernet

Tried everything, removed mods, simconnect programs, offline mode, driver reinstall, nothing worked.

Solution for me was completely re-installing the sim. Flown for 6+ hours with good performance.

1 Like

Maybe your CPU is thermal throttling?

1 Like

This is an issue happening since the first release Last year. I usted 3 different machines with different specs and still happening . So I dont think is an issue with hardware. It’s a real bug.

1 Like

Nope, always monitoring CPU temp, kept below 60º all the time. I’m using a DeepCool Captain 240 PRO v2 cooling system, no overcloking.

Now I’m monitoring with dev mode enabled to show FPS. After 2:40 hours, it seems mainthread ms is getting worse, but nothing changed regarding CPU/GPU temperature and load. FPS has dropped from 40 to 30. Mainthread was almost all the time in green and showing under 16 ms, now is 50/50 green/yellow and showing values of 20 ms.

Just opened a ticket to Microsoft

1 Like

if this happens, can you please open the “Resource Manager” ( Taskmanager, Perf-Tab, bottom ) . Choose within the memory tab then the Flightsimulator.exe and check what is statet at “commited” memory ?

Also some users report, that shortly open the options menue, will bring the “fps” back. Can you recheck too ?

Going back to the menu does not solve the issue for me. Even within game’s menu FPS are 10 or lower. Right now commited memory is 21GB, will keep an eye on it. Workspace memory is 4,5 GB now.

Thanks!

1 Like

hmm… this sounds okay. So its not a slow down because paging.

Than maybe it’s a caching problem of some sort.
Something must slow the game engine down after a while and since MSFS uses lots of system resources, a caching problem is the first thing i can think of.

Today have been flying for a few hours. FPS dropped from 40 to 20 slowly. I have been streaming it to record, showing the CPU-Z, resources monitor and task manager.

Can see full video here: twitch ciberajj

Check your available RAM memory when you start flying and then as the game progresses. On another thread we have found an issue where memory is slow to be reclaimed when there are lots of buildings and textures. When my available RAM drops to 20 or 10%, the frame rate goes very low.

You can use Windows task manager performance tab to watch your available RAM.

Anyone who is having this issue-

Try flying with 16x time acceleration for a minute. When you go back to 1x time acceleration, your frame rate will drop by half or more and never recover.

Basically, using time acceleration makes this issue happen faster.

It is definitely a major bug with the way FS manages memory that was introduced 1-2 patches ago.

I’m personally amazed that the entire first page of the general discussion isn’t filled with people complaining about this as it is a massive bug that affects everyone if they fly for more than a couple hours

5 Likes

not for me… and thats because you speak about usage of slew / time acceleration , which I not do.

Thus… first let us wait for an answer from OP whether he use slew / time acceleration. If this the case, we can link ( possible merge ) to the topic from @LimburgerSmell . Former we know “definitely” nothing…

@JUAS33 sorry… your twitch video is to long to can check such things :wink:

4 Likes

I’m having similar problems since a few days, much sooner than after 2 hours though. After say 45mins or less, CPU frame time basically doubles for some reason. This in turn reduces GPU utilization to 20% or less. Only way to fix it is to restart the game, really annoying. Anyone else seeing similar? I feel like somethings changed in the last week or so…

2 Likes

Had the same issue here in both the 787 and A320neo. Checked the system utilisation, everything was chill, yet the game was running at around 5fps. The flight started at around 40fps. I was 9mins out of arrival after a 14hr flight (realtime) so I committed to the approach then it suddenly CTD without any error messages.

The next day I tried another flight at it went from 40fps at start as usual to around 5fps about 1hr in, just a short flight.

This is only a new problem, in the last week or so.

1 Like

I never use slew/time acceleration as it’s forbidden in IVAO and also in the VA I use to flight. Last time it took many hours to reproduce the issue. However, it’s really anoying not to be able to perform long flights across the world.

2 Likes

There is no such a big difference on available RAM between flight start and frame start dropping. I can see the commited memory gows up to 26 GB

thanks reporting back… Thus there must be another reason.

PS: thumbs up for real-time flying

Just did a few tests with the latest patch-

Started out at a solid 30fps.

Started in Atlanta, used time acceleration for about 20 seconds and dropped it back to 1x over downtown. Framerate dipped to stream in new assets, then after about a minute the data was streamed in and the framerate was wouldn’t go above 27.

Used time acceleration again for another 20 seconds, continuing to fly east. Dropped out to 1x, and it took even longer for the data to stream in. After about 2 minutes it seemed that everything was streamed in, and my FPS wouldn’t go above 18.

Put on Time acceleration for a third time, did it for 20 seconds, dropped it to 1x. Data streaming took a really long time… it was streaming in new stuff for about 3-4 minutes. I actually got an error that popped up on screen that said my bandwitdth wasn’t good enough for photogrammetry streaming (I have never seen this message before). Tabbed out to check bandwitdth, and it was fine otherwise. The game finally streamed everything in and the frame rate wouldn’t go above 5 fps.

At this point I quit the program back to windows.

Loaded it up again, this time flying out of Detroit. Did the exact same thing outlined above and had the exact same results. I didn’t get a bandwidth warning this time, but after using time acceleration 3 times my frame rate was locked at 5-7 fps even after letting the sim run at 1x for 10 minutes flying straight forward.

3 Likes