After playing a few hours, FPS drops from 40 to 5FPS

Same issue still exists in SU9, after a few hours fps drop. MSFS is unplayable for me. Tried every trick in the book. It‘s just a broken game.

6 Likes

same here, just 1 hour into my flight and mainthread + manipulators is going off the roof.
it’s extremely frustrating.

4 Likes

did you tried to turn of the anti manipulation feature in the windows defender options? that fixed the manipulator thread for me. i think windows defender thinks its a bitcoin miner

No i didn‘t, thank you for the suggestion, i will try that out asap!

So guys i tried around a little bit with the windows defender options and turned it off completely at the end ( all options) and i found out that the sim was holding strong 40FPS and then a rapid degradation followed by a CTD I have the program from Asobo installed that records crashes and creates dump files.
i Filed a zendesk report maybe someone is here that can read these dump files i will link the zendesk post here.

https://flightsimulator.zendesk.com/hc/en-us/requests/156983

Setup
i9-9900K
64GB Ram
RTX2080
MSFS and os Installed on SSD

Ok, just to report back. I finished an 8 hours flight using the Headwind A330-900 (which I had degradation before) and now I didn’t have any issues whatsoever. No degradation nor fps oscillations.

Things that I did:

  • NDU procedure (here)
  • Change flightsimulator.exe to open as admin
  • added Flight simulation folder (where the .exe is located) + flight simulator roaming folder as scan exception on my anti virus program (which is kaspersky). Also added the .exe to be trusted on AV.
  • added fsuipc7 folder as scan exception also the .exe to be trusted.
  • disabled dev mode (no particular reason, only because I wanted to have my logbook back)

I didn’t removed any addon (I use toolbar pushback too) and externally I use Volanta + Vamsys Pegasus (which uses the fsuipc7) + Navigraph Charts + fs2crew (but in this flight I didn’t used it).

To be honest I’m not quite sure if it was something that I did, the update 9 (since this was my first flight in the new update), a mix of both, pure luck for this particular flight, or something else.

I’m going to do another long haul today and I report back.

As the last few guys suggest it happens mostly over europe so where did you flew?

1 Like

This was my route (SBSV > LPPT). I had issues before in this route, particularly when I cross the ocean around +5hours flying.

interesting i get problems mostly in or over germany and over middlesea

2 Likes

@blindeye1995 Do you think this could be a region-specific problem perhaps? Maybe with Europe?
I will try a US flight to confirm if I get the same degradation.

@Brunocarvalh0 Just to check with the prementioned, what was your route?

could be realy anything but as you say it it coud have to do with the german / european scenery update

Route was: SBSV/10 TIRKU2A TIRKU DCT AZOTE UZ10 NTL UN873 SAMAR DCT BEXAL DCT
LIGRA LIGRA8A LPPT/03

did the degradation startet as you cam in Render distance of the Mainlland of Europa?

My flights are mostly 1-3 hr hops within Europe, so didn´t really had this problem until y tried to do a long haul 13.5 hour flight from Madrid Barajas (LEMD) to Santiago de Chile Pudahuel (SCEL) after doing it in real life (what a wonderful country Chile is, by the way…).

I did it in the sim just before World Update 8, with version 0.94 of the Headwind A330 Neo.

Frame rate degraded from 30-40 when leaving Madrid, to about 5 fps in mid-Atlantic. I had to exit the sim and start a new flight from my last waypoint (50 - 60 fps in the air, above the ocean). I arrived to Pudahuel at 12-15 fps some 6 hours later.

After WU8 in the sim, and a massive update in the Headwind A330 Neo to the latest version (1.04 maybe?) I repeated that flight with much better results (not perfect, but better).

I flew for 13.5 hours and landed at Pudahuel at 20-25 fps, not great, but way more usable than 12-15 after restarting the flight mid way.

The next day came back from Santiago to Madrid. 12 hour flight. Departed from Pudahuel at 35 fps, and made it to Barajas with no interruptions, with frame-rates at 20-25 (If I load at Barajas, I get about 30-40 fps).

Since WU8 should not have changed anything at all in the sim itself, I guess something in the Headwind A330 Neo (maybe the cockpit by FBW) might have changed and caused the better performance I got in my last two flights.

Now with SU9, I´ll repeat the flight to see how it goes (it must be this weekend, since I don´t use elapsed time).

Let´s hope this problem is a thing of the past.

1 Like

dosnt look like this because i am in su9 beta

You should change out of the SU9beta to SU9, get out of the insider program and so on.

Ok i try that one out

I’m 5 hours into a trans Atlantic hop from KJFK to London Heathrow and albeit there has been some degradation, I’m not experiencing any significant lags or audio skips after the last update. Plus I turned all my graphic options to Ultra just to test it and I’m rocking between 20-30FPS (locked @30) Very, very cool.

1 Like

I usually fly around 1-2hrs/flight
but another data points(long flight) that I have recently are…

  1. WMKK-YPPH approx 5.5h no issue (pre SU9 update, with Volanta,a32nx exp)
    I should have checked task manager…
    2)RJAA-PANC after 5 hrs sound has gone and unplayable,exit the flight (pre SU9, 747 salty with Volanta )
    3)RJTT-PKMJ after 5 hrs huge fps drop but still playable(pre SU9, no Volanta, hw a330 1.04, no EFB used:some said EFB on a330 is considered one of factors of performance issue)
    4)VTBS-YSSY after 6.5hrs sound broke and fps gets down around 5-10fps and exit the flight (after SU9, no Volanta, Vanilla 747, no mods)

In the case4, acually I didn’t have bad Manupilator latency but GT coherent draw and Main thread went high. Same as last time, commited memory went up to more than double when I started flight while active memory usage stays around the same.
Also after exit the flight and went back to the main menu, commited memory weren’t released. I should have start another flight at that condition but I didn’t :stuck_out_tongue_winking_eye:

so I’m not flying European area but still having same issue…?

it could be anything a object like a boat or even a specific waveform over the atlantik or a simple memory leak because of to much scnery loadet or a specific building a bug in aircraft rendering of traffic interference in data so i noticed in parts of the world where more buildings and meshes have to be loadet the fps drop increase

1 Like