AI aircrafts misses taxi pathways

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes, when recording, but occures also when dev mode disables. Clean MSFS without enabled addons with the recording.

Which aircraft are you using that experiences this issue?

this is about stock AI Aircraft with stock trafficAircraft.bgl.

Brief description of the issue:

AI aircraft are missing taxipahts along on its way to end of the runway. They end up taxiing out of the aiport.

Provide Screenshot(s)/video(s) of the issue encountered:

https://youtu.be/qMyolACBGjI?si=0hI4Y2ES5nfHMRHJ

Detailed steps to reproduce the issue encountered:

Enable AI Offline traffic, go to for example KSPY and use increase sim rate to catch AI aircraft to depart. Then follow it when it is taxiing.

PC specs and peripheral set up:

7800x3d, 4090, 32ddr4, 1440 monitor.

Are you using DX11 or DX12?

DX12

Are you using DLSS?

Yes, Ultra quality setting.


:loudspeaker: For anyone who wants to contribute to this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

the aeroplanes taxi all over the airfield.

Are you using DX11 or DX12?

DX12

Are you using DLSS?

yes

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Any general aircraft in PAYA have the issue for exemple

Are you using DX11 or DX12?

DX12

Are you using DLSS?

Yes, balanced

If relevant, provide additional screenshots/video:

https://i.vgy.me/81mIcs.jpg https://vgy.me/u/GvMZl7 https://i.vgy.me/XXhUD4.jpg

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

i watched A320 drive through downtown Miami at 75 knots

Are you using DX11 or DX12?

DX11

Are you using DLSS?

no

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

AI aircraft taxi all around the airfield taking no care of taxi paths.

Are you using DX11 or DX12?

DX12

Are you using DLSS?

No

If relevant, provide additional screenshots/video:


this is the situation now. 90% of the yellow taxi aircraft are actually in the forests finding taxi paths.

https://youtu.be/fl-irqkF3KM?si=VuMim8djedWv8KG1

This is so embarrassing behaviour with SU15 beta. It has get worse update by update. Now every aircraft misses taxi paths in certain stock airports.

https://youtu.be/QfZrBhtgh1o?si=6RG30PzXfa3eUXnD

3 Likes

I’m wondering if it has anything to do with the increased taxi speeds. Its evident that they have increased, but not sure if the logic has been adjusted cause it seems like the aircraft are searching for a waypoint which is a ‘fly-through’ point meaning it has to cross that point before it can sequence the next waypoint. When that happens, it can overcorrect for the next point. I do agree though with each update in the beta, the behavior has gotten progressively worse. Live AI is not usable at this point due to number of aircraft stuck across major airports.

1 Like

I tought this too. I will try aiground with decreased taxi speeds.

Interesting times ahead. Apparently bug “cant follow taxi paths” arent bug in AI traffic behaviour by itself, because AIG models works great: https://youtu.be/DTUj3GErYgQ?si=I6H8N-6vCBLO_AYy

So now i have to find the problem inside of stock models´s .cfg files. I will keep you guys updated in this matter.

edit. I can confirm this. Using AIG´s C208b .cfg files with stock c208b… it worked!

1 Like

ok, this is kind a bug, but can be fixed. Gamod models had modified wing_span, to have every aircraft in airports availeble. But this was the case, they didnt have ability to follow taxi paths because of that. Byt MSFS was working great earlier with these modified wing_span values but with su15 beta it did get unplayble.

1 Like

The bug still exists! Even with su15 beta updated C172.

https://youtu.be/mrVgcOa9r8A?si=xXA9-5jxhHpkFvbM

hello asobo team,

thank you for your new SU 15 Beta 1.37.11.0 March 2024

but unfortunately it is still quite right on the runways with big winds, the AI Real Traffic

at my home Airport EDDF Germany
is still not the RWY 18 West,
and on the NW RWY 07 L is landed zar correctly, but unfortunately unrolled until the end and not the first or the second junction could be improved that would be possible

now briefly to the traffic worldwide no matter if you Europe is the AI Real Traffic, you should still fix short leg touch down the runway, is short the plane there, then it is wg ploped almost at every airport!

Ok MSFS team, here is solution for you. You just need to make it working again and edit the code you have changed in this SU 15 beta.

Here is video that is showing the problem: https://youtu.be/bJkbh0Z-tLw?si=ajoH1cEynJ7o1f1Q

And image attached about the problems.

1 Like

Thank you for adding this with “bug logged” status. So there is hope.