Air Manager G1000 needed!

The built-in G1000 now works without any of this Mobiflight tomfoolery required. The only thing that doesn’t work atm is the VNAV from the Working Title G1000 NXi. The code I have above fixes that.

That said, I’ll probably share my updated G1000 panel that incorporates that fix at some point. No programming required. You just import a new instrument into AM and use that instead of the stock G1000.

1 Like

Thanks for the update. The only 1000 I see is for the Cirrus. Is that it? I compared it to the 172’s and looks close enough. If that’s it, I’m rollin’ with it and a touch screen ( if I can get past ‘She Who Must be Obeyed’). Next is the Knobster.
By the way, I’ve been watching a couple of your videos. Excellent. I did subscribe. Some people need lessons on instructional videos, for example, clean audio, no background music or engine noise unless it is part of the demo.

1 Like

If you have the old beta version of AM, the G1000 doesn’t work. You need the current full paid V4.02 release with the latest plugin.

Glad you’ve been enjoying my videos. I wouldn’t call them instructional in any way, but I guess there’s something to be learned from just watching someone doing things.

You should find the G1000 under Panel->Cessna C172SP. At the bottom you will see “Dual G1000”. Click the Add button.

I’ve always believed the best way to learn some things is ‘don’t tell me how it’s done, show me’.

1 Like

Agreed! I learn best that way too.

On another note, I’ve released my modified G1000 bezel at the link below. 100% compatible with regular SimConnect / MSFS SDK commands, so no Mobiflight wankery required to get it working. I’ve improved VS and FLC functionality and the associated nose up / down button behaviours to match how it works in the real unit. VNAV key now also works if using the Working Title G1000 NXi add-on from the marketplace.

1 Like

Thank You.

I am trying to remove a waypoint and if I press the CLR button nothing happens in Airmanager but it works in the cockpit. Can you confirm if this is a problem or I am doing something wrong?
Thanks

If it works in the sim but not in the panel, then it’s an issue with my panel. I’ll have to look into it.

I’m looking at it. The CLR button is the stock Sim Innovations code, as is for most of this panel. I don’t know what this is supposed to be doing, but it’s not activating the CLR event. I’ll have to go look this up in the SDK and see what the correct event for it is.

Thanks. Wasn’t sure if I should have referred that to you. Hope it’s OK, if not just let me know. I’m new to all this.

Looking at it now. Trying all kinds of different events and such from the SDK, but none of them want to fire for that button. I’m stumped… I can only get it to fire using a Mobiflight event.

If it needs a Mobiflight events than lets use it, until a better solution comes up.

OK, got it working. I had to dig though the Mobilight events file to find what SDK / Simconnect event it was using. Seems to be working now.

I now have the newest copy uploaded to my Google Drive. Download, install, and enjoy.

At one time, Mobiflight was the only way. Now I’d rather avoid it altogether is possible and let people use the G1000 natively now that the commands are in the SDK and accessible. WEll, mostly, it seems.

Is it the Generic - Garmin G1000 NXi.siff? Because I just download it and there is no Mobiflight events in the logic.lua code.

Nope. No Mobiflight events. It should work as is. I looked into the Mobiflight event file and looked up what SDK event Mobiflight was using, used that, and it worked. It’s using an old SimConnect command vs what’s in the new SDK. The events listed in the current SDK do nothing with the Garmin, it seems.

1 Like

Works great. SorryI was under the impression that you used a Mobiflight event. I must of read wrong.

Thanks again.

I just wasn’t clear. I tried the current SDK events, and couldn’t get them to work. Tried old SDK values, they didn’t work either. Tried a Mobiflight even, and that worked. So I went and looked up what the Mobiflight event was using and found it was an old SimConnect command. Using that old H: command worked without having to have Mobiflight in the loop at all

Well, I now have a touch monitor and AM. Managed to get the 1000 bezel and the PFD from the 172 on the same screen and more or less sized. The touch responds but not the way I expect. The touch does nothing to the bezel, but it shows a square with a depression on the main screen.

  1. Displays are set to ‘Extend’
  2. Bezel is set to Lock, Always on top
    I read through the AM ‘manual’. I see nothing on how to save the completed panel. Do you have to re- assemble and resize it each time? That’s a real chore.

When you touch your Windows start menu on the touch screen, does it pop the touchscreen, or main monitor? If it pops open on the main screen, then you need to do a touch calibration in Windows.

Look for this in your Start Menu…

image