Albatros L-39 Pilot - Crew Legs

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:

PC When prepare L-39 for flight, pilots legs protrude under the cabin - see atteched picture
After SU 7 when I bought L-39 in the Marketplace

Not only that, the rear pilot is wearing civilian clothes when set to default in the pilot avatar options.

Please tag your post with #pc and/or #xbox.
#pc
Are you on Steam or Microsoft Store version?
Steam
Are you using Developer Mode or made changes in it?
Just regular
Brief description of the issue:
The picture says it all
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Fly the thing
PC specs and/or peripheral set up of relevant:
Brawny PC
Build Version # when you first started experiencing this issue:
um…SU7


Loaded up Air Racing to try out the jets and well this is what happened. I have to say I have the sudden urge to scream Yaba-Daba_Doooo!!! everytime I pass a pylon, however I’m not sure my pilot’s legs are strong enough to stop the plane when I land.

Microsoft Store version
Not in Dev Mode
Happens Everytime

Ryzen 9 3900X, RTX 3070, Windows 10 (latest version), 32 Gb DDR 3200 Ram, 1Tb M.2 drive, 3Tb Sata Drive

Latest Build of MSFS 2020

1 Like

I have the same problem BUT only with the single seat version; similar PC setup as the others have described.

This post was flagged by the community and is temporarily hidden.

1 Like

Absolutely, pretty embarrassing, and shows how bad Microsobo’s QA is.
I have the same problem…just hides me, doesn’t change the fact that I regret the purchase.

2 Likes

Yes clearly another sign this product was rushed…BUT…this is one glitch that keeps making me lol when i see it, so there’s that silver lining…

2 Likes

Today I purchase from marketplace in msfs20 the L39, to my surprise I see a pilot in the plane with arms and legs OUTSIDE the aircraft. Whats going on ???

Well, now we can walk those clouds:))) The first step to drivable avatars?:)))

As a temporary fix, in options ->misc you can change your pilot, copilot, and instructor pilot models to “default” and the next time you load the L-39 it should be fine. This will show the pilot models that were intended for the Albatros (with fighter helmets, oxygen mask and flight suits etc), and they won’t have any limbs sticking out.

2 Likes

Thanks, but it doesn’t work either

Do you see the pilots with flight suits and helmets after setting them all to default? It doesn’t work unless you restart the sim afterwards sometimes I find. After that it should stick.

I do that but not work for me… Thanks a lot anyway Maybe the reason is that I only buy the l39 Tumbling goose and the T6 Undecided

Once with pilot avtar on custom I had empty cockpit but after restart again same issue, arms and legs outside, changed to default again but no succes

Maybe but still waste of money although cheap, think it should be ok when one buys something on msfs20 marketplace.

To add to my comments, is Microsoft working on this problem ???

Please see this post here regarding tags on topics:

after setting on default and start pc again, the cockpit is empty on both seats.

Hester what must I do, just purchased a T6 and the same issue, parts of pilots outside cockpit.
When can I expect a solution else I need refund for both aircrafts, L39 and T6, I am very disappointed.
cheers Achim