All controls frozen after update v

Since I have installed update v and the small update that followed I have absolutely no control over any aeroplane. The only way I can fly is to use the AI pilot and sit back like a passenger.

I am using a PC.

Any help would be appreciated, as I have tried everything I know (which is not much) and can not find anything like it mentioned in the forums.

Thanks in advance.
Roger

1 Like

Half my peripherals no longer work. They worked fine before the updates. Bummer.

Suggest unplugging all your peripheral USB connectors and replugging them while the game is running.

Also check to make sure all your drivers are up to date.

It is a mess!

I’m using Saitek/Logitech peripherals and since SU5, I’m getting pauses in response. Yoke works for a few minutes and then no response for a few seconds. Bad situation when in a turn.

It’s definitely a MSFS issue because when I test the yoke with American Truck Sim, there are no pauses in steering control.

I also am having issues with controls, there is no consistency with mappings since the last updates. Some are missing, for example ‘MENU_BACK’ was essential to map to a button for VR.
What a mess. MSFS team have done a real job on us with this. It was mostly good before but really poor now.
Most of the time if I map something it does not work. Today I mapped the Active Pause to button 1 on my controller. To my surprise it brings up the Toolbar. It worked yesterday.
Come on Microsoft. This is essential.

I found the solution to my issue (above). It seems I can no longer simultaneously mouse scan the cockpit AND use the yoke/throttles. Once I press the right mouse button, it locks out my Saitek/Logitech controllers.

I am 99% positive this was not an issue before SU5.

1 Like

report to Zendesk issue you may come across. A list can be compiled and hopefully some resolution to the problems

Hi everyone, thanks for taking the time to reply.
After fiddling around with the settings in the sim everything seems fine now. Unfortunately, I have no idea what I did (if anything) to get it working again. :slightly_smiling_face:

It would be great to know how you solved the problem because as it seems i have the same problem. My controllers stop to work every few seconds (like freezing for 10 seconds). Then they work again. That made me crash on approach :frowning:

After last big update I have the same mentioned problem with controllers in cocpit. When I put the mouse over them, appropriate controller is getting blue but doesnt work. All peripherals work normal. This situation applies to all aircrafts. I dont know what to do. Any idea? Thanks