All my flight plans go to 'null island'

Whenever I try to make a flight plan with the World Map, once on the plane, the GPS always goes to coordinates 0’N 0’E (null island). He gives me a flight distance of several thousand miles. Even if it is not visually displayed on the VFR map, the autopilot takes the wrong waypoint. Have you ever encountered this kind of problem? Thanks

Yes, this is a known bug. A very weird one, but apparently easy to solve:

In Windows 10 Control Panel → Region → Administrative Tab-> Change System Locale…
Turn off: “Beta: Use Unicode UTF-8 for worldwide language support

Reboot PC

I know it sounds ridiculous. But it works.


Woaw, it’s super weird indeed but it worked :slight_smile:
Many thanks.

1 Like


So, somehow the world map/navigation is taking your PC’s language region as some sort of reference?

Obviously it needs the timezone but surely there are better ways?

I’m just passing on the information. Why this is causing so much misery in the sim I don’t know.

But seeing UTF-8, I suspect they have some kind of Unicode issue going on. Maybe it’s counting on UTF-16? Or perhaps even ASCII. I have no idea. It’s all a bit nutty.

1 Like

Frankly, what’s also still a mystery to me: why is this setting even ‘on’ with some people? Mine was always off. Why would anyone go in there to turn that check mark on?

So if it wasn’t the user, and it’s on… who turned it on? And when?

1 Like

Turns out that folks might be turning this on in order to resolve another issue with the game who’s problem is actually rooted in the way that the Windows OS handles non-standard characters in user names…

1 Like

Ah that explains. But if topic starter turned it on for that reason, apparently that whole issue got solved. Else he would have ended up in different trouble.

I think it’s a world of hurt that has its root in Windows OS and probably has more impacts than those 2 issues. (Probably including the game not installing or updating too well if the file system is janked.)

Those impacted with the issue described in this thread had probably cross check to make sure that they are not getting messed over with the other issue if they switch.

These charset issues could be fixed with Windows 11, hopefully …

Indeed a strange bug.
By the way, I turned this feature on once in the OS (Beta: Use Unicode UTF-8 for worldwide language support), 'cause I read in some forum that this prevented some malfunction with the FBW A320NX (if I recall well).
Side effect: All my work MS-EXCEL spreadsheets which use Visual Basic macros stopped working. I was like crazy, traing to repair MS-Office, until I realized it was this stupid checkbox which was on…