I cannot load any different airport and plane - always the same airport and same aircraft - non ascii windows 10 account name

I have installed the version (Premium Deluxe), now “Fly” button works! But I have a serious problem… I try to select a different airport from the menu but always load the same airport as the first time I did select… also for the aircraft (always load the Cessna) Of course I have downloaded all the content, also I click on “repair” the game… but still the same… I cannot select and fly in any airport. Is there anyone with the same problem? Any ideas? It is a nightmare! There’s many bugs & issues! What a pity!

have you tried a full reinstall of the game? totally wipe it from your drive(s) and %appdata% folder etc… and just reinstall it as new?


Yes, I did full reinstallation… but, frankly I need to wipe %appdata%… I will see… Thanks for your reply!

Just to clarify, don’t wipe the whole of appdata. Just the MSFS related folders if you must.

Make sure too that all add-ons are removed and that nothing is in the community folder.

Could you change your subject line to reflect your post? That way is easier searched on and others seeing it can offer more help.

Ahh… okay, thanks for your recommendation.

Okay mate, anyway I have no any add-ons… Of course, Then I try to change the subject line.

sorry for that… I did mean the msfs folder inside

Okay, sure…

Did you fix it? Having the same problem here.

Hi… not yet… but Microsoft told me were included into the Zendesk fix list (I did “via submit a request”).

Hi ETLG and @matukmatuk
I see this problem still exists. Do you have the English Language pack installed on your Windows 10?

A temporary fix I just figured out is to delete the .fssave and .spb files under %appdata% MISSIONS folder, but you have to do that before every new flight.

Not sure that I do… Where can I find it?

In Windows 10 settings, go to Time & Language, then Language. Under Preferred Languages, make sure English is one of them.

I’m not sure if this will fix it, but it’s a start since MSFS requires it even though other Languages can be used.

@ECTLG and matukmatuk,
Can you fly out of a different airport by only using the “Departure” and not selecting an “Arrival” (leave that blank)? So basically, a “free” flight.

I just checked and I do have the english language pack installed, that doesn’t seem to be the problem

No, no matter how you set up the pre-flight, it will always load the settings of the last flight.

But at least we figured out what happens, what the bug is about: FS automatically saves and always reads the file of the last flight as if the user were asking to read a saved flight. How and why this happens is up to the developers. I will submit a request as the ECTLG did.

Interesting. When ECTLG first posted I have never seen it before. I’d like to know the cause too. There was another user who posted today on the forum about this same thing.

It shouldn’t be saving that type of flight unless you manually save it but you still should have the option of picking different airports and aircraft.

The files you are manually deleting, .fssave I don’t have. I do have the “missions” folder with some .spb files.

Try manually saving a flight plan and check if it creates the .fssave file. If so, thats what it is doing wrong and what they have to figure out why.