AMD Fluid Motion Frames (AFMF) + MSFS2020

So I’ve been experimenting with the new preview driver with a lot of success in quite a few games. It’s giving considerably more FPS and a smoother experience for most games i’ve tried.

My problem is I cannot get it to work in MSFS20.

My guess why it isn’t working is MSFS20 fullscreen is not actually fullscreen-exclusive, it’s instead borderless fullscreen, and AFMF does not work with this display setting.

Does anyone know how to force fullscreen exclusive? Has anyone had success getting driver level FMF working with this game?

Note: To avoid confusion, this is not FSR - https://www.amd.com/en/support/kb/release-notes/rn-rad-win-23-30-afmf-tech-preview

1 Like

I have set it up as specified and in the Adrenaline driver display performance I can see double frames, however when inside the sim, on full screen I can’t see double frames on the driver overlay…something not right somewhere.

“Fullscreen” on MSFS is actually borderless windowed. AFMF Requires Exclusive, and MSFS lacks that option entirely at this time.

2 Likes

People have reported it working, though, so either it works or they’re incorrectly reading what’s going on on their screens.

I recommend you ask them on that thread. I haven’t tried it, I’m only passing on the existence of the other thread where people are trying it out and talking about it.

It was working for me when I went to bed last night. Set up a long flight, got to cruise with FMF running, woke up to find it had just stopped working.

2 Likes

Had a similar experience. The first time I used it with FSR2, it increased performance. After a reboot, performance actually decreased to below the levels before adding AFMF. I intend to try it again today and see what happens.

2 Likes

The msfs inbuilt fps counter will only count the real rendered frames, not the „fake“ generated frames. You might need an external fps counter

3 Likes

yup or pull up AMD overlay, if it shows framelag counter in milliseconds it means it works and is active.

1 Like

Hello there,

Thank you for your post! Your topic has been moved to the Tech Talk subcategory of General Discussion & Community Support. The General Discussion category is meant for discussions that fall outside our other sub-categories.

Please check out these other categories for your future posts:

  • Aircraft
    is where you discuss current or future planes coming to MSFS as well as assistance with liveries.
  • World
    is where you discuss scenery, airports, and weather.
  • Aviate, Navigate, Communicate
    is where you ask for help with flying.
  • Tech Talk
    is where you discuss installation, graphics, drivers, performance, CTDs, peripherals, and hardware.
  • Menus & Activities
    is where you discuss activities (landing challenges, bush trips, etc), plus anything accessed by the menus including the Marketplace, settings, logbook, cameras, etc.

When I used it with AMD’s metrics overlay, it reported higher frames, but the smoothness on screen was the same. With all settings cranked the FPS did not deviate from 121.7 FPS regardless of areas where you would expect large drops.

Tested in GA, Airliner, Empty sky, and A.I filled intl. airport. (as well as other games like Destiny 2 where it did work properly, if not particularly well)

In the Adrenalin control panel, FMF shows as inactive with the tooltip indicating improper in-game settings. If it’s not working according to AMD then it shouldn’t be indicating extra frames in the overlay & Vice Versa.

I get the error message that “AMD Fluid Motion Frames is not compatible with the games display mode setting. The game should run in fullscreen exclusive display mode.”

MSFS does not run in fullscreen exclusive display modes so I am afraid this driver is useless for us.

Yes exactly my issue: MSFS does not have a true ‘exclusive’ fullscreen option so I cannot enable AFMF.

I am confused as to how other people are getting this to work. It cannot work unless the application is exclusive fullscreen. I think people are confusing FSR with FMF maybe?

I am going to see if there is a way to programmatically force the window into exclusive fullscreen rather than through the games options menus.

2 Likes

I installed the “Preview” driver and set it up as can be seen in this post: AFMF
However, instead of TAA, it is set to FSR2 with only 1080p, not 1440p. Using the built-in MSFS counter as the internal counter and the AMD Adrenalin counter as the external counter, I’ve monitored frame rates. If these counters are reliable, I get, consistently, almost exactly double the fps on the external counter. I’m not convinced that I’m seeing any benefit from it, however. Display mode is set to “Full screen” in MSFS, whatever that means. I do not get any error message as indicated above.

2 Likes

System
AMD Ryzen 5900X / AMD Powercolor Red Devil 6800XT / 32GB DDR4 ram/ 3440x1440P Ultrawide Monitor with freesync range 40-100mhz

MSFS 2020 Premium (MS Store / Modern Install (Unencrypted exe)
Graphics Ultra Settings
Render scaling 115% / TAA / TLOD 230 / DX 12 / Full screen /

Radeon Settings
First off i recommend having the Radeon Software detect your game so you have an actual MSFS game profile and change the settings within that profile instead of trying to use the global settings.

Start the sim in full screen then once at the menu press Alt+R to bring up the radeon driver settings overlay and within the msfs profile settings enable fluid motion frames. ( the indicator light should turn green and it will also enable the optional anti lag toggle)

With the tech release drivers dated 10-3 which allows 6000 series for me fluid motion frames is available and can be verifiably enabled as in driver overlay reports the total frames rendered and the additional latency. It also shows a green indicator to show it is running when the sim is starting and the game profile for the driver is properly set up.

My initial experience
At first it was running but really choppy and uneven. But after enabling:
VRR Enabled via(windows graphics settings)
Freesync Enabled via (Actual Monitor setting and MSFS game profile within the Radeon Software)
Vsync + half refresh rate enabled within the sim the experience smoothed out considerably.

A few observations…
Your graphics card will be running at full tilt especially in the sim menu’s and if your PC cannot handle the resultant heat or power draw of the gpu you may not have optimal results. (A user on another forum said his pc just flat out turned off). With that in mind, I’m going to assume anyone willing to try a tech preview driver should have a properly stress tested system that can accommodate max gpu power draw and heat management when its running at max and is a little tech savvy.

The best experience ( for my system is to turn the anti lag feature in the radeon software off) It doesn’t reduce lag for me at all. Your mileage may vary with that though.

While i’m very happy with the results (very smooth for me) I have further testing to be done since i really don’t need my card to be screaming along at over 100 FPS in cruise.

I want to see what options i can use to hard lock the framerate because while turning on Vsync in game SUBSTANTIALLY improved the frame pacing and cleaned up the tearing it did not hard lock the framerate. I was still seeing up to 112 fps being reported in the overlay and i had set in game Vsync on with half monitor refresh rate so that it would max out at 50 real frames with 50 fake ones inserted for a 100fps cap. That didn’t happen (but the flight was smooth as silk). I suspect VRR was at work to allow this but it didn’t seem to work unless in game vsync is turned on.

So the two “hard lock options” ive been seeing are to either set the monitor refresh rate in windows under monitor options and see if a lower rate is available to select and use or use RTSS. From what i have been reading RTSS does not recognize the fake frames so if my monitor is capable of 100fps and i want to cap the frames to 50 fps with fluid motion frames running i would have to set RTSS to 25fps and those 25fps would be doubled with fluid motion frames to get to the “Lock or limit” at 50 fps

Will test and report when i get home. For me though this is a pretty nice feature that i’m going to permanently use until it gets incorporated within the sim.

Supplemental link about locking down the frames
https://www.reddit.com/r/Amd/comments/172gumq/amd_fluid_motion_frames_driver_how_do_we_limit/

POST TESTING EDIT
Option 1 of changing your windows monitor refresh rate in advanced settings does not work. Your GPU will still blow past the limit to 100% utilization.

Now Option two … RTSS … that worked a treat !!! If i locked the frames at 30 fps in RTSS and start the sim The Radeon software automatically kicks in, detects the sim, turns on Fluid motion Frames and wont go past 60 FPS. GPU is no longer maxing out even in the menus !!! Perfection !!!

1 Like

The way you have this set up seems to contradict the AMD messages about VSYNC, also, I run at 4K so I take it it’s no use me trying. What is VRR?
Seems like a lot of faf just to get the same frame rate as you get now?? Whats RTSS?
Cheers

AMD does not have any direct internal control of how a Game’s Vsync is implemented So when the in game Vsync is turned on they wont know what would happen unless they previously tested that specific game. In any case MSFS Vsync does not appear to be truly working (in DX12) with a hard frame rate lock as noted in my testing. It only improved frame pacing and reduced screen tearing.

It may seem like a lot of FAF to you but to people who actually know how to identify issues and test for potential solutions and what to turn on to improve their experience (like being on finals with a smooth VRR + Fluid Motion enabled 50 to 60 FPS on approach to a maxed out settings KJFK) it may be worth something to them. This is a tech preview driver after all … A lot of “faf” and testing is expected. Your value may vary.

VRR - Variable Refresh Rate | RTSS - Rivatuner Statistics Server

1 Like

So i cant get mine working. Is this because my monitor is not freesync enabled?
Apart from that i don’t see what’s different.
The FAF reference was reference as to why if you have 30 fps doubled to 60 and then cap this at 30 would this be a move forward?

However can you verify using the ALT R toggle to overlay the driver on top of MSFS that it is actually working? I get this error…

Try and change to full screen, although msfs doesn’t do reall full screen it may fix that…

Edit: I can confirm that switching to full screen does activate it…