Anti-Aliasing broken in VR after update

Interesting, what headset and runtime do you have?

I am using Quest 2, tried oculus and steamvr runtimes, and have definite new shimmering/aliasing on the menus (all the time) and trees and buildings (at medium/long distance). However the cockpit and aircraft (at standard external view distance, at least) look same as normal.

Yes but these are just the config values set in the game itself, but if you edit that file then it will change them in the game and vice versa. SSAO is ambient occlusion which can also help with 3d clarity.

Using Oculus Runtime. Cockpit dials and readouts and lettering are all clear and AA is working.

1 Like

I am using the HP reverb G2 and a RTX3070, I5 10th Gen and 32GB.
Crazy how poor the quality is actually… the only reason I’m motivated to keep VR is for the immersion, everything else is horrendous…
Any tips you have will be most welcome.
Currently 100 rendering in game and 80 in openxr

AA is also working fine for me everywhere except the menus. Inside the plane, outside the plane, the clouds… all look fine. But I can barely read the names of towns on my in-game map now, whereas before SU5 they were clear as day.

Not sure why you’re running the sim at 80 in OpenXR? That’ll be why your graphics look poor. I run at 100 render scale in-game and 1.0 SS on a 2060, most settings on medium, and I get good graphical quality and smooth performance most of the time. You should be able to do the same on 3070 surely?

Will try this when I get home, thanks.

Agreed - as I said the new issue we are describing, whatever it is, is apparent on further away buildings and trees (and the menus / overlays of course).

Those who do see the issue, you can vote for the devs to fix it here No AA anymore on menues in VR?

GTX 1080 overclocked / ryzen 5600x / 32gb ram / htc vive / steamvr

Just a few more observations since my post yesterday:

Even in 2D, the same shimmering happens on the horizontal lines of buildings (e.g. roofs) at mid- to long- range. Trees also have a strange contrast to them that makes them look like large pixels in certain lighting conditions; almost like they have a “glare” effect. Both effects are amplified in the headset due to screen proximity, resolution, etc. But the point is it’s not only in VR that this is happening on my rig-- but in the core graphics processing of the sim.

Additionally, in 2D I am now able to run full Ultra settings at 1080p, resolution upscaled to 110, while still maintaining 30fps with vsync enabled. This just… doesn’t make sense to me. The “ceiling” for graphics quality just shouldn’t be so low that a GTX 1080 can max all settings other than resolution.

The FACT is that something in the game is broken with this release, causing distinct image degradation for me and apparently plenty of other people in VR. I have checked all relevant settings and nothing has changed from pre-update.

I’m really glad that you don’t seem to have the issue, but please don’t assume that because you don’t that there is no issue. Whether it is AA or something else, the patch has changed something which is causing a degraded experience for some seemingly significant subset of VR users.

6 Likes

For me cockpit sharp cannot get good sharp scenery. Something very wrong high level of pd do not help .rift s pd 1.8 3090 rtx an scaling at 80. Asw 30 very smooth just blurry and washed out.

To make sure we are comparing fixed conditions, next time you are in the sim can you try the Rio landing challenge? I have the shimmering/aliasing most obvious on the buildings towards the sun. Maybe it is to do with reflections as it does always seem worse towards the sun. If you don’t have it then indeed there must be something different between your configuration and ours.

I will, although I don’t know how to fly an Airbus so there could be some tragedy in our future.

You’re missing the point. There is nothing special about my install, nothing at all. There is no voodoo, no trick, no setting, no magic. My system is normal. Investigating the issue on your own system is the best way to solve the problem because it’s highly unlikely that any fix is going to come from Asobo if there is no problem they can actually identify and frustration will abound for all eternity.

Well, I’m in the process of playing the re-tweak everything game, and thus far nothing has given me the balance of image quality and performance I had before the update. And like you, there is nothing special about my install or system.

They obviously changed something in the sim that has essentially broken it for me. I’ll keep messing with settings (instead of flying) in hopes of regaining some of what I had pre-update, but my real hope is that enough other folks in my boat will squeal loud enough so that Asobo does work to identify and fix the problem.

Again, just because you are not experiencing any issues does not mean that there aren’t any. Whether differences in hardware, drivers, etc. are ultimately at the root of it, the simple truth is that something Asobo did in SU5 has caused new issues for me and many other VR users. If they are going to mess with things that could be responsible for configuration-specific problems then they should at least make an effort to warn us, and suggest configuration changes that could help mitigate them.

1 Like

I totally second this!

1 Like

just did this, I see no issues in the graphics, especially not with AA as this would be very obvious. I use a OQ2.

1 Like

10900K + 6800XT + Reverb G2 user here.

The VR graphic has gotten so bad on this update that I’ve lost all desire to fly anymore. The Antialiasing is not working or has degraded so badly that the trees and buildings are just a glob of shimmer, menus are plagued with jagged lines, and the color has been so washed out that I cannot even see the PAPI lights until I am on the runway.

100 render scale in SU5 is about the quality of 70 in SU4. What they’ve done is instead of optimizing the code and the multithread, reduced the graphics quality to a point where the sim is flyable at 30fps for XBOX, and called it an optimization.

I was really hoping that XBOX release would push the sim to the next level. Instead, it’s going backwards to make room for XBOX platform. Really sad!

9 Likes

Same here, AA Broken, at least in menus. Ctd every 10 minutes and empty cities and airports… Disaster.

Interesting. I just tried with both the G2 and the Quest 2 just to be sure (also, Reflections OFF, no add-ons installed, fresh install post hotfix):
When the Rio landing challenge starts (I am also not an airliner pilot, so many victims each time):

  • buildings in the sun are shimmering due to the antialiasing (to the left, close to us)
  • the bridge crossing the bay is a shimmering jagged mess especially in the sun
  • some of the shore line decks and peers are the same
  • The white bars at the top of the glass cockpit display (within the display) are jagged, shimmering as I move my head

When turning on final:

  • to my left there is an orange-ish building (right in front of a peer) is a shimmering mess, I can infer it’s supposed to have lots of horizontal lines/window rows, but all I see are jagged lines shimmering diagonally, like moiré
  • the peninsula covered in trees front left of the runway is a jagged, shimmering mess until I get closer
  • The bridge to the left of the runway, crossing to the mainland is a jagged shimmering mess
  • The coastline beyond the airport and to the left is a very aliased line (not so shimmering)
  • The airport buildings to the right of the runway are a shimmering mess
  • The antenna array at the start of the runway is a jagged, shimmering mess (and it doesn’t seem to be due to the sun)
  • Ditto for the light poles to the right of the runway

You don’t see any of that? At all?

I’m using maximum Q2 resolution in the Oculus app and 90 in the sim, and for the G2 I’m at 130 in OpenXR and 90 in the sim. 5800x/32GB/RTX3080Ti system.

If for you everything looks peachy without any of that shimmering, it sounds like maybe one of the GPU control center settings could be the cause. I will investigate that. Thanks for the input!

1 Like

CptLucky, are you suggesting that the shimmering is happening because we have the in game render scale <100 ?
Thanks!

There seems to be 2 different problems:

  • menus: this has nothing to do with the game AA because these are most likely VR overlays. However it is possible SU5 is using a lower resolution image for them and this shows some aliasing, but I doubt it, or maybe they are using the wrong XrCompositionLayerFlagBits values, or it is a bug in the latest OXR driver updates (but this would be affecting SteamVR, Oculus, WMR at the same time?)

  • game: the “shimmering” you’re seeing is maybe due to the sun reflection accentuating the bright/dark regions, I really don’t know.

Just speculating here. Eventually, try changing your NVidia CPL setting Texture Filtering Negaive LOD Bias for FS2020 from CLAMP to ALLOW?