Any issues? Windows 11 Preview + MSFS 2020 w/ July 27 Performance Update

Has anybody tried Windows 11 Preview with MSFS 2020 (w/ July 27 Performance Update)?
If yes, any issues that can prevent the use of MSFS 2020 ?

Your thoughts will be helpful. Thank you in advance

1 Like

Just upgraded to 11 today now that it’s in the Beta channel. MSFS ran perfectly fine, don’t have any benchmarks but everything felt as good or better. FPS were the same but the occasional stutters I got used to, like when switching to an external view for the first time, were gone.

Overall I’m very happy, sim is working fine and windows itself feels a lot smoother overall.

I9-9900K/RTX 2080/32GB/2x1TB NVMe

1 Like

Nice. I also upgraded to Windows 11. Works great. No issues.

1 Like

No issues for me either. I’m getting used to Win 11 now.

1 Like

I have been using the recent build(s) with Windows 11 for a while, no OS/MSFS stability issues to report that are specific to Windows 11.

If anyone who sees this wants to upgrade your OS, I highly recommend you do a fresh install.

1 Like

Is it possible to do a fresh install of Windows 11 now?

What I needed to do before was to fresh install Windows 10 21H1 version, then immediately join the Insider and updgrade to Windows 11. I couldn’t find the ISO file for the Windows 11 version to do a fresh install directly at the time.

Not quite, I should call it a “close to fresh install”. I used “Reset this PC” to wipe my drive and reinstall Windows 10. Once done, I then upgraded to Windows 11 using the insider program.

1 Like

Today I realized that all is not well with Win 11 and MSFS 2020. :frowning:

When I started FS 2020, it froze. Later when I re-started the simulator again, it asked me to install Mandatory Update. When I click OK, it doesn’t take me to Game in store. Searching the ‘Preview’ version of Microsoft Store couldn’t find MSFS 2020. Later I found it in XBox App, which shows as installed. But, starting the game has same issue.

Looks like I am stuck until it’s fixed. :frowning:


Quick update: When I go to game section, it shows and also says you own it and that system meets the requirements. But no option to install. Not sure what I may be missing.

Quick Update: LoL. Now found in search without using Microsoft and it now show Play button but nothing to update etc. I am still confused how this store works.

Have you tried opening the Windows 11 Xbox app? I think you can install it from there.

It only show “Uninstall” option. There is no update. Let me re-install.

Isn’t it automatic though? I’m not sure about the store version, mine is through Steam and it automatically updates for me.

Game was totally up-to date with Jul 27 performance pack and additional package updates.

It suddenly started asking for update after I did an additional Windows update (i.e. post Windows 11 Preview install). Seems like something must have gone corrupt before or after that.

Anyways, now waiting for 127GB of data to be installed. :slight_smile: Hopefully should be done by EOD.

did you uninstalled it and re-install the setup?

Yes. That fixed the issue.

I also did the same. Thanks

Just for future reference, you don’t need to re-download the whole 100+ GB next time. Just rename that folder to something else before uninstalling so it doesn’t get deleted then change it back after reinstalling the 1 GB app. Then when you run the sim, point it to that folder again when it’s wanting to start the big d/l. It’ll recognize all the files are there and will continue on.

That worked for me earlier, after messing around for hours trying to get it updated on Win 11 it took like 10 minutes just to uninstall/reinstall this way.


No CTD´s or something, but nice increase of performance.
The only thing is - Before the update i was able to listen to youtube music, now after the update the music suddenly stops and goes on only when i click into the chrome browser. As long as i am active in the Sim with the mouse, no music plays. Only when i click there. Strange

I had Win 11 but could not get the hotfix to load. I got the “There’s a mandatory update”. But both Microsoft Store, and Xbox app, only allowed “Play”. No update.

I rolled back Win 11, to Win 10, and when starting the game again, the update happened automatically in the game. So there’s an issue there. Not sure if I can go back to Win 11 now. But Win 11 to Win 10 is very easy.

Probably something to do with how the store app works. Usually by opening the app in the store it would “kickstart” the update.