Apparently 200% render scale in PC settings does wonders for VR performance

The zoom of the compass is zoomed in more on the left picture, can you show the same picture where the picture is zoomed in to an equal level?

@NRosko, I mean no disrespect by saying this, but no. Those pics were carefully setup and frankly, kind of a PITA to do, and I even posted further in the thread another couple of shots that are even more definitive. If I stumble across some more photos that go to prove my point, I may share those, but in my mind, my point is proved and I’m not spending any more time trying to convince people.

They either get it or they don’t, either way it’s of zero consequence to me. Sorry.

Kev

1 Like

Hi there, i saw a significant increase in frame rate with this “200” trick at first. And then i found out that it should be something else! I think it must be the VSync Option in PC settings!
Try it out: start your VR session (i start in 2d and then start VR on Runway), then go to Graphics Options, change to PC, set the VSync to On with 60 fps, Apply that. After that, set PC VSync to Off and Apply that. Thats it! But i think you have to do it every time you start VR. With this method i can use 100% OXR and 100% TAA with the CTSL Ultralight in the nordics landing challenge. This with Reverb G2, no Motion Interpolation. Really smooth and this smoothness increases the visual quality, but for me not the visuals. Clouds Ultra, Textures Ultra.

PC: MSI B550-A Pro, Ryzen 5800X (no OC), 32GB Ram
HMD: Reverb G2 (only working on front USB, but good there)
GPU: Msi 3070ti Suprim X
Monitor: Dell WQHD

I think with this method it should perhaps be faster to lower all PC Render settings to the minimum possible (perhaps except the Texture Resolution, because the textures would be loaded two times perhaps). I set render resolution PC to 30%, this changes nothing for me in the HMD.
I also tried lowering the Screen Resolution of PC (1280x720), but i think this did not help. But i saw a significant decrease of the Airport description Texts in the HMD, but nothing else was degraded in HMD.

In my understanding the monitor must be rendered and also the HMD, you see that for example the menu will only be shown in the HMD and not on the monitor. So i think lowering the visual quality on monitor could speed up the HMD.
I also saw a big increase in consumed power (i had a power meter on the PC), with the vsync trick it had a peak power of 380W, compared to 200 if i remember correctly without it! I can also hear the increased power.

Hope this helps,
Thomas

P.S. just bought this PC only for FS2020 in VR - and i like it!

Kev - thanks for your posts and contributions so far! I Suppose that other people WOULD dowload the beta and test, would they be allowed to share results/info? Or is there an non-disclosure on every beta that is released?

I’m not running the beta. This is all SU4. But I think it would be covered by an NDA if I was on SU5 beta.

This is because these are using a dedicated VR only API for presenting popup textured quads into the VR view (overlays).

It is because they are independent of the whole frame rendering, that I suggested using these for higher legibility of the EFIS screens among other things:

[BUG/FEATURE] EFIS Screens Problems and Solutions for higher legibility - Virtual Reality (VR) / VR Wishlist - Microsoft Flight Simulator Forums

This would let you use lower rendering settings for the outside view with higher res popup overlays in-lieu of the EFIS screens VC polygons. This would also decouple the sync between the whole frame rendering and the EFIS rendering which can in some cases open up other optimization opportunities.

It’s funny you talked about the vsync. For me it’s the second 2D parameter which is “corrupted” by a VR session. Each time I play VR, if I quit the Sim from VR through the main menu, the vsync is turned off next time I launch the sim (and my 2D Render Scale is made equal to VR Render Scaling, but I said that here a thousand times).

Saying that I’ll try what you said, I remember vsync was a problem at the very beginning of MSFS in VR and created stutters in VR. Possibly why it’s forced turned OFF in my configuration at least.

Thanks for your input!

Anyone tested this in SU5 yet?

I didn’t see this thread until now but it doesn’t appear to work for me with a Quest2 and a GTX1080.

Would like to know if I’m wasting me time trying to get it to work. Thanks.

2 Likes

good question :wink:

It may be too soon to tell, but with a survey size of one (that would be me), talking specifically about a night flight (which could influence the results), it appears not only does it not help, it might just hurt. Of course, that makes just about as much sense as "the trick"™ working in the first place!

Given I had such good results with you, you know I was going to try it, and at first I just thought, “Dad gummit, this just don’t werk like it ust ta!”. I had that old, familiar feeling of it being slightly blurred, like before "the trick"™ was discovered when VR looked almost like I needed glasses that, sadly, I had forgotten at home.

But then @LooseCannon08 and @MasterlySloth45 had to go and ask, so I specifically went out of my way to turn the PC setting to 100 while VR was still off, and turned it back on to see if there was a change.

There was.

It was like someone gave me my glasses back.

Again, this was at night, in a tubeliner, so perhaps some others might want to give it a go under differing conditions and give their opinion, but I ain’t taking any pictures to try to prove myself this time around. (Famous last words, no?)

Kev

2 Likes

Legend!

1 Like

I tried it yesterday night, and can no longer say if I can notice the difference.
Not saying that it doesn’t work anymore, but at this moment I can’t tell for sure.
Did a flight on Monterey, CA yesterday twice, first with Render Scale at 100 and second with Render Scale at 200.
No change on performance, but I still see more clearly when on 200, but for now I’m starting to believe that it is a placebo effect on SU5…
PS. before this update the difference was night and day for me.

1 Like

They completely changed the way the settings variables appear in the UserCfg.opt file. Before they had the same variable names for both 2D and VR render scale settings in each section for 2D and VR, and now all appear at the bottom on the file in the video section. So I guess they fixed some problems here.

Saying that, I was able to reproduce the bug where the 2D vsync is disabled after playing a VR session…

Start of the new UserCfg.opt file:

Version 66
{Video
Adapter “NVIDIA GeForce RTX 3070”
Monitor 0
Windowed 1
FullscreenBorderless 1
Resolution 1920 1080
FullScreenResolution 1920 1080
PrimaryScaling 1.000000
SecondaryScaling 1.000000
PrimaryScalingVR 0.700000
SecondaryScalingVR 1.000000
VSync 1
HDR10 0
Raytracing 0
PosX 300
PosY 140
}

EDIT : Have you noted the Raytracing variable?

2 Likes

Thanks, but you forgot the “in my own mind” part…

:crazy_face:

Kev

1 Like

Good news Kev, finally got MSFS downloaded after deleting windows and reinstalling everything from a clean disk, What a joke. I saw someone on another forum suggest this as they said the messy way MSFS instals itself leads to registry corruptions and un removable system files.

1 Like

Hey, thanks for insight. What other settings do you have in the game? I am the HP reverb G2 and the clarity sucks. If I am on the ground next to an aircraft, its slightly blurry, The tress are a tad blurry, nothings sharp!
Any suggestions?

So whats the consensus so far? Does the 200% trick still work? I tried it but im not too sure… The new visuals are so messed up anyway.

I also feel like it decreases VR performance now when PC render scale is on 200??

I’m struggling to see a difference, overall similar to you my attention is more drawn to the lower visual quality overall in VR.

Hard to see if quality is better when view overall is now best described as fuzzy, need to confirm also whether this a server issue, so might take a few days of things to settle down, fingers crossed

2 Likes

I swear that shimmering/jagged lines on buildings is the worst. It just loses all semblancr of realism. We need +2 generation of hardware at least so we can crank up all the render scalings/supersample and still get acceptable fps. I really hope they fix something

I read this afternoon that turning reflections off might help with the shimmering but I haven’t tried it yet