Application hangs when loading a flight "Fly"

For some strange reason the app hangs when trying to load a basic flight at any airport. Everything loads fine quickly (check for updates no problem) when I hit “FLY” it goes well to 3/4 ways and hangs, FPS goes from 125 to 2 FPS and stays RED and just sits there forever.

Finally I got a message stating “Your Packages are out of Date” and I should return to the Sign In screen and go online. The issue is I am already signed in and online and there were no updates pending.

When I went in to Microsoft store there were two sets of MSFS 2020 in the store in my account.
One set said 'Ready to Update" (when I hit update nothing happens); and another set said 'Modified 11/18/21" which is the date it was installed. The 'Ready to Update" ones I think were a result of an issue on the initial install and they weren’t deleted.

Regardless, everything was working fine the way it is until today so maybe the number MSFS apps in the store may not be causing the issue. Not sure, since it has always been like that.
I did absolutely nothing, I have no addons and no new updates (my Community folder is empty). I only got that message once during the 6 times I have been trying to launch it today.

The interesting thing is during the process the system usage is negligible (CPU 15%; GPU .09%) so I know it’s not my new hardware causing the issue.
I tried launching the App from the one in the Microsoft Store instead of my regular icon on my PC, but the same issue.
I am on verson so I am up to date. I am totally at a lost.

Any help that anyone can provide would be greatly appreciated.


Kindest Regards.

Moderator Edit:
The same thing happens to me. Yesterday I reinstalled the game and the problem continues.
I’m also lost.

A mi me pasa lo mismo. Ayer volvi a instalar el juego y el problema continua.
Tambien estoy perdido.

Moderator Edit:
If you can find the solution, please share it with me. Thank you very much in advance.
Best regards

Si consigues encontrar la solucion, por favor me la compartes. Muchas gracias de antemano.
Cordial saludo

Yeah, I am at a total loss as to what’s going on. The only thing that changed when this problem started was a Windows 10 update on 8th Dec (Feature update to Windows 10, version 21H2) so not sure if that would have caused the problem.

It is really getting frustrating for me since a have an IT background and still can’t determine what’s going on. I have tried everything short of un-installing and then doing a clean install since I am not sure if that will work. Haven’t worked for you AndresBacha.

My PC in less than 1 month old so there are no add-ons that could cause the problem. I will continue to think of what else to check also hopefully someone out there can provide any feedback. :slightly_smiling_face:


We’re having the exact same problem. Does not matter the location from within the application which we choose to “fly.” We have completely uninstalled both MSFS2020 and Steam (on PC), deleted all Roaming Cache, removed all Steam files. Reinstalled both, actually downloading and installing to a completely separate PC and porting over the game files. Problem persists. Started 2 days ago, running version Running Windows 10 Pro with AMD 3600, 1080Ti, etc etc. Tried both DX 11 and 12. Video drivers remain unchanged (457.30) ​as issue first presented itself.

1 Like

Sera que seguimos todos sin encontrar la solucion a esto ?
Llevo 4 dias sin poder volar !!!


Yes, it is very frustrating, since so many individuals are having exactly the same problem starting about the same time, and MS “boiler plate” procedures aren’t working. Something changed on Microsoft end that affected the process.

I wish there was more information and suggestion from MS about addressing this issue. What is frustrating for me and for others I assume, is that my PC is brand new so is MSFS 2020 just loaded it less than a month ago and I have never added any addons and or any upgrades, so I have nothing to undo and or change. The only thing I did was a windows update on the 8th to make sure I am up to date just in case.

It is a little concerning that I paid over $100.00 for the product and I was only able to use it for 3 days before I experienced the problem. It’s not about the money I just want to fly. I left behind my FSX and P3D on my older PC and bought this new gaming PC to move on.

Hopefully we hear something that would address this issue.

Kindest Regards.

Check that your Xbox App for WIndows is updated and that you are logged in there.

Yes, already tried that. All updated and I am always logged in.


I still grounded… not able to get this working since it hangs when load the flight “Fly”. Cleanup my windows, did all updates, cleanup the MSFS application, reinstalled few times, and still in the same for the last 5-6 days. Please, please, please I need help and support! Thanks!

Welcome to the forum mbpr62;

Yes, this has been a big issue for lots of individual and it seems that there really hasn’t been any type of solution thus far from MS. I have an IT background and like you I have tried everything (short of uninstalling and reinstalling) and still no luck. It seems that files may be out of sync and or file corruption at the MS Store end.

I logged a ticket with MS Support (Zendesk) and have attached files showing the status of my MS 2020 files in the MS Store which may trigger something on their end that I couldn’t see. I also attached snapshots of detail activities of my system and the app during the hanging process. It’s their application and infrastructure so they should be able to provide some level of feedback on what’s really going on, at least one would hope so.

Waiting to hear back from them.


Has anyone found a solution to this? If so, please share. Thanks.

I have not as yet. Still awaiting a response from Microsoft Support. Very frustrating since I have spent more time troubleshooting than flying.


1 Like

Hello Folks;

I took a snapshot of the FS activities during the “Hanging process” just to get an idea of what’s going on at the time. Since I am not quite versed on exactly what goes on when the “Fly” is initiated I really can’t tell if those activities are normal. It seems as there is a lot of disk and network activities going on but nothing happening.

The interesting thing is my PC is pretty much idle during all of this; with CPU usage topped at 20% for 1 or 2 seconds, GPU is 0.05 % (fans are idle) and memory very small. And lots of time FS.exe stated “Not responding”

Again, not sure if this is an indication of what the root cause of the problem might be or this might be the normal process. Anyone familiar with the process and can take a look at this and maybe spot something that’s unusual and or a concern.

Thanks again.

Same error here as well… Tried everything and ended up with uninstall and reinstall 2-3 times. Updated drivers and pc. Nope…
Xbox App updated, uninstalled and reinstalled… Nope.
Microsoft Store app updated, uninstalled and reinstalled… Nope.
Everytime I click FLY, it loads about 2/3 and hangs / Freeze.

1 Like

Well, this is what I did… and it is working now…

  • Disable the Avast AV
  • Re-install the MSFS

In my case, I found that the Avast was affecting the application.

December 22/2021. as of Ver, still stalls at 60-75% flight loads but has now started to crash upon clicking the ‘FLY’ button. Nothing seems to fix this fault? I’ve tried everything: a complete reinstallation, language version, all addons inc community objects and models, internet connections (constantly tells me there’s a issue with the online bandwidth - there ISN’T!!), server location, game configuration. DirectX versions (?), hardware etc, etc. So much time & money wasted. Does anyone have any fix for this kinda fault?
Many thanks.


Do you have an Nvidia graphics card? If so, one of the latest driver versions (497.09) is known to cause issues with MSFS. A newer driver has now been released that seems to fix the issues for most users, so I’d suggest making sure you’re up to date (497.29).

Yes, thank you. Nvidia 497.29 installed. No difference. :frowning:

Try checking the windows event viewer logs as described here:
Once you’ve opened that if you see any red errors on the application tab that relate to MSFS, click on it once to open the details and check the ‘faulting module name’ and ‘error code’. It may give a clue as to what is causing the issue

1 Like