ATC cleareance from FP doesn`t appear aftes SU7 (FBW A320)

Are you on Steam or Microsoft Store version?
Microsoft Store
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
Since SU7 I’m no longer able to request an IFR clearance from ATC menu even the flight plan is correctly defined into MCDU (got if from Simbrief). Before the update it worked fine.

Detail steps to reproduce the issue encountered:
Im defining into FBW A32NX into MCDU ( by syncing from Simbrief ) and then i want get IFR clearenace from ATU menu but that option is not available there (looks like the VFR mode is available only - im able to depart in any direction)

Build Version # when you first started experiencing this issue:
SU7 + latest FBW development version

@HollowManPL5849 I have moved this to the correct area of the forums.

I am pretty sure someone will chip in with a solution.

Same issue here. ATC window got broken for IFR plans in SU7. Mouse selection doesn’t work, only working solution is to use keyboard keys (1, 2, 3 etc) while window is closed.

In VR is even worse, as this ATC window is able to freeze other interactions in the cockpit.

@HollowManPL5849 I have just installed the latest dev version of FBW A320 and am able to get an IFR clearance from ATC for a flight plan imported from SimBrief.

Before loading your flight plan into the MCDU it is worth checking on the EFB that the option to Sync MSFS flight plan is set to “save”


Hopefully this corrects the issue you may have been having.

2 Likes

Hi , thaks for that - definitelly you solved my problem . Currently IFR clearence option is visible as expected.
Really apprceiate that.
Cheers,
HM

1 Like

Yes, these kind of new bugs ruined my weekend. Sit and set up flight plans with Navigraph for FBW A32NX, then get into cockpit and only got clearance from Center (altitude and squawk code), and then it let me get back to airport ATC, but must manually choose runway for departure, no ground services, no Pushback request, no instructions or whatever…

Very frustrated and waste of players time with all new bugs from SU7.

Hopefully this corrects the issue you may have been having.

Your solution is just a temporary workaround if it really works, obviously ATC does not work properly as it should be before SU7.

Not only problem with FBW A32NX, when flying with GA airplanes, I don’t get informed by aiport ATC when I get out of their airspace. All these only happened since SU7.

Oddly enough, this does not work for me. (Development version)
With the setting on “save” as per the solution, i can invoke Simbrief through MCDU but ATC wont show any signs of IFR clearance.
The best i could come up with is to put the setting to “none” and load flight plan in the MSFS world map. I then have ATC and can still import simbrief as usual. But the ATC will not react to any flight plan changes in MCDU.

Any tips appreciated

Edit
After today’s update, it works as intended !
This plane is excellent and fbw team is very professionnal.

1 Like

Upss…it`s happening again after last 1.21.18.0 update.
Once i installed the udpate i cant see the option in ATC (after initialization flight plan from Simbrief into MSDU)
Has anyone encountered same issue ?
Cheers,
HM

I’d say that Simbrief integration works from time to time (seems like somtimes it does not “click” even though all goes ok).
If this happens and is not solved by restarts, i input the whole FP and all that is needed by hand and then it works…wierd.

Experimental version

Tested on either experimental or dev.
Ive just noticed that it depends on the airport im going to departure
I selected another one and seems to get worked even if the airport 3 times smaller then EKCH :slight_smile: (i have an issue with) …as you said …really wierd…but im 100% sure it started occuring me from the moment when ive updated MSFS to 1.21.18.0
Cheers,

It doesn’t sync with me after update 1.21.18.0 (worked before). So no clearances from ATC after editing the FP on the MCDU

Not sure, but maybe this thread is related?

Try a wait a little bit - FP clearance seems to visible in ATC after few minutes …maybe its a co-incidence but often it`s starting apearing once i request for example jetway connection…weird but since my last response on that topic I havent faced that issue again.

I get the initial clearance. But in flight it doesn’t give me an approach anymore.