ATC Does Not Give Vectors

I noted during the recent developer Q&A that there are big picture plans to improve ATC, which is great. There are many specific topics out there, but I do not see a specific bug report about the complete lack of vectors. I apologize if this is duplicated elsewhere, but I couldn’t find it!

In a variety of scenarios, ATC should be giving vectors. In a lot of cases, the ATC even says or assumes that vectors will be coming, but it never gives them. It’s possible to ask for vectors to the next waypoint, but that’s clunky at best.

The most obvious way to get the issue is to request a visual approach. ATC will tell me to expect vectors, but doesn’t really provide them. Similar issues can occur when requesting vectors to final, so I always instead request a full instrument procedure even though that’s unusual in the real world.

A less common way to see the issue is with certain SIDs and STARs that call for vectors. The other day, I flew the LIHUE SIX SID from PHLI: https://skyvector.com/files/tpp/2304/pdf/00776LIHUE.PDF

It calls for radar vectors to intercept a point. I never got those vectors until I started manually asking for vectors to the next waypoint (the PMDG 737 entered the SID correctly).

Hopefully, this sort of thing will be part of the big ATC fix, but I wanted to make sure these issues were documented to be a part of that fix. Thanks, everyone!

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

Not applicable

Brief description of the issue:

ATC does not give any vectors during various phases of flight, especially for a visual approach or vectors to final

Provide Screenshot(s)/video(s) of the issue encountered:

Not applicable

Detailed steps to reproduce the issue encountered:

Have ATC assign a visual approach or an approach with vectors to final.

PC specs and/or peripheral set up if relevant:

No applicable.

Build Version # when you first started experiencing this issue:

Since the beginning.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

I get this consistently on IFR when assigned visual approaches. Once the approach is assigned, you can ask for vectors and they’ll give you back a heading but when it’s time to turn they won’t break in to give you the next vector – you have to just keep asking for the current vector over and over and over until it changes.

If relevant, provide additional screenshots/video:

2 Likes

Another aspect of the issue is that whatever vectors are available (by manually requesting them) do not seem to correlate to altitude. Sometimes, a vector call will send the pilot seemingly in circles because the altitude isn’t yet established.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes. ATC does not give vectors for a visual approach but tells you it will. You keep flying, passing the airfield and beyond and no more word from ATC.
When i request visual, last thing i hear from ATC is similar to this: “Reamain current altitude and heading, expect vectors for visual”.

The “request vectors to next waypoint” button doesn’t help either (it keeps telling me to remain alt and hdg, even if i’m way to close to the airport and should have started decend and change heading long time ago) in my case and shoudn’t be neccessary - ATC needs to be proactive, not me.

May be this could be of help: Last time i tested this, ATC said expect vectory visual, then nothing, i passed the airfield and then slewed my plane (320neo) backwards till the airfield was in sight again. During this slewing ATC said i should decend to 2000 feet, but still no heading command. So the functionality is somewhat there but seems not to be triggered or something… Just a thought…

And this is just one bug of many showstopper-class bugs reported in the ATC forum - i don’t know what happened here, but ATC was WAY better and more reliable in FSX imo.

Please Asobo do something about the ATC, this is a real letdown, especially for a next gen sim like this, which is stellar in so many aspects and really kills immersion not only for more dedicated simmers (they probably use vatsim or external ATC anyways) but especially for average simmers like me, who like basic ATC guidance for immersion and fun.

Provide extra information to complete the original description of the issue:

I independent of the used aircraft.
I do not use any addons, the sim is vanilla.
Happens with Azure and offline voices.

If relevant, provide additional screenshots/video:

Hopefully, this is something that can be rolled into MSFS 2024 if not before!

I don’t understand how it is that we could get vectors in FSX what nine years ago but FS2020 is unable to do the same job. Aggravating.

1 Like

Still no activity on this :frowning:

can we at least get an response as to if this is going to be addressed in MSFS2020, or put off till any new ATC system in 2024.

If its NOT going to be fixed, please just say so Asobo, and then at least we will know what to expect, and stop wasting time reporting this as a Bug, or trying to make any sense of of the whole “asking ATC for Vector” part of the simulator.

Its not so much the BUG that is frustrating (although it is ), but the total lack of response from Asobo about this situation.

Bugged Logged is all well and good, but in reality, it COULD stay logged for years, for all we are told.

To me the cause & correction seems pretty obvious.

(1) The Vector is calculated when one files a flight plan, but that heading is never updated, despite flying along the Flight Play waypoints

(2) Even when it is calculated, it is calculated as the Past waypoint to next waypoint heading, and NOT the Current Position to next waypoint heading.

Note: The Vector waypoint names ARE updated, just not the correct heading. (although they sometimes get STUCK, and then do not update either)

VERY FRUSTRATING as a simulator – but “who cares” as a Flying Game, so I conclude we now know what MSFS is.

1 Like

Here is a documented example of ATC not updating the VECTOR heading, as it gives vectors to a series of waypoint (not in line)

v1

v2

v3

IN all cases, ATC gave the SAME vector heading of 165 degrees, to all the waypoints.

At least, this should be fixable – and while at it, the VECTOR SHOULD be from the plane’s CURRENT POSITION, to the Next Waypoint, not the heading between the two waypoints. !!! {sigh}

==========
Also show clearly is Approach handing off to tower some 14 miles out, before vectoring and ensuring that the IFR plane was established on the ILS, before handing off to TOWER (who should never be giving an clearance to intercept an ILS !!) Tower is not allowed to VECTOR planes to an ILS – the most they can do is to to suggest headings based on a visual observation of the plane’s position – difficult to see at 14 miles !

It’s just all so WRONG & Clueless !!!

2 Likes

ATC also does not see to have a clue what flight parameters a given plane has.

ie A C172’s maximum ceiling !!

CESSNA 22C, Please expedite your climb FL210


ATC does not needs to issue a 250 knot speed restriction to a C172 !!

Yes, but this is not the thread for that.

Let’s focus on vectors only in here.

OK, but I will be really surprised if there are any significant fixes to Vectors in SU14. - there certainly are not in the current SU14 beta :frowning:

Latest SU14 beta( 12/2/2023) has a small improvement to Vectors, but its still not working correctly.

see

Maybe the "BUG LOGGED should be updated ??

A picture is worth 1000 Words, and a Video is even better !!

So here is a Video, just releaed this morning, demonstrating some of the ATC Vectors issues, and a few other GOOD & not so good things, that are still with us in SU14 Beta.

So sit back, get a cup of Coffee, and relax, watching someone else struggle with MSFS !!

(Its amazing how quickly an HOUR can pass when IMMERSED in MSFS )

Please IGNORE the phone conversation in the audio background – TRUST ME, its not of any interest to you, or is it confidential

I got lost trying to keep up with him.
Your points are valid , I assume but have no real knowledge to judge.

(Low knowledge/experience level armchair simmer here.)

But, there seems to be a real difference in the ATC Flight Plan, as filed, and the airplanes Flight Plan and the airplanes flight.

ATC seems to have no knowledge of where you are going and
your heading, with AP or not.
It tracks your reaching its waypoints in its Flight Plan and
has no idea of how you get to its waypoints.

Thus, it cannot give you a vector from your location to the next waypoint.
ATC doesn’t know where you are.

ATC can only give you a vector from its last waypoint that you reached to its next waypoint.

If you are not flying the Flight Plan you filed, then you are in trouble.
ATC cannot help you.
You have to get yourself back on the Flight Plan.

That does not make total sense. Your SIM knows, and ATC is part of your sim. So of course ATC “COULD” know where you are in the SIM (as ATC knows where you are in the RW with Radar).

Much of ATC is knowing where you are to know what to do next .

ie It know when you have taxied to a Hold Short point, and its time to talk to tower.

In the video example, at one point I still had an active leg (magenta line), but ATC, clearly knew where I was, and vectored me onto the next leg, as I was off course, and closer to the next leg, than the previous “active Leg”.

Maybe the issue is, there is no USER documentation, that lays out what MSFS is Trying to do, so it is all Guesswork from the Users, based on what they

  • have seen in other sims
  • have seen in the RW
  • have seen in MSFS

but there is no written description of what MSFS is meant to do (ie has been “Designed” to do")

– Its all Guesses and assumptions, so how can a user really comment on what is a bug, or is by design, without such information ?

Maybe the GAME side of MSFS, in reality, is trying to figure out what is happening in the “MSFS World” , as opposed to a Flight Simulator, aiming to simulate the real world.

MFFS QUEST
“you are flying in a plane at 4000ft, 10 miles for your destination – what do you do next” ?

1 Like

Its’ pretty much a give now, that If you change your FP in your GPS, and then ask for another clearance, then ATC know, and give you a new clearance to match your current GPS flight plan.

ie MSFS ATC has a tracker virus installed in your GPS :rofl:

So, that’s why when I asked for a new clearance, ATC gave me the filed clearance.

I had not changed the FMS Flight Plan.

Thanks…

Correct, to make it very obvious, change the Destination airport, and then ask again for a clearance, The new clearance will be to the amended destination airport,

Okay, I was just going to reply to you that I changed the Longitude’s
Flight Plan in the FMS but ATC did not change its plan
to match mine.

But, I didn’t change the Destination airport.
Just changed to a further waypoint on the plan.

I don’t remember now but I think the ATC prompt said something to the effect of “request change in flight plan” and not in Destination.